summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-09-21 12:09:04 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-09-21 12:09:04 +0000
commit303d4362247a8465565fee9e77f0dc0df0966932 (patch)
treeea6791503fbc69f7c079719d7b8e1f480923ef6d /dev-tex
parentversion bump (diff)
downloadgentoo-2-303d4362247a8465565fee9e77f0dc0df0966932.tar.gz
gentoo-2-303d4362247a8465565fee9e77f0dc0df0966932.tar.bz2
gentoo-2-303d4362247a8465565fee9e77f0dc0df0966932.zip
version bump
(Portage version: 2.2.0_alpha130/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/chktex/ChangeLog8
-rw-r--r--dev-tex/chktex/chktex-1.7.1.ebuild51
-rw-r--r--dev-tex/chktex/files/chktex-1.7.1-asneeded.patch13
3 files changed, 71 insertions, 1 deletions
diff --git a/dev-tex/chktex/ChangeLog b/dev-tex/chktex/ChangeLog
index a44d90973fca..abb1bde65b0b 100644
--- a/dev-tex/chktex/ChangeLog
+++ b/dev-tex/chktex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tex/chktex
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/chktex/ChangeLog,v 1.42 2012/06/22 15:42:23 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/chktex/ChangeLog,v 1.43 2012/09/21 12:09:04 aballier Exp $
+
+*chktex-1.7.1 (21 Sep 2012)
+
+ 21 Sep 2012; Alexis Ballier <aballier@gentoo.org> +chktex-1.7.1.ebuild,
+ +files/chktex-1.7.1-asneeded.patch:
+ version bump
22 Jun 2012; Alexis Ballier <aballier@gentoo.org> chktex-1.7.0.ebuild:
perl is a runtime dep too
diff --git a/dev-tex/chktex/chktex-1.7.1.ebuild b/dev-tex/chktex/chktex-1.7.1.ebuild
new file mode 100644
index 000000000000..b9d6e3490804
--- /dev/null
+++ b/dev-tex/chktex/chktex-1.7.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/chktex/chktex-1.7.1.ebuild,v 1.1 2012/09/21 12:09:04 aballier Exp $
+
+EAPI=4
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Checks latex source for common mistakes"
+HOMEPAGE="http://www.nongnu.org/chktex/"
+SRC_URI="http://download.savannah.gnu.org/releases/chktex/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug doc +pcre test"
+# Tests fail without pcre. Enable pcre by default and make tests depend on it.
+REQUIRED_USE="test? ( pcre )"
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}
+ sys-apps/groff
+ doc? ( dev-tex/latex2html )"
+
+PATCHES=( "${FILESDIR}/${P}-asneeded.patch" )
+DOCS=( NEWS )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug debug-info)
+ $(use_enable pcre)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile html
+}
+
+src_install() {
+ if use doc ; then
+ HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/HTML/ChkTeX/")
+ DOCS+=("${AUTOTOOLS_BUILD_DIR}/HTML/ChkTeX.tex")
+ fi
+ autotools-utils_src_install
+ doman *.1
+}
diff --git a/dev-tex/chktex/files/chktex-1.7.1-asneeded.patch b/dev-tex/chktex/files/chktex-1.7.1-asneeded.patch
new file mode 100644
index 000000000000..7862a3534b9e
--- /dev/null
+++ b/dev-tex/chktex/files/chktex-1.7.1-asneeded.patch
@@ -0,0 +1,13 @@
+Index: chktex-1.7.1/configure.in
+===================================================================
+--- chktex-1.7.1.orig/configure.in
++++ chktex-1.7.1/configure.in
+@@ -173,7 +173,7 @@ if test "$enable_pcre" = "yes"; then
+ if test "$WITH_PCRE" = "yes"; then
+ AC_DEFINE(HAVE_PCRE, 1, "Whether PCRE can be used for user warnings.")
+ CFLAGS="${CFLAGS} $(pcre-config --cflags-posix)"
+- LDFLAGS="${LDFLAGS} $(pcre-config --libs-posix)"
++ LIBS="${LIBS} $(pcre-config --libs-posix)"
+ else
+ AC_DEFINE(HAVE_PCRE, 0, "Whether PCRE can be used for user warnings.")
+ AC_MSG_WARN(PCRE library not found.)