summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-10-11 14:02:04 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-10-11 14:02:04 +0000
commit977ebff7aa41b692d1faca98b541b1dd6ccf4f14 (patch)
tree7679f70ab5888ada3216fad869aef0f9b2d6dc7d /dev-tex/mh
parentShutup compile phase informing us that there is nothing to do. (diff)
downloadgentoo-2-977ebff7aa41b692d1faca98b541b1dd6ccf4f14.tar.gz
gentoo-2-977ebff7aa41b692d1faca98b541b1dd6ccf4f14.tar.bz2
gentoo-2-977ebff7aa41b692d1faca98b541b1dd6ccf4f14.zip
version bump, bug #378477
(Portage version: 2.2.0_alpha66/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex/mh')
-rw-r--r--dev-tex/mh/ChangeLog7
-rw-r--r--dev-tex/mh/mh-20111011.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-tex/mh/ChangeLog b/dev-tex/mh/ChangeLog
index fe8947df625b..cc4f33d0b429 100644
--- a/dev-tex/mh/ChangeLog
+++ b/dev-tex/mh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/mh
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/mh/ChangeLog,v 1.24 2011/08/28 16:28:45 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/mh/ChangeLog,v 1.25 2011/10/11 14:02:04 aballier Exp $
+
+*mh-20111011 (11 Oct 2011)
+
+ 11 Oct 2011; Alexis Ballier <aballier@gentoo.org> +mh-20111011.ebuild:
+ version bump, bug #378477
28 Aug 2011; Fabian Groffen <grobian@gentoo.org> mh-20101024.ebuild:
Marked ~x64-macos
diff --git a/dev-tex/mh/mh-20111011.ebuild b/dev-tex/mh/mh-20111011.ebuild
new file mode 100644
index 000000000000..8f5f4cf8e6e9
--- /dev/null
+++ b/dev-tex/mh/mh-20111011.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/mh/mh-20111011.ebuild,v 1.1 2011/10/11 14:02:04 aballier Exp $
+
+inherit latex-package
+
+DESCRIPTION="Additional LaTeX math tools."
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/mh/"
+SRC_URI="mirror://gentoo/${P}.zip"
+LICENSE="LPPL-1.3"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="dev-tex/xcolor
+ || ( >=dev-texlive/texlive-latexrecommended-2011 >=dev-texlive/texlive-latex3-2008 )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+TEXMF=/usr/share/texmf-site
+
+src_compile() {
+ # To avoid sandbox violations
+ export VARTEXFONTS="${T}/fonts"
+
+ # Unpacking *.dtx
+ for i in *.dtx; do
+ tex ${i} || die "TeXing ${i} failed"
+ done
+
+ latex-package_src_compile
+}
+
+src_install() {
+ latex-package_src_doinstall styles fonts bin
+
+ insinto "${TEXMF}/tex/latex/${PN}"
+ doins *.sym
+
+ use doc && latex-package_src_doinstall doc
+ dodoc README
+}