summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-03-08 11:55:10 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-03-08 11:55:10 +0000
commitbd7cc34bfbf6d42f68527b2299cd9d50e7da0332 (patch)
tree7d319c64c81e843fde005f774dde52064797763c /dev-tex/listings
parentStable on ppc. (diff)
downloadgentoo-2-bd7cc34bfbf6d42f68527b2299cd9d50e7da0332.tar.gz
gentoo-2-bd7cc34bfbf6d42f68527b2299cd9d50e7da0332.tar.bz2
gentoo-2-bd7cc34bfbf6d42f68527b2299cd9d50e7da0332.zip
version bump, bug #172443
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-tex/listings')
-rw-r--r--dev-tex/listings/ChangeLog9
-rw-r--r--dev-tex/listings/listings-1.4.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-tex/listings/ChangeLog b/dev-tex/listings/ChangeLog
index a4a6c56704e5..ef60af8a87f4 100644
--- a/dev-tex/listings/ChangeLog
+++ b/dev-tex/listings/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/listings
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/listings/ChangeLog,v 1.15 2007/07/02 15:08:35 peper Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/listings/ChangeLog,v 1.16 2008/03/08 11:55:10 aballier Exp $
+
+*listings-1.4 (08 Mar 2008)
+
+ 08 Mar 2008; Alexis Ballier <aballier@gentoo.org> +listings-1.4.ebuild:
+ version bump, bug #172443
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> listings-1.3.ebuild:
(QA) RESTRICT clean up.
diff --git a/dev-tex/listings/listings-1.4.ebuild b/dev-tex/listings/listings-1.4.ebuild
new file mode 100644
index 000000000000..10e7137975ec
--- /dev/null
+++ b/dev-tex/listings/listings-1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/listings/listings-1.4.ebuild,v 1.1 2008/03/08 11:55:10 aballier Exp $
+
+inherit latex-package
+
+DESCRIPTION="A source code and pretty print package for LaTeX"
+# Taken from ctan:
+# http://www.tex.ac.uk/tex-archive/macros/latex/contrib/listings.zip
+SRC_URI="mirror://gentoo/${P}.zip"
+HOMEPAGE="http://www.tex.ac.uk/tex-archive/macros/latex/contrib/listings/"
+LICENSE="LPPL-1.3"
+
+IUSE="doc"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+TEXMF="/usr/share/texmf-site"
+
+DOCS="README"
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ emake listings || die "Failed to create listings.sty"
+ if use doc; then
+ emake -j1 all || die "Failed to create documentation"
+ fi
+}
+
+src_install() {
+ export VARTEXFONTS="${T}/fonts"
+ latex-package_src_install
+}