summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-02-20 18:35:47 +0000
committerMamoru Komachi <usata@gentoo.org>2004-02-20 18:35:47 +0000
commit330a78eb2753bb8f41df708802814024e0e03e2e (patch)
tree0bfaf1f92dd1f99ed2993820ad41a3575ba37d7f /dev-tex/lgrind
parentFixed conditional statement when only apache2 is installed but apache2 USE fl... (diff)
downloadgentoo-2-330a78eb2753bb8f41df708802814024e0e03e2e.tar.gz
gentoo-2-330a78eb2753bb8f41df708802814024e0e03e2e.tar.bz2
gentoo-2-330a78eb2753bb8f41df708802814024e0e03e2e.zip
Fixed "cannot find lgrindef" problem. Thanks to Fernando A. Serboncini <fserb@terra.com.br> for reporting a solution. This closes bug #35097
Diffstat (limited to 'dev-tex/lgrind')
-rw-r--r--dev-tex/lgrind/ChangeLog11
-rw-r--r--dev-tex/lgrind/Manifest2
-rw-r--r--dev-tex/lgrind/files/99lgrind1
-rw-r--r--dev-tex/lgrind/files/digest-lgrind-3.67-r11
-rw-r--r--dev-tex/lgrind/lgrind-3.67-r1.ebuild44
5 files changed, 57 insertions, 2 deletions
diff --git a/dev-tex/lgrind/ChangeLog b/dev-tex/lgrind/ChangeLog
index b67916e24bc7..6de533e935fb 100644
--- a/dev-tex/lgrind/ChangeLog
+++ b/dev-tex/lgrind/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-tex/lgrind
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/lgrind/ChangeLog,v 1.1 2003/10/02 15:28:23 obz Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/lgrind/ChangeLog,v 1.2 2004/02/20 18:35:47 usata Exp $
+
+*lgrind-3.67-r1 (21 Feb 2004)
+
+ 21 Feb 2004; Mamoru KOMACHI <usata@gentoo.org> lgrind-3.67-r1.ebuild,
+ files/99lgrind:
+ Fixed "cannot find lgrindef" problem. Thanks to Fernando A. Serboncini
+ <fserb@terra.com.br> for reporting a solution. This closes bug #35097
*lgrind-3.67 (02 Oct 2003)
diff --git a/dev-tex/lgrind/Manifest b/dev-tex/lgrind/Manifest
index 8839ee5da630..2406b5c4269d 100644
--- a/dev-tex/lgrind/Manifest
+++ b/dev-tex/lgrind/Manifest
@@ -1,4 +1,6 @@
MD5 4cdd3bf2eae7c49a4c7d38445dc64ddc lgrind-3.67.ebuild 867
MD5 5b4ab202623c06940b8560cf8ff7f8da ChangeLog 427
MD5 c472f5fd1646eb8bca71d8df5cb2bdcc metadata.xml 164
+MD5 4cdd3bf2eae7c49a4c7d38445dc64ddc lgrind-3.67-r1.ebuild 867
MD5 13c9a4bcc670c1e8eef9a40d0768694c files/digest-lgrind-3.67 57
+MD5 13c9a4bcc670c1e8eef9a40d0768694c files/digest-lgrind-3.67-r1 57
diff --git a/dev-tex/lgrind/files/99lgrind b/dev-tex/lgrind/files/99lgrind
new file mode 100644
index 000000000000..c1c737c76e54
--- /dev/null
+++ b/dev-tex/lgrind/files/99lgrind
@@ -0,0 +1 @@
+LGRINDEF=/usr/share/texmf/tex/latex/lgrind/lgrindef
diff --git a/dev-tex/lgrind/files/digest-lgrind-3.67-r1 b/dev-tex/lgrind/files/digest-lgrind-3.67-r1
new file mode 100644
index 000000000000..e029dda14af4
--- /dev/null
+++ b/dev-tex/lgrind/files/digest-lgrind-3.67-r1
@@ -0,0 +1 @@
+MD5 650e14f7b9f098854aa10ef0f49712f7 lgrind.tar.gz 73205
diff --git a/dev-tex/lgrind/lgrind-3.67-r1.ebuild b/dev-tex/lgrind/lgrind-3.67-r1.ebuild
new file mode 100644
index 000000000000..7a6781fcd44f
--- /dev/null
+++ b/dev-tex/lgrind/lgrind-3.67-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/lgrind/lgrind-3.67-r1.ebuild,v 1.1 2004/02/20 18:35:47 usata Exp $
+
+inherit latex-package
+
+DESCRIPTION="A source pretty printer for LaTeX - styles to stylise your source and code examples."
+SRC_URI="mirror://gentoo/${PN}.tar.gz"
+LICENSE="as-is"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86"
+S=${WORKDIR}/${PN}
+
+src_compile() {
+
+ cd ${S}/source
+ emake || die "Error compiling lgrind executable"
+ latex-package_src_compile
+
+}
+
+src_install() {
+
+ # binary first
+ dobin source/lgrind
+
+ # then the texmf stuff
+ latex-package_src_install
+ insinto /usr/share/texmf/tex/latex/${PN}
+ doins lgrindef
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/99lgrind || die
+
+ # and finally, the documentation
+ dodoc FAQ README
+ docinto examples/
+ dodoc example/*
+ cd ${S}/source
+ doman lgrind.1 lgrindef.5
+
+}