summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-11-21 00:20:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-11-21 00:20:06 +0000
commit6c69896b10ed483f25b4133010d3465d12fefbb5 (patch)
treea002f816fa4a8a896e6394959fdbb3795f6c04a2 /dev-tex/latexmk/latexmk-435.ebuild
parentversion bump (diff)
downloadgentoo-2-6c69896b10ed483f25b4133010d3465d12fefbb5.tar.gz
gentoo-2-6c69896b10ed483f25b4133010d3465d12fefbb5.tar.bz2
gentoo-2-6c69896b10ed483f25b4133010d3465d12fefbb5.zip
version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-tex/latexmk/latexmk-435.ebuild')
-rw-r--r--dev-tex/latexmk/latexmk-435.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-tex/latexmk/latexmk-435.ebuild b/dev-tex/latexmk/latexmk-435.ebuild
new file mode 100644
index 000000000000..84b3d71f2e8b
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-435.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latexmk/latexmk-435.ebuild,v 1.1 2012/11/21 00:20:06 aballier Exp $
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents."
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin latexmk.pl latexmk
+ doman latexmk.1
+ dodoc CHANGES README latexmk.pdf latexmk.ps latexmk.txt
+ dodoc -r example_rcfiles extra-scripts
+ newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}