summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-02-15 23:07:52 +0000
committerChristoph Junghans <ottxor@gentoo.org>2011-02-15 23:07:52 +0000
commit78ecf6c3b8478740d370cc7dd9998229675c9320 (patch)
tree6ce64257b9fecc11354b3f702be3dc0c9e276700 /dev-tex/latexmk/latexmk-422e.ebuild
parentMask xorg-server-1.7 and friends for removal in 30 days. (diff)
downloadgentoo-2-78ecf6c3b8478740d370cc7dd9998229675c9320.tar.gz
gentoo-2-78ecf6c3b8478740d370cc7dd9998229675c9320.tar.bz2
gentoo-2-78ecf6c3b8478740d370cc7dd9998229675c9320.zip
version bump
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'dev-tex/latexmk/latexmk-422e.ebuild')
-rw-r--r--dev-tex/latexmk/latexmk-422e.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-tex/latexmk/latexmk-422e.ebuild b/dev-tex/latexmk/latexmk-422e.ebuild
new file mode 100644
index 000000000000..8241cdcf66f5
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-422e.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latexmk/latexmk-422e.ebuild,v 1.1 2011/02/15 23:07:52 ottxor Exp $
+
+inherit bash-completion
+
+DESCRIPTION="Perl script for automatically building LaTeX documents."
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86 ~ppc-macos"
+IUSE=""
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_install() {
+ cd "${WORKDIR}"
+ newbin latexmk.pl latexmk || die
+ dodoc CHANGES README latexmk.pdf latexmk.ps latexmk.txt || die
+ doman latexmk.1 || die
+ insinto /usr/share/doc/${PF}
+ doins -r example_rcfiles extra-scripts || die
+ dobashcompletion "${FILESDIR}"/completion.bash-2 ${PN}
+}