summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-05-13 03:18:27 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-05-13 03:18:27 +0000
commit304c611e6dd3e88c8a88ea07f0f065135f8c5171 (patch)
treec8b153565e361a719d3971725d656de2cdaf2a68 /dev-tex/hlatex/hlatex-1.0.1.ebuild
parentStable 2.6.19.2-r2 on mips, add ~mips to 2.6.20-r2. (diff)
downloadgentoo-2-304c611e6dd3e88c8a88ea07f0f065135f8c5171.tar.gz
gentoo-2-304c611e6dd3e88c8a88ea07f0f065135f8c5171.tar.bz2
gentoo-2-304c611e6dd3e88c8a88ea07f0f065135f8c5171.zip
Version bumped, bug #98795.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-tex/hlatex/hlatex-1.0.1.ebuild')
-rw-r--r--dev-tex/hlatex/hlatex-1.0.1.ebuild104
1 files changed, 104 insertions, 0 deletions
diff --git a/dev-tex/hlatex/hlatex-1.0.1.ebuild b/dev-tex/hlatex/hlatex-1.0.1.ebuild
new file mode 100644
index 000000000000..0c23e83350ec
--- /dev/null
+++ b/dev-tex/hlatex/hlatex-1.0.1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/hlatex/hlatex-1.0.1.ebuild,v 1.1 2007/05/13 03:18:27 matsuu Exp $
+
+inherit toolchain-funcs latex-package
+
+MY_P="HLaTeX-${PV}"
+DESCRIPTION="HLaTeX is a LaTeX package to use Hangul with LaTeX."
+HOMEPAGE="http://project.ktug.or.kr/hlatex/"
+UHCFONTS="uhc-myoungjo-1.0.tar.gz
+ uhc-gothic-1.0.tar.gz
+ uhc-taza-1.0.tar.gz
+ uhc-graphic-1.0.tar.gz
+ uhc-gungseo-1.0.tar.gz
+ uhc-shinmun-1.0.tar.gz
+ uhc-pilgi-1.0.tar.gz
+ uhc-pen-1.0.tar.gz
+ uhc-bom-1.0.tar.gz
+ uhc-yetgul-1.0.tar.gz
+ uhc-jamo-1.0.tar.gz
+ uhc-vada-1.0.tar.gz
+ uhc-pilgia-1.0.tar.gz
+ uhc-dinaru-1.0.tar.gz"
+
+SRC_URI="ftp://ftp.ktug.or.kr/pub/ktug/hlatex/${MY_P}.tar.gz
+ ftp://ftp.ktug.or.kr/pub/ktug/hlatex/fonts/uhc-fonts-1.0.tar.gz
+ ${UHCFONTS//uhc-/ftp://ftp.ktug.or.kr/pub/ktug/hlatex/fonts/uhc-}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc-macos ~x86"
+IUSE=""
+
+S="${WORKDIR}/HLaTeX"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ unpack uhc-fonts-1.0.tar.gz
+}
+
+src_install() {
+ cd "${S}"/latex
+ insinto ${TEXMF}/tex/latex/hlatex
+ doins *
+
+ cd "${S}"/lambda
+ insinto ${TEXMF}/tex/lambda/hlatex
+ doins u8hangul.tex uhc-test.tex uhc*.fd
+
+ insinto ${TEXMF}/omega/otp/hlatex
+ doins hlatex.otp
+
+ insinto ${TEXMF}/omega/ocp/hlatex
+ doins hlatex.ocp
+
+ cd "${S}"/contrib
+ insinto ${TEXMF}/tex/latex/hlatex
+ doins hbname-k.tex khyper.sty showhkeys.sty showhtags.sty
+ doins hangulfn.sty hfn-k.tex
+
+ insinto ${TEXMF}/tex/lambda/hlatex
+ doins hbname-u.tex hfn-u.tex
+
+ insinto ${TEXMF}/bibtex/bst/hlatex
+ doins halpha.bst
+
+ insinto ${TEXMF}/makeindex
+ doins hind.ist hglo.ist
+
+ $(tc-getCC) -o hmakeindex hmakeindex.c || die
+ $(tc-getCC) -o hbibtex hbibtex.c || die
+ dobin hmakeindex hbibtex
+
+ cd "${S}"
+ dodoc ChangeLog.ko NEWS* README.en
+
+ cd "${WORKDIR}"/uhc-fonts-1.0
+ insinto ${TEXMF}/fonts/map/hlatex
+ doins uhc-base.map uhc-extra.map
+
+ cd "${D}"/${TEXMF}/fonts
+ for X in ${UHCFONTS}
+ do
+ unpack ${X}
+ done
+}
+
+pkg_postinst() {
+ updmap-sys --enable Map=uhc-base.map
+ updmap-sys --enable Map=uhc-extra.map
+ texhash
+}
+
+pkg_postrm() {
+ if [ ! -e ${TEXMF}/fonts/map/hlatex/uhc-base.map ] ; then
+ updmap-sys --disable Map=uhc-base.map
+ fi
+
+ if [ ! -e ${TEXMF}/fonts/map/hlatex/uhc-extra.map ] ; then
+ updmap-sys --disable Map=uhc-extra.map
+ fi
+
+ texhash
+}