summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-02-04 12:54:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-02-04 12:54:21 +0000
commitfc2a32464497ebcc2b53be132b651b9f695fe183 (patch)
treed23f9a4846c4030601e9e2264fd7291bb8fa30b6 /dev-tex/hevea
parentStable for arm, wrt bug #450940 (diff)
downloadgentoo-2-fc2a32464497ebcc2b53be132b651b9f695fe183.tar.gz
gentoo-2-fc2a32464497ebcc2b53be132b651b9f695fe183.tar.bz2
gentoo-2-fc2a32464497ebcc2b53be132b651b9f695fe183.zip
version bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-tex/hevea')
-rw-r--r--dev-tex/hevea/ChangeLog9
-rw-r--r--dev-tex/hevea/hevea-2.02.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-tex/hevea/ChangeLog b/dev-tex/hevea/ChangeLog
index 334f37b3f4c8..ec2ac837d87b 100644
--- a/dev-tex/hevea/ChangeLog
+++ b/dev-tex/hevea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/hevea
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/hevea/ChangeLog,v 1.34 2012/12/29 14:35:15 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/hevea/ChangeLog,v 1.35 2013/02/04 12:54:21 aballier Exp $
+
+*hevea-2.02 (04 Feb 2013)
+
+ 04 Feb 2013; Alexis Ballier <aballier@gentoo.org> +hevea-2.02.ebuild:
+ version bump
29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> hevea-2.00.ebuild:
Stable for sparc, wrt bug #441304
diff --git a/dev-tex/hevea/hevea-2.02.ebuild b/dev-tex/hevea/hevea-2.02.ebuild
new file mode 100644
index 000000000000..8b0e115e42de
--- /dev/null
+++ b/dev-tex/hevea/hevea-2.02.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/hevea/hevea-2.02.ebuild,v 1.1 2013/02/04 12:54:21 aballier Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="HeVeA is a quite complete and fast LaTeX to HTML translator"
+HOMEPAGE="http://hevea.inria.fr/"
+SRC_URI="http://hevea.inria.fr/distri/${P}.tar.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ rm -f config.sh
+ emake PREFIX=/usr DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/hevea" LATEXLIBDIR="/usr/share/texmf-site/tex/latex/hevea" config.sh || die "Failed to create config.sh"
+ if use ocamlopt; then
+ emake PREFIX=/usr || die "Failed to build native code binaries"
+ else
+ emake PREFIX=/usr TARGET=byte || die "Failed to build bytecode binaries"
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ emake DESTDIR="${D}" PREFIX=/usr install || die "Install failed"
+ else
+ emake DESTDIR="${D}" PREFIX=/usr TARGET=byte install || die "Install failed"
+ fi
+
+ dodoc README CHANGES
+}
+
+# If texmf-update is present this means we have a latex install; update it so
+# that hevea.sty can be found
+# Do not (r)depend on latex though because hevea does not need it itself
+# If latex is installed later, it will see hevea.sty
+
+pkg_postinst() {
+ if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
+ /usr/sbin/texmf-update
+ fi
+}
+
+pkg_postrm() {
+ if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
+ /usr/sbin/texmf-update
+ fi
+}