summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-10-02 09:23:56 +0000
committerMamoru Komachi <usata@gentoo.org>2004-10-02 09:23:56 +0000
commit742fc779cf17125c2225e2102371479c78df1129 (patch)
treeaecd2be0b0a8eb4c23841d146885cdb14970c414 /dev-tex/feynmf/feynmf-1.08.ebuild
parentMarked ppc (Manifest recommit) (diff)
downloadgentoo-2-742fc779cf17125c2225e2102371479c78df1129.tar.gz
gentoo-2-742fc779cf17125c2225e2102371479c78df1129.tar.bz2
gentoo-2-742fc779cf17125c2225e2102371479c78df1129.zip
Initial import. Ebuild submitted by Ulrich Mueller <ulm@kph.uni-mainz.de>, closing bug #62800.
Diffstat (limited to 'dev-tex/feynmf/feynmf-1.08.ebuild')
-rw-r--r--dev-tex/feynmf/feynmf-1.08.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-tex/feynmf/feynmf-1.08.ebuild b/dev-tex/feynmf/feynmf-1.08.ebuild
new file mode 100644
index 000000000000..c223db9b92af
--- /dev/null
+++ b/dev-tex/feynmf/feynmf-1.08.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/feynmf/feynmf-1.08.ebuild,v 1.1 2004/10/02 09:23:56 usata Exp $
+
+inherit eutils latex-package
+
+DESCRIPTION="Combined LaTeX/Metafont package for drawing of Feynman diagrams"
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/feynmf/"
+#Taken from: ftp.tug.ctan.org/tex-archive/macros/latex/contrib/${PN}.tar.gz
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/tetex"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}.patch
+}
+
+src_compile() {
+ addwrite /var/cache/fonts
+ emake MP=mpost all manual.ps || die "emake failed"
+}
+
+src_install() {
+ newbin feynmf.pl feynmf
+ doman feynmf.1
+ insinto ${TEXMF}/tex/latex/${PN}; doins feynmf.sty feynmp.sty
+ insinto ${TEXMF}/metafont/${PN}; doins feynmf.mf
+ insinto ${TEXMF}/metapost/${PN}; doins feynmp.mp
+ dodoc README manual.ps template.tex
+}