summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-09-01 08:31:56 +0000
committerUlrich Müller <ulm@gentoo.org>2008-09-01 08:31:56 +0000
commitc809083ade1feb0ea6759011a94ccba6707820d3 (patch)
treef70ce7021ed7e329de6df9298220480195dbb0af /dev-tex/feynmf/feynmf-1.08-r3.ebuild
parentfix #218051; version bump (diff)
downloadgentoo-2-c809083ade1feb0ea6759011a94ccba6707820d3.tar.gz
gentoo-2-c809083ade1feb0ea6759011a94ccba6707820d3.tar.bz2
gentoo-2-c809083ade1feb0ea6759011a94ccba6707820d3.zip
Redefine VARTEXFONTS instead of using addwrite for font cache, bug 221921. Change installation dir from texmf to texmf-site.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-tex/feynmf/feynmf-1.08-r3.ebuild')
-rw-r--r--dev-tex/feynmf/feynmf-1.08-r3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-tex/feynmf/feynmf-1.08-r3.ebuild b/dev-tex/feynmf/feynmf-1.08-r3.ebuild
new file mode 100644
index 000000000000..a0a0242dbd5b
--- /dev/null
+++ b/dev-tex/feynmf/feynmf-1.08-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/feynmf/feynmf-1.08-r3.ebuild,v 1.1 2008/09/01 08:31:56 ulm Exp $
+
+inherit eutils latex-package
+
+DESCRIPTION="Combined LaTeX/Metafont package for drawing of Feynman diagrams"
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/feynmf/"
+#Taken from: ftp.tug.ctan.org/tex-archive/macros/latex/contrib/${PN}.tar.gz
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ doc? ( mirror://gentoo/${PN}-cnl.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND="|| ( dev-texlive/texlive-metapost virtual/tetex )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+TEXMF="/usr/share/texmf-site"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${P}.patch"
+ epatch "${FILESDIR}/${P}-tempfile.patch"
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}"/fonts
+ emake MP=mpost all manual.ps || die "emake failed"
+ if use doc; then
+ emake -f Makefile.cnl ps || die "emake fmfcnl failed"
+ fi
+}
+
+src_install() {
+ newbin feynmf.pl feynmf
+ doman feynmf.1
+ insinto ${TEXMF}/tex/latex/${PN}; doins feynmf.sty feynmp.sty
+ insinto ${TEXMF}/metafont/${PN}; doins feynmf.mf
+ insinto ${TEXMF}/metapost/${PN}; doins feynmp.mp
+ dodoc README manual.ps template.tex
+ use doc && dodoc fmfcnl*.ps
+}