summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-12 20:25:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-12 20:25:13 +0000
commit52311b95ede518fb56d1716d506c1f0bccb7282d (patch)
tree6ec97e07c74eb2f611e1d08417821c41cae55320 /dev-tex/crosstex
parentMask dev-ruby/amrita for removal. (diff)
downloadgentoo-2-52311b95ede518fb56d1716d506c1f0bccb7282d.tar.gz
gentoo-2-52311b95ede518fb56d1716d506c1f0bccb7282d.tar.bz2
gentoo-2-52311b95ede518fb56d1716d506c1f0bccb7282d.zip
Use Python 2 and fix deprecation warnings (bug #312219).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex/crosstex')
-rw-r--r--dev-tex/crosstex/ChangeLog8
-rw-r--r--dev-tex/crosstex/crosstex-0.6.ebuild32
2 files changed, 25 insertions, 15 deletions
diff --git a/dev-tex/crosstex/ChangeLog b/dev-tex/crosstex/ChangeLog
index ea750e2565e1..c62b04043b90 100644
--- a/dev-tex/crosstex/ChangeLog
+++ b/dev-tex/crosstex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tex/crosstex
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/crosstex/ChangeLog,v 1.5 2008/10/16 22:03:07 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/crosstex/ChangeLog,v 1.6 2010/06/12 20:25:13 arfrever Exp $
+
+ 12 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ crosstex-0.6.ebuild:
+ Use Python 2 and fix deprecation warnings (bug #312219).
16 Oct 2008; Alexis Ballier <aballier@gentoo.org> -crosstex-0.5.6.ebuild:
remove old
diff --git a/dev-tex/crosstex/crosstex-0.6.ebuild b/dev-tex/crosstex/crosstex-0.6.ebuild
index c2e8a25363db..7ee68a3b305c 100644
--- a/dev-tex/crosstex/crosstex-0.6.ebuild
+++ b/dev-tex/crosstex/crosstex-0.6.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/crosstex/crosstex-0.6.ebuild,v 1.1 2008/08/07 22:41:27 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/crosstex/crosstex-0.6.ebuild,v 1.2 2010/06/12 20:25:13 arfrever Exp $
-inherit python
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit multilib python
DESCRIPTION="CrossTeX - object oriented BibTeX replacement"
HOMEPAGE="http://www.cs.cornell.edu/people/egs/crosstex/"
@@ -13,19 +16,23 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
-RDEPEND="dev-lang/python
- dev-python/ply"
+RDEPEND="dev-python/ply"
DEPEND="${RDEPEND}"
-src_install() {
- python_version
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
- cd "${S}"
+src_install() {
emake \
ROOT="${D}" \
PREFIX="/usr" \
- LIBDIR="/$(get_libdir)/python${PYVER}/site-packages" \
- install || die "make install failed"
+ LIBDIR="/$(get_libdir)/python$(python_get_version)/site-packages" \
+ install || die "emake install failed"
+
+ python_convert_shebangs -r $(python_get_version) "${D}"
+ python_need_rebuild
insinto /usr/share/doc/${PF}
doins "${PN}".pdf
@@ -36,10 +43,9 @@ src_install() {
}
pkg_postinst() {
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
+ python_mod_optimize ${PN}
}
pkg_postrm() {
- python_mod_cleanup
+ python_mod_cleanup ${PN}
}