summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-05-17 11:01:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-05-17 11:01:24 +0000
commita9d85619368da67c8b8c87341698ade5f9458951 (patch)
treed0aef3bb87861f544a2559f688867f5a151c45c8 /dev-tex/chktex
parentsci-chemistry/acpype: Version Bump (diff)
downloadgentoo-2-a9d85619368da67c8b8c87341698ade5f9458951.tar.gz
gentoo-2-a9d85619368da67c8b8c87341698ade5f9458951.tar.bz2
gentoo-2-a9d85619368da67c8b8c87341698ade5f9458951.zip
version bump
(Portage version: 2.2.0_alpha175/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-tex/chktex')
-rw-r--r--dev-tex/chktex/ChangeLog12
-rw-r--r--dev-tex/chktex/chktex-1.7.2.ebuild51
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-tex/chktex/ChangeLog b/dev-tex/chktex/ChangeLog
index 3d97f07a3e54..8d3c6e512faf 100644
--- a/dev-tex/chktex/ChangeLog
+++ b/dev-tex/chktex/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-tex/chktex
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/chktex/ChangeLog,v 1.55 2013/05/17 10:50:59 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/chktex/ChangeLog,v 1.56 2013/05/17 11:01:24 aballier Exp $
+
+*chktex-1.7.2 (17 May 2013)
+
+ 17 May 2013; Alexis Ballier <aballier@gentoo.org> +chktex-1.7.2.ebuild:
+ version bump
+
+ 17 May 2013; Alexis Ballier <aballier@gentoo.org> -chktex-1.6.4.ebuild,
+ -chktex-1.6.6.ebuild, -chktex-1.7.0.ebuild,
+ -files/chktex-1.7.0-asneeded.patch:
+ remove old
17 May 2013; Alexis Ballier <aballier@gentoo.org> -chktex-1.6.4.ebuild,
-chktex-1.6.6.ebuild, -chktex-1.7.0.ebuild,
diff --git a/dev-tex/chktex/chktex-1.7.2.ebuild b/dev-tex/chktex/chktex-1.7.2.ebuild
new file mode 100644
index 000000000000..0083e78886b1
--- /dev/null
+++ b/dev-tex/chktex/chktex-1.7.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/chktex/chktex-1.7.2.ebuild,v 1.1 2013/05/17 11:01:24 aballier Exp $
+
+EAPI=4
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Checks latex source for common mistakes"
+HOMEPAGE="http://www.nongnu.org/chktex/"
+SRC_URI="http://download.savannah.gnu.org/releases/chktex/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug doc +pcre test"
+# Tests fail without pcre. Enable pcre by default and make tests depend on it.
+REQUIRED_USE="test? ( pcre )"
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}
+ sys-apps/groff
+ doc? ( dev-tex/latex2html )"
+
+PATCHES=( "${FILESDIR}/${PN}-1.7.1-asneeded.patch" )
+DOCS=( NEWS )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug debug-info)
+ $(use_enable pcre)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile html
+}
+
+src_install() {
+ if use doc ; then
+ HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/HTML/ChkTeX/")
+ DOCS+=("${AUTOTOOLS_BUILD_DIR}/HTML/ChkTeX.tex")
+ fi
+ autotools-utils_src_install
+ doman *.1
+}