summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-11-18 16:50:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-11-18 16:50:09 +0000
commita08ed7ba506b83dfcaf2ab27b900964994c1e1d8 (patch)
tree9ef5b6dc9ceea2e9c33151ae062b311f6b3aa0cd /dev-tex/chktex/chktex-1.6.4.ebuild
parentStable on ppc64; bug #155220 (diff)
downloadgentoo-2-a08ed7ba506b83dfcaf2ab27b900964994c1e1d8.tar.gz
gentoo-2-a08ed7ba506b83dfcaf2ab27b900964994c1e1d8.tar.bz2
gentoo-2-a08ed7ba506b83dfcaf2ab27b900964994c1e1d8.zip
version bump, bug #199550
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-tex/chktex/chktex-1.6.4.ebuild')
-rw-r--r--dev-tex/chktex/chktex-1.6.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-tex/chktex/chktex-1.6.4.ebuild b/dev-tex/chktex/chktex-1.6.4.ebuild
new file mode 100644
index 000000000000..698fa42d9154
--- /dev/null
+++ b/dev-tex/chktex/chktex-1.6.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/chktex/chktex-1.6.4.ebuild,v 1.1 2007/11/18 16:50:09 aballier Exp $
+
+DESCRIPTION="Checks latex source for common mistakes"
+HOMEPAGE="http://baruch.ev-en.org/proj/chktex/"
+SRC_URI="http://baruch.ev-en.org/proj/chktex/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc"
+
+DEPEND="virtual/latex-base
+ dev-lang/perl
+ sys-apps/groff
+ doc? ( dev-tex/latex2html )"
+
+src_compile() {
+ econf `use_enable debug debug-info` || die
+ emake || die
+ if use doc ; then
+ emake html || die "emake html failed"
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc NEWS
+ if use doc ; then
+ dohtml HTML/ChkTeX/*
+ dodoc HTML/ChkTeX.tex
+ fi
+ doman *.1
+}