summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-31 21:18:12 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-31 21:18:12 +0000
commite41e047cfda705a98c3dceed35ba63012c764eec (patch)
treed531cb2d543564271caafea186b196f0e427a7cf /dev-tcltk
parentversion bump (diff)
downloadgentoo-2-e41e047cfda705a98c3dceed35ba63012c764eec.tar.gz
gentoo-2-e41e047cfda705a98c3dceed35ba63012c764eec.tar.bz2
gentoo-2-e41e047cfda705a98c3dceed35ba63012c764eec.zip
Adopted to new python situation, #312215, EAPI=3
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/snack/ChangeLog10
-rw-r--r--dev-tcltk/snack/snack-2.2.10-r3.ebuild (renamed from dev-tcltk/snack/snack-2.2.10-r1.ebuild)39
-rw-r--r--dev-tcltk/snack/snack-2.2.10.ebuild53
3 files changed, 36 insertions, 66 deletions
diff --git a/dev-tcltk/snack/ChangeLog b/dev-tcltk/snack/ChangeLog
index 6b1e26575d79..31bc966f6e06 100644
--- a/dev-tcltk/snack/ChangeLog
+++ b/dev-tcltk/snack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/snack
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/ChangeLog,v 1.40 2009/10/10 15:30:43 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/ChangeLog,v 1.41 2010/03/31 21:18:12 jlec Exp $
+
+*snack-2.2.10-r3 (31 Mar 2010)
+
+ 31 Mar 2010; Justin Lecher <jlec@gentoo.org> -snack-2.2.10.ebuild,
+ -snack-2.2.10-r1.ebuild, +snack-2.2.10-r3.ebuild:
+ Adopted to new python situation, #312215, EAPI=3
10 Oct 2009; Raúl Porcel <armin76@gentoo.org> snack-2.2.10-r2.ebuild:
sparc stable wrt #282987
diff --git a/dev-tcltk/snack/snack-2.2.10-r1.ebuild b/dev-tcltk/snack/snack-2.2.10-r3.ebuild
index 6f996d84e0d6..fb1c05e93d1f 100644
--- a/dev-tcltk/snack/snack-2.2.10-r1.ebuild
+++ b/dev-tcltk/snack/snack-2.2.10-r3.ebuild
@@ -1,29 +1,40 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.10-r1.ebuild,v 1.9 2008/08/08 16:55:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.10-r3.ebuild,v 1.1 2010/03/31 21:18:12 jlec Exp $
-inherit eutils multilib
+EAPI="3"
+
+PYTHON_DEPEND="python? 2"
+
+inherit eutils multilib python
DESCRIPTION="The Snack Sound Toolkit (Tcl)"
HOMEPAGE="http://www.speech.kth.se/snack/"
SRC_URI="http://www.speech.kth.se/snack/dist/${PN}${PV}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="alpha amd64 hppa ~ppc ppc64 sparc x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
SLOT="0"
IUSE="alsa examples python threads vorbis"
RESTRICT="test" # Bug 78354
-DEPEND=">dev-lang/tcl-8.4.3
+DEPEND="
>dev-lang/tk-8.4.3
alsa? ( media-libs/alsa-lib )
- vorbis? ( media-libs/libvorbis )
- python? ( virtual/python )"
+ vorbis? ( media-libs/libvorbis )"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}${PV}/unix"
-src_compile() {
+src_prepare() {
+ # bug 226137 - snack depends on alsa private symbol _snd_pcm_mmap_hw_ptr
+ epatch "${FILESDIR}"/alsa-undef-sym.patch
+ # bug 270839 - error from /usr/include/bits/mathcalls.h:310
+ sed -i -e 's|^\(#define roundf(.*\)|//\1|' ../generic/jkFormatMP3.c
+}
+
+src_configure() {
local myconf="--libdir=/usr/$(get_libdir) --includedir=/usr/include"
use alsa && myconf="${myconf} --enable-alsa"
@@ -34,9 +45,7 @@ src_compile() {
myconf="${myconf} --with-ogg-lib=/usr/$(get_libdir)"
fi
- econf ${myconf} || die "configure failed"
- emake || die "make failed"
-
+ econf ${myconf}
}
src_install() {
@@ -63,3 +72,11 @@ src_install() {
fi
fi
}
+
+pkg_postinst() {
+ python_mod_optimize tkSnack.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup tkSnack.py
+}
diff --git a/dev-tcltk/snack/snack-2.2.10.ebuild b/dev-tcltk/snack/snack-2.2.10.ebuild
deleted file mode 100644
index a2df28e97866..000000000000
--- a/dev-tcltk/snack/snack-2.2.10.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.10.ebuild,v 1.9 2007/06/25 10:40:53 peper Exp $
-
-inherit eutils multilib
-
-DESCRIPTION="The Snack Sound Toolkit (Tcl)"
-HOMEPAGE="http://www.speech.kth.se/snack/"
-SRC_URI="http://www.speech.kth.se/snack/dist/${PN}${PV}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-SLOT="0"
-IUSE="alsa python threads vorbis"
-
-RESTRICT="test" # Bug 78354
-
-DEPEND=">dev-lang/tcl-8.4.3
- >dev-lang/tk-8.4.3
- alsa? ( media-libs/alsa-lib )
- vorbis? ( media-libs/libvorbis )
- python? ( virtual/python )"
-
-S="${WORKDIR}/${PN}${PV}/unix"
-
-src_compile() {
- local myconf="--libdir=/usr/$(get_libdir) --includedir=/usr/include"
-
- use alsa && myconf="${myconf} --enable-alsa"
- use threads && myconf="${myconf} --enable-threads"
-
- if use vorbis ; then
- myconf="${myconf} --with-ogg-include=/usr/include"
- myconf="${myconf} --with-ogg-lib=/usr/$(get_libdir)"
- fi
-
- econf ${myconf} || die "configure failed"
- emake || die "make failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- if use python ; then
- cd "${S}"/../python
- python setup.py install --root="${D}" || die
- fi
-
- cd "${S}"/..
-
- dodoc README changes
- dohtml doc/*
-}