summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-02 09:44:28 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-02 09:44:28 +0000
commitdfbedb230de80f43503e343545139aedcaa61fdb (patch)
tree2c044b0e73ce93afae81616dd7b6f401d3a3ae92 /dev-tcltk
parentImported from prefix overlay (diff)
downloadgentoo-2-dfbedb230de80f43503e343545139aedcaa61fdb.tar.gz
gentoo-2-dfbedb230de80f43503e343545139aedcaa61fdb.tar.bz2
gentoo-2-dfbedb230de80f43503e343545139aedcaa61fdb.zip
Version Bump, Imported from prefix overlay, LDFLAGS patch
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/expect/ChangeLog8
-rw-r--r--dev-tcltk/expect/expect-5.44.1.ebuild114
-rw-r--r--dev-tcltk/expect/files/expect-5.44.1-darwin.patch15
-rw-r--r--dev-tcltk/expect/files/expect-5.44.1-ldflags.patch13
4 files changed, 148 insertions, 2 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 54b752fb9b9e..240a60e375a7 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/expect
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.64 2009/09/27 14:56:55 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.65 2010/04/02 09:44:28 jlec Exp $
+
+ 02 Apr 2010; Justin Lecher <jlec@gentoo.org> +expect-5.44.1.ebuild,
+ +files/expect-5.44.1-darwin.patch, +files/expect-5.44.1-ldflags.patch:
+ Version Bump, Imported from prefix overlay, LDFLAGS patch
27 Sep 2009; nixnut <nixnut@gentoo.org> expect-5.43.0.ebuild:
ppc stable #281420
diff --git a/dev-tcltk/expect/expect-5.44.1.ebuild b/dev-tcltk/expect/expect-5.44.1.ebuild
new file mode 100644
index 000000000000..76e92864bede
--- /dev/null
+++ b/dev-tcltk/expect/expect-5.44.1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.44.1.ebuild,v 1.6 2010/04/02 09:44:28 jlec Exp $
+
+EAPI="3"
+
+WANT_AUTOCONF="2.5"
+inherit autotools eutils
+
+DESCRIPTION="tool for automating interactive applications"
+HOMEPAGE="http://expect.nist.gov/"
+SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="X doc"
+
+# We need dejagnu for src_test, but dejagnu needs expect
+# to compile/run, so we cant add dejagnu to DEPEND :/
+DEPEND="
+ >=dev-lang/tcl-8.2
+ >=dev-lang/tk-8.2"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ # fix install_name on darwin
+ [[ ${CHOST} == *-darwin* ]] && \
+ epatch "${FILESDIR}"/${P}-darwin.patch
+
+ sed -i "s#/usr/local/bin#${EPREFIX}/usr/bin#" expect.man
+ sed -i "s#/usr/local/bin#${EPREFIX}/usr/bin#" expectk.man
+ #stops any example scripts being installed by default
+ sed -i \
+ -e '/^install:/s/install-libraries //' \
+ -e 's/^SCRIPTS_MANPAGES = /_&/' \
+ Makefile.in
+
+ #they forgot to include expect.m4 (now it's in expect cvs)
+ cp "${FILESDIR}/expect.m4" .
+ #configure broken for testsuite
+ sed -i -e 's/^AC_CONFIG_SUBDIRS(testsuite)$//' configure.in
+ #fixes "TCL_REG_BOSONLY undeclared" error due to a change in tcl8.5
+ sed -i -e 's/^#include "tcl.h"/#include "tclInt.h"/' exp_inter.c
+ #slacky destdir support in Makefile
+ epatch "${FILESDIR}/${P}-destdir.patch"
+
+ epatch "${FILESDIR}/${P}-gfbsd.patch"
+
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+
+ eautoconf
+}
+
+src_configure() {
+ local myconf
+ local tclv
+ local tkv
+ # Find the version of tcl/tk that has headers installed.
+ # This will be the most recently merged, not necessarily the highest
+ # version number.
+ tclv=$(grep TCL_VER ${EPREFIX}/usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
+ #tkv isn't really needed, included for symmetry and the future
+ #tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
+
+ #configure needs to find the files tclConfig.sh and tclInt.h
+ myconf="--with-tcl=${EPREFIX}/usr/$(get_libdir) --with-tclinclude=${EPREFIX}/usr/$(get_libdir)/tcl${tclv}/include/generic"
+
+ if use X ; then
+ #--with-x is enabled by default
+ #configure needs to find the file tkConfig.sh and tk.h
+ #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
+ myconf="$myconf --with-tk=${EPREFIX}/usr/$(get_libdir) --with-tkinclude=${EPREFIX}/usr/include"
+ else
+ #configure knows that tk depends on X so just disable X
+ myconf="$myconf --without-x"
+ fi
+
+ econf $myconf --enable-shared || die "econf failed"
+}
+
+src_test() {
+ # we need dejagnu to do tests ... but dejagnu needs
+ # expect ... so don't do tests unless we have dejagnu
+ type -p runtest || return 0
+ make check || die "make check failed"
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)
+ make install DESTDIR="${D}" || die "make install failed"
+
+ dodoc ChangeLog FAQ HISTORY NEWS README
+
+ local static_lib="lib${NON_MICRO_V/-/}.a"
+ rm "${ED}"/usr/$(get_libdir)/${NON_MICRO_V/-/}/${static_lib}
+
+ #install examples if 'doc' is set
+ if use doc ; then
+ docinto examples
+ local scripts=$(make -qp | \
+ sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
+ exeinto /usr/share/doc/${PF}/examples
+ doexe ${scripts}
+ local scripts_manpages=$(make -qp | \
+ sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
+ for m in ${scripts_manpages}; do
+ dodoc example/${m}.man
+ done
+ dodoc example/README
+ fi
+}
diff --git a/dev-tcltk/expect/files/expect-5.44.1-darwin.patch b/dev-tcltk/expect/files/expect-5.44.1-darwin.patch
new file mode 100644
index 000000000000..bdbfffb959dc
--- /dev/null
+++ b/dev-tcltk/expect/files/expect-5.44.1-darwin.patch
@@ -0,0 +1,15 @@
+http://bugs.gentoo.org/show_bug.cgi?id=287072
+
+patch by Stuart Shelton
+
+--- Makefile.in.dist 2009-10-09 15:09:49 +0100
++++ Makefile.in 2009-10-09 15:09:59 +0100
+@@ -148,7 +148,7 @@
+ RANLIB = @RANLIB@
+ RANLIB_STUB = @RANLIB_STUB@
+ SHLIB_CFLAGS = @SHLIB_CFLAGS@
+-SHLIB_LD = @SHLIB_LD@
++SHLIB_LD = @SHLIB_LD@ -install_name $(tcl_libdir)/$(EXP_SHARED_LIB_FILE)
+ SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
+ STLIB_LD = @STLIB_LD@
+ TCL_DEFS = @TCL_DEFS@
diff --git a/dev-tcltk/expect/files/expect-5.44.1-ldflags.patch b/dev-tcltk/expect/files/expect-5.44.1-ldflags.patch
new file mode 100644
index 000000000000..be3641c2105c
--- /dev/null
+++ b/dev-tcltk/expect/files/expect-5.44.1-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index cc2c79b..1083eaf 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -148,7 +148,7 @@ OBJEXT = @OBJEXT@
+ RANLIB = @RANLIB@
+ RANLIB_STUB = @RANLIB_STUB@
+ SHLIB_CFLAGS = @SHLIB_CFLAGS@
+-SHLIB_LD = @SHLIB_LD@
++SHLIB_LD = @SHLIB_LD@ $(LDFLAGS)
+ SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
+ STLIB_LD = @STLIB_LD@
+ TCL_DEFS = @TCL_DEFS@