summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-26 07:15:56 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-26 07:15:56 +0000
commitb95b1772e3e4f05f4b1ed996ad20d71440509ca8 (patch)
tree96a1ab24db2fd7aca30edf0aae71204e42048f70 /dev-tcltk
parentNew snapshot from CVS, fixes issues with Emacs 24, bug 459202. Remove old. Sp... (diff)
downloadgentoo-2-b95b1772e3e4f05f4b1ed996ad20d71440509ca8.tar.gz
gentoo-2-b95b1772e3e4f05f4b1ed996ad20d71440509ca8.tar.bz2
gentoo-2-b95b1772e3e4f05f4b1ed996ad20d71440509ca8.zip
dev-tcltk/tdom: Fix underlinking; fix typo in tcl8.6 patch; respect AR
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tdom/ChangeLog8
-rw-r--r--dev-tcltk/tdom/files/tdom-0.8.3-tcl8.6.patch2
-rw-r--r--dev-tcltk/tdom/tdom-0.8.3-r3.ebuild88
3 files changed, 96 insertions, 2 deletions
diff --git a/dev-tcltk/tdom/ChangeLog b/dev-tcltk/tdom/ChangeLog
index 7e84762f7cfa..8f2638eaa8f5 100644
--- a/dev-tcltk/tdom/ChangeLog
+++ b/dev-tcltk/tdom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/tdom
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tdom/ChangeLog,v 1.17 2013/01/15 14:21:40 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tdom/ChangeLog,v 1.18 2013/02/26 07:15:56 jlec Exp $
+
+*tdom-0.8.3-r3 (26 Feb 2013)
+
+ 26 Feb 2013; Justin Lecher <jlec@gentoo.org> +tdom-0.8.3-r3.ebuild,
+ files/tdom-0.8.3-tcl8.6.patch:
+ Fix underlinking; fix typo in tcl8.6 patch; respect AR
*tdom-0.8.3-r2 (15 Jan 2013)
diff --git a/dev-tcltk/tdom/files/tdom-0.8.3-tcl8.6.patch b/dev-tcltk/tdom/files/tdom-0.8.3-tcl8.6.patch
index 94bfa22d06e2..b61ec8c5d449 100644
--- a/dev-tcltk/tdom/files/tdom-0.8.3-tcl8.6.patch
+++ b/dev-tcltk/tdom/files/tdom-0.8.3-tcl8.6.patch
@@ -10,7 +10,7 @@ index 91d98c9..ae6d413 100644
char msg[64 + TCL_INTEGER_SPACE];
sprintf(msg, "\n (\"%s %s\" body line %d)", Tcl_GetString(objv[0]),
- Tcl_GetString(objv[1]), interp->errorLine);
-+ Tcl_GetString(objv[1]), TCL_GetErrorLine(interp));
++ Tcl_GetString(objv[1]), Tcl_GetErrorLine(interp));
Tcl_AddErrorInfo(interp, msg);
}
diff --git a/dev-tcltk/tdom/tdom-0.8.3-r3.ebuild b/dev-tcltk/tdom/tdom-0.8.3-r3.ebuild
new file mode 100644
index 000000000000..7d102e3bdc70
--- /dev/null
+++ b/dev-tcltk/tdom/tdom-0.8.3-r3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tdom/tdom-0.8.3-r3.ebuild,v 1.1 2013/02/26 07:15:56 jlec Exp $
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic multilib toolchain-funcs
+
+MY_P="tDOM-${PV}"
+
+DESCRIPTION="A XML/DOM/XPath/XSLT Implementation for Tcl"
+HOMEPAGE="http://tdom.github.com/"
+#SRC_URI="http://cloud.github.com/downloads/tDOM/${PN}/${MY_P}.tgz"
+SRC_URI="mirror://github/tDOM/${PN}/${MY_P}.tgz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs threads"
+
+DEPEND="
+ dev-lang/tcl:=
+ dev-libs/expat"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/"${PN}-0.8.2.patch
+ "${FILESDIR}/"${P}-soname.patch
+ "${FILESDIR}/"${P}-expat.patch
+ "${FILESDIR}/"${PN}-0.8.2-tnc.patch
+ "${FILESDIR}/"${P}-tcl8.6.patch
+ )
+
+src_prepare() {
+ tc-export AR
+ append-libs -lm
+ sed \
+ -e 's:-O2::g' \
+ -e 's:-pipe::g' \
+ -e 's:-fomit-frame-pointer::g' \
+ -e '/SHLIB_LD_LIBS/s:\"$: ${TCL_LIB_FLAG}":g' \
+ -i {.,extensions/tnc}/configure tclconfig/tcl.m4 || die
+ epatch "${PATCHES[@]}"
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable threads)
+ --enable-shared
+ --disable-tdomalloc
+ --with-expat
+ --with-tcl="${EPREFIX}"/usr/$(get_libdir)
+ )
+
+ cd "${S}"/unix && ECONF_SOURCE=".." econf ${myeconfargs}
+ cd "${S}"/extensions/tdomhtml && econf ${myeconfargs}
+ cd "${S}"/extensions/tnc && econf ${myeconfargs}
+}
+
+src_compile() {
+ local dir
+
+ for dir in "${S}"/unix "${S}"/extensions/tnc; do
+ pushd ${dir} > /dev/null
+ emake
+ popd > /dev/null
+ done
+}
+
+src_install() {
+ local dir
+
+ dodoc CHANGES ChangeLog README*
+
+ for dir in "${S}"/unix "${S}"/extensions/tdomhtml "${S}"/extensions/tnc; do
+ pushd ${dir} > /dev/null
+ emake DESTDIR="${D}" install
+ popd > /dev/null
+ done
+
+ if ! use static-libs; then
+ einfo "Removing static libs ..."
+ rm -f "${ED}"/usr/$(get_libdir)/*.{a,la} || die
+ fi
+}