summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-25 11:01:58 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-25 11:01:58 +0000
commit9ee524664b5be861e790edb6dee29a00ace7cc5d (patch)
tree0281a4046eeef9ddc76d7b201b13ccb1f604bd21 /dev-tcltk
parentversion bump (diff)
downloadgentoo-2-9ee524664b5be861e790edb6dee29a00ace7cc5d.tar.gz
gentoo-2-9ee524664b5be861e790edb6dee29a00ace7cc5d.tar.bz2
gentoo-2-9ee524664b5be861e790edb6dee29a00ace7cc5d.zip
Fix for build w/o tk, #319631; thanks Jonathan-Christofer Demay for digging out the patch
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/expect/ChangeLog7
-rw-r--r--dev-tcltk/expect/expect-5.44.1.15.ebuild15
-rw-r--r--dev-tcltk/expect/files/expect-5.44.1.15_with-tk-no.patch117
3 files changed, 131 insertions, 8 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 72c3228caad9..bae1987b18e7 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tcltk/expect
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.72 2010/04/28 19:58:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.73 2010/05/25 11:01:58 jlec Exp $
+
+ 25 May 2010; Justin Lecher <jlec@gentoo.org> expect-5.44.1.15.ebuild,
+ +files/expect-5.44.1.15_with-tk-no.patch:
+ Fix for build w/o tk, #319631; thanks Jonathan-Christofer Demay for
+ digging out the patch
28 Apr 2010; Justin Lecher <jlec@gentoo.org> expect-5.44.1.15.ebuild:
Fix for changed path of example files, #316885, thanks Juergen Rose for
diff --git a/dev-tcltk/expect/expect-5.44.1.15.ebuild b/dev-tcltk/expect/expect-5.44.1.15.ebuild
index 4f9ba7bd77ba..9291bf9b22c0 100644
--- a/dev-tcltk/expect/expect-5.44.1.15.ebuild
+++ b/dev-tcltk/expect/expect-5.44.1.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.44.1.15.ebuild,v 1.5 2010/04/28 19:58:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.44.1.15.ebuild,v 1.6 2010/05/25 11:01:58 jlec Exp $
EAPI="3"
@@ -37,6 +37,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-gfbsd.patch"
epatch "${FILESDIR}/${P}-ldflags.patch"
+ epatch "${FILESDIR}/${P}_with-tk-no.patch"
eautoconf
}
@@ -51,17 +52,17 @@ src_configure() {
tclv=$(grep TCL_VER ${EPREFIX}/usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
#tkv isn't really needed, included for symmetry and the future
#tkv=$(grep TK_VER ${EPREFIX}/usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
- myconf="--with-tcl=${EPREFIX}/usr/$(get_libdir) --with-tclinclude=${EPREFIX}/usr/$(get_libdir)/tcl${tclv}/include/generic"
+ myconf="--with-tcl=${EPREFIX}/usr/$(get_libdir) --with-tclinclude=${EPREFIX}/usr/$(get_libdir)/tcl${tclv}/include/generic --with-tk=yes"
-# if use X ; then
+ if use X ; then
#--with-x is enabled by default
#configure needs to find the file tkConfig.sh and tk.h
#tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
myconf="$myconf --with-tk=${EPREFIX}/usr/$(get_libdir) --with-tkinclude=${EPREFIX}/usr/include"
-# else
-# #configure knows that tk depends on X so just disable X
-# myconf="$myconf --without-x"
-# fi
+ else
+ #configure knows that tk depends on X so just disable X
+ myconf="$myconf --with-tk=no"
+ fi
econf \
$myconf \
diff --git a/dev-tcltk/expect/files/expect-5.44.1.15_with-tk-no.patch b/dev-tcltk/expect/files/expect-5.44.1.15_with-tk-no.patch
new file mode 100644
index 000000000000..cea372daaacb
--- /dev/null
+++ b/dev-tcltk/expect/files/expect-5.44.1.15_with-tk-no.patch
@@ -0,0 +1,117 @@
+This is a minimal patch that does not keep indentation consistent in tcl.m4
+Updating indentation would make the patch much bigger and less readable.
+
+Signed-off-by: Gilles Espinasse <g.esp@free.fr>
+
+Index: INSTALL
+===================================================================
+RCS file: /cvsroot/expect/expect/INSTALL,v
+retrieving revision 5.30
+diff -u -r5.30 INSTALL
+--- INSTALL 21 Jun 1999 18:41:41 -0000 5.30
++++ INSTALL 30 May 2009 11:51:21 -0000
+@@ -152,6 +152,7 @@
+
+ --with-tk=... Specifies the directory containing Tk's
+ configure file (tkConfig.sh).
++ --with-tk=no disable Tk usage in expect
+
+ --with-tkinclude=... Specifies the directory containing Tk's
+ private include files (such as tkInt.h)
+Index: Makefile.in
+===================================================================
+RCS file: /cvsroot/expect/expect/Makefile.in,v
+retrieving revision 5.45
+diff -u -r5.45 Makefile.in
+--- Makefile.in 3 Oct 2008 17:05:14 -0000 5.45
++++ Makefile.in 30 May 2009 11:51:21 -0000
+@@ -103,7 +103,11 @@
+ PKG_STUB_LIB_FILE = @PKG_STUB_LIB_FILE@
+
+ lib_BINARIES = $(PKG_LIB_FILE)
+-bin_BINARIES = expect expectk
++bin_BINARIES = expect
++ifneq ($(TK_BIN_DIR),)
++ bin_BINARIES += expectk
++endif
++
+ BINARIES = $(lib_BINARIES) $(bin_BINARIES)
+
+ SHELL = @SHELL@
+Index: tclconfig/tcl.m4
+===================================================================
+RCS file: /cvsroot/expect/expect/tclconfig/tcl.m4,v
+retrieving revision 1.3
+diff -u -r1.3 tcl.m4
+--- tclconfig/tcl.m4 25 Jan 2006 21:52:11 -0000 1.3
++++ tclconfig/tcl.m4 30 May 2009 11:51:23 -0000
+@@ -181,10 +181,12 @@
+ #
+ # Adds the following arguments to configure:
+ # --with-tk=...
++# --with-tk=no disable Tk usage
+ #
+ # Defines the following vars:
+ # TK_BIN_DIR Full path to the directory containing
+ # the tkConfig.sh file
++# Empty if Tk is disabled
+ #------------------------------------------------------------------------
+
+ AC_DEFUN(TEA_PATH_TKCONFIG, [
+@@ -201,6 +203,12 @@
+ AC_HELP_STRING([--with-tk],
+ [directory containing tk configuration (tkConfig.sh)]),
+ with_tkconfig=${withval})
++
++ if test x"${with_tkconfig}" = x"no" ; then
++ AC_MSG_RESULT([Tk is disabled by --with-tk=no])
++ unset TK_BIN_DIR
++ else
++
+ AC_MSG_CHECKING([for Tk configuration])
+ AC_CACHE_VAL(ac_cv_c_tkconfig,[
+
+@@ -309,6 +317,7 @@
+ TK_BIN_DIR=${ac_cv_c_tkconfig}
+ AC_MSG_RESULT([found ${TK_BIN_DIR}/tkConfig.sh])
+ fi
++ fi
+ fi
+ ])
+
+@@ -420,6 +429,7 @@
+ #------------------------------------------------------------------------
+
+ AC_DEFUN(TEA_LOAD_TKCONFIG, [
++ if test x"${with_tkconfig}" != x"no" ; then
+ AC_MSG_CHECKING([for existence of ${TK_BIN_DIR}/tkConfig.sh])
+
+ if test -f "${TK_BIN_DIR}/tkConfig.sh" ; then
+@@ -501,6 +511,7 @@
+
+ AC_SUBST(TK_LIBS)
+ AC_SUBST(TK_XINCLUDES)
++ fi
+ ])
+
+ #------------------------------------------------------------------------
+@@ -3528,6 +3539,11 @@
+ #------------------------------------------------------------------------
+
+ AC_DEFUN(TEA_PUBLIC_TK_HEADERS, [
++ if test x"${with_tkconfig}" = x"no" ; then
++ TK_INCLUDES=""
++ AC_SUBST(TK_INCLUDES)
++ else
++
+ AC_MSG_CHECKING([for Tk public headers])
+
+ AC_ARG_WITH(tkinclude, [ --with-tkinclude directory containing the public Tk header files.], with_tkinclude=${withval})
+@@ -3608,6 +3624,7 @@
+ fi
+ AC_MSG_RESULT([${INCLUDE_DIR_NATIVE}])
+ fi
++ fi
+ ])
+
+ #------------------------------------------------------------------------