summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-02 09:27:08 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-02 09:27:08 +0000
commit9e386fac3762074081a2003b8c8f8d2cd88a2a2c (patch)
tree099f402808733ce7aa732c318550c96c751a6658 /dev-tcltk
parentImported from prefix overlay, LDFALGS patch (diff)
downloadgentoo-2-9e386fac3762074081a2003b8c8f8d2cd88a2a2c.tar.gz
gentoo-2-9e386fac3762074081a2003b8c8f8d2cd88a2a2c.tar.bz2
gentoo-2-9e386fac3762074081a2003b8c8f8d2cd88a2a2c.zip
Imported from prefix overlay
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/snack/ChangeLog8
-rw-r--r--dev-tcltk/snack/files/snack-2.2.10-darwin.patch28
-rw-r--r--dev-tcltk/snack/snack-2.2.10-r4.ebuild88
3 files changed, 123 insertions, 1 deletions
diff --git a/dev-tcltk/snack/ChangeLog b/dev-tcltk/snack/ChangeLog
index 31bc966f6e06..a8a137c8dd3a 100644
--- a/dev-tcltk/snack/ChangeLog
+++ b/dev-tcltk/snack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/snack
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/ChangeLog,v 1.41 2010/03/31 21:18:12 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/ChangeLog,v 1.42 2010/04/02 09:27:08 jlec Exp $
+
+*snack-2.2.10-r4 (02 Apr 2010)
+
+ 02 Apr 2010; Justin Lecher <jlec@gentoo.org> +snack-2.2.10-r4.ebuild,
+ +files/snack-2.2.10-darwin.patch:
+ Imported from prefix overlay
*snack-2.2.10-r3 (31 Mar 2010)
diff --git a/dev-tcltk/snack/files/snack-2.2.10-darwin.patch b/dev-tcltk/snack/files/snack-2.2.10-darwin.patch
new file mode 100644
index 000000000000..8c6dc5285863
--- /dev/null
+++ b/dev-tcltk/snack/files/snack-2.2.10-darwin.patch
@@ -0,0 +1,28 @@
+* grobian@gentoo.org: need all symbols to be satisfied, need
+ install_name for actual usage
+
+--- unix/Makefile.in
++++ unix/Makefile.in
+@@ -35,7 +35,7 @@
+
+ LIBSO = -lc @ALIB@ @TCL_LIB_SPEC@
+
+-LIBSN = -lc @TK_LIBS@ @ALIB@ @TCL_LIB_SPEC@ @TK_LIB_SPEC@
++LIBSN = -lc -lX11 -ltk @TK_LIBS@ @ALIB@ @TCL_LIB_SPEC@ @TK_LIB_SPEC@
+
+ SHLIB_LD = @SHLIB_LD@
+ SHLIB_SUFFIX = @SHLIB_SUFFIX@
+@@ -158,11 +158,11 @@
+ $(CC) -c $(CFLAGS) $(GENERIC_DIR)/snackStubLib.c
+
+ libsound${SHLIB_SUFFIX}: ${OBJSO}
+- ${SHLIB_LD} ${OBJSO} ${LIBSO} -o libsound${SHLIB_SUFFIX}
++ ${SHLIB_LD} ${OBJSO} ${LIBSO} -install_name $(SNACK_INSTALL_PATH)/snack${VERSION}/libsound${SHLIB_SUFFIX} -o libsound${SHLIB_SUFFIX}
+ sed s/.dll/${SHLIB_SUFFIX}/ < $(UNIX_DIR)/pkgIndex.tcl.dll > pkgIndex.tcl
+
+ libsnack${SHLIB_SUFFIX}: ${OBJSN}
+- ${SHLIB_LD} ${OBJSN} ${LIBSN} -o libsnack${SHLIB_SUFFIX}
++ ${SHLIB_LD} ${OBJSN} ${LIBSN} -install_name $(SNACK_INSTALL_PATH)/snack${VERSION}/libsnack${SHLIB_SUFFIX} -o libsnack${SHLIB_SUFFIX}
+ sed s/.dll/${SHLIB_SUFFIX}/ < $(UNIX_DIR)/pkgIndex.tcl.dll > pkgIndex.tcl
+
+ stublib: ${OBJSNST}
diff --git a/dev-tcltk/snack/snack-2.2.10-r4.ebuild b/dev-tcltk/snack/snack-2.2.10-r4.ebuild
new file mode 100644
index 000000000000..56798f413cb0
--- /dev/null
+++ b/dev-tcltk/snack/snack-2.2.10-r4.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.10-r4.ebuild,v 1.1 2010/04/02 09:27:08 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="python? 2"
+
+inherit eutils multilib python
+
+DESCRIPTION="The Snack Sound Toolkit (Tcl)"
+HOMEPAGE="http://www.speech.kth.se/snack/"
+SRC_URI="http://www.speech.kth.se/snack/dist/${PN}${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+SLOT="0"
+IUSE="alsa examples python threads vorbis"
+
+RESTRICT="test" # Bug 78354
+
+DEPEND="
+ >dev-lang/tcl-8.4.3
+ >dev-lang/tk-8.4.3
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libvorbis )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}${PV}/unix"
+
+src_prepare() {
+ # bug 226137 - snack depends on alsa private symbol _snd_pcm_mmap_hw_ptr
+ epatch "${FILESDIR}"/alsa-undef-sym.patch
+ # bug 270839 - error from /usr/include/bits/mathcalls.h:310
+ sed -i -e 's|^\(#define roundf(.*\)|//\1|' ../generic/jkFormatMP3.c
+
+ # adds -install_name (soname on Darwin)
+ [[ ${CHOST} == *-darwin* ]] && epatch "${FILESDIR}"/${P}-darwin.patch
+}
+
+src_compile() {
+ local myconf="--libdir="${EPREFIX}"/usr/$(get_libdir) --includedir="${EPREFIX}"/usr/include"
+
+ use alsa && myconf="${myconf} --enable-alsa"
+ use threads && myconf="${myconf} --enable-threads"
+
+ if use vorbis ; then
+ myconf="${myconf} --with-ogg-include="${EPREFIX}"/usr/include"
+ myconf="${myconf} --with-ogg-lib="${EPREFIX}"/usr/$(get_libdir)"
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if use python ; then
+ cd "${S}"/../python
+ python setup.py install --root="${ED}" || die
+ fi
+
+ cd "${S}"/..
+
+ dodoc README changes
+ dohtml doc/*
+
+ if use examples ; then
+ sed -i -e 's/wish[0-9.]+/wish/g' demos/tcl/* || die
+ docinto examples/tcl
+ dodoc demos/tcl/*
+
+ if use python ; then
+ docinto examples/python
+ dodoc demos/python/*
+ fi
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize tkSnack.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup tkSnack.py
+}