summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-01-15 01:27:50 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-01-15 01:27:50 +0000
commit99121f71a5120446a6945ab1902f8b07efbef0a5 (patch)
tree02027e017a18cc2ee856114bd34ab2ff406a93fa /dev-tcltk
parentinitial commit (diff)
downloadgentoo-2-99121f71a5120446a6945ab1902f8b07efbef0a5.tar.gz
gentoo-2-99121f71a5120446a6945ab1902f8b07efbef0a5.tar.bz2
gentoo-2-99121f71a5120446a6945ab1902f8b07efbef0a5.zip
bumped up release numbers of packages that were updated with the tcl/tk
update
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/itcl/files/digest-itcl-3.2-r11
-rw-r--r--dev-tcltk/itcl/itcl-3.2-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-tcltk/itcl/files/digest-itcl-3.2-r1 b/dev-tcltk/itcl/files/digest-itcl-3.2-r1
new file mode 100644
index 000000000000..9e62103bda12
--- /dev/null
+++ b/dev-tcltk/itcl/files/digest-itcl-3.2-r1
@@ -0,0 +1 @@
+MD5 b41ed909969eaa5f0a06ab698393760f itcl3.2.tar.gz 1499136
diff --git a/dev-tcltk/itcl/itcl-3.2-r1.ebuild b/dev-tcltk/itcl/itcl-3.2-r1.ebuild
new file mode 100644
index 000000000000..68926d45dff5
--- /dev/null
+++ b/dev-tcltk/itcl/itcl-3.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/itcl/itcl-3.2-r1.ebuild,v 1.1 2002/01/15 01:27:50 gbevin Exp $
+
+S=${WORKDIR}/itcl${PV}
+DESCRIPTION="Object Oriented Enhancements for Tcl/Tk"
+SRC_URI="http://dev.scriptics.com/ftp/itcl/itcl${PV}.tar.gz"
+HOMEPAGE="http://dev.scriptics.com/ftp/itcl/"
+
+DEPEND=">=dev-lang/tk-8.4.2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ try patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ ./configure --prefix=/usr --host=${CHOST} || die
+ make CFLAGS_DEFAULT="${CFLAGS}" || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+
+ rm ${D}/usr/lib/iwidgets
+ ln -s iwidgets3.0.1 ${D}/usr/lib/iwidgets
+ dodoc CHANGES INCOMPATIBLE README TODO
+ cd ${S}/doc ; docinto doc
+ dodoc README
+}