summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-06-04 02:30:46 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-06-04 02:30:46 +0000
commit8854f559cf3b44976379177ba50567071a748345 (patch)
treea6f0a806eb91ecec16b064828987216d80406805 /dev-tcltk
parent~amd64 bug #134497 (diff)
downloadgentoo-2-8854f559cf3b44976379177ba50567071a748345.tar.gz
gentoo-2-8854f559cf3b44976379177ba50567071a748345.tar.bz2
gentoo-2-8854f559cf3b44976379177ba50567071a748345.zip
Fixed bash-3.1 issue
(Portage version: 2.1_rc4)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tclxml/ChangeLog5
-rw-r--r--dev-tcltk/tclxml/tclxml-2.6.ebuild14
2 files changed, 16 insertions, 3 deletions
diff --git a/dev-tcltk/tclxml/ChangeLog b/dev-tcltk/tclxml/ChangeLog
index 556603fe3ba2..5ecc1f3a3feb 100644
--- a/dev-tcltk/tclxml/ChangeLog
+++ b/dev-tcltk/tclxml/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-tcltk/tclxml
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/ChangeLog,v 1.22 2006/06/03 19:54:56 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/ChangeLog,v 1.23 2006/06/04 02:30:46 matsuu Exp $
+
+ 04 Jun 2006; MATSUU Takuto <matsuu@gentoo.org> tclxml-2.6.ebuild:
+ Fixed bash-3.1 issue
03 Jun 2006; MATSUU Takuto <matsuu@gentoo.org> tclxml-3.0-r1.ebuild,
tclxml-3.1.ebuild:
diff --git a/dev-tcltk/tclxml/tclxml-2.6.ebuild b/dev-tcltk/tclxml/tclxml-2.6.ebuild
index 3e1cb3126f8d..cc673c2f775c 100644
--- a/dev-tcltk/tclxml/tclxml-2.6.ebuild
+++ b/dev-tcltk/tclxml/tclxml-2.6.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-2.6.ebuild,v 1.9 2005/04/07 13:56:01 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-2.6.ebuild,v 1.10 2006/06/04 02:30:46 matsuu Exp $
+
+inherit eutils
DESCRIPTION="Pure Tcl implementation of an XML parser."
HOMEPAGE="http://tclxml.sourceforge.net/"
@@ -11,6 +13,14 @@ SLOT="0"
KEYWORDS="x86 ~ppc sparc alpha ~amd64"
DEPEND=">=dev-lang/tcl-8.3.3"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i -e "s/relid'/relid/" \
+ configure tcl.m4 tclconfig/tcl.m4 expat/configure || die
+}
+
src_compile() {
econf || die
make || die