summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-01-08 15:15:25 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-01-08 15:15:25 +0000
commit7bd8b10129ee5c0ef165bc378b1b837da1b06c8e (patch)
tree5448fe764089a5bb06fb179cb76fb9ec38d2c4a6 /dev-tcltk
parentMove the ai-patch to the mirrors because it has a cvs Id tag and thus breaks ... (diff)
downloadgentoo-2-7bd8b10129ee5c0ef165bc378b1b837da1b06c8e.tar.gz
gentoo-2-7bd8b10129ee5c0ef165bc378b1b837da1b06c8e.tar.bz2
gentoo-2-7bd8b10129ee5c0ef165bc378b1b837da1b06c8e.zip
Version bumped, Bug 117121.
(Portage version: 2.0.53)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/thread/ChangeLog9
-rw-r--r--dev-tcltk/thread/Manifest12
-rw-r--r--dev-tcltk/thread/files/digest-thread-2.6.21
-rw-r--r--dev-tcltk/thread/thread-2.6.2.ebuild59
4 files changed, 69 insertions, 12 deletions
diff --git a/dev-tcltk/thread/ChangeLog b/dev-tcltk/thread/ChangeLog
index 98cea70c8c5d..57263a4b200e 100644
--- a/dev-tcltk/thread/ChangeLog
+++ b/dev-tcltk/thread/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tcltk/thread
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.3 2005/11/16 11:27:05 herbs Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.4 2006/01/08 15:15:25 matsuu Exp $
+
+*thread-2.6.2 (08 Jan 2006)
+
+ 08 Jan 2006; MATSUU Takuto <matsuu@gentoo.org> +thread-2.6.2.ebuild:
+ Version bumped. Bug 117121.
16 Nov 2005; Herbie Hopkins <herbs@gentoo.org> thread-2.6.1.ebuild:
Multilib fix.
diff --git a/dev-tcltk/thread/Manifest b/dev-tcltk/thread/Manifest
index 10687bed38ac..fafac3b6d0e9 100644
--- a/dev-tcltk/thread/Manifest
+++ b/dev-tcltk/thread/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 fd0b6946646b51f640fea3b6d1a6cb2b ChangeLog 586
MD5 9b4c86b16329dae30cdefd49b1e31f68 files/digest-thread-2.6.1 63
+MD5 6d37f504d8438a12a11fdb217d868062 files/digest-thread-2.6.2 63
MD5 43e377139ff5f3b7415b94a8c8d5260d metadata.xml 158
MD5 0485e2ab2787a91f581d98d07cd85cf5 thread-2.6.1.ebuild 1362
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDexeY2G5bA0cA/ScRAjuUAJ9tj/WQLi9zcVtacozi4+8EjR9PlwCfU+ue
-HHEaM4o2cKrIaliiU1L0zJo=
-=COIn
------END PGP SIGNATURE-----
+MD5 af0161ffc231e90118d488d0fc2f0f80 thread-2.6.2.ebuild 1423
diff --git a/dev-tcltk/thread/files/digest-thread-2.6.2 b/dev-tcltk/thread/files/digest-thread-2.6.2
new file mode 100644
index 000000000000..526e940b31e4
--- /dev/null
+++ b/dev-tcltk/thread/files/digest-thread-2.6.2
@@ -0,0 +1 @@
+MD5 316d025176e46b68db6db03755a6927d thread2.6.2.tar.gz 267344
diff --git a/dev-tcltk/thread/thread-2.6.2.ebuild b/dev-tcltk/thread/thread-2.6.2.ebuild
new file mode 100644
index 000000000000..ea2ce8bd1dd3
--- /dev/null
+++ b/dev-tcltk/thread/thread-2.6.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.2.ebuild,v 1.1 2006/01/08 15:15:25 matsuu Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="the Tcl Thread extension"
+HOMEPAGE="http://www.tcl.tk/"
+SRC_URI="mirror://sourceforge/tcl/${PN}${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="gdbm"
+
+DEPEND="gdbm? ( sys-libs/gdbm )
+ >=dev-lang/tcl-8.4"
+
+S="${WORKDIR}/${PN}${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Search for libs in libdir not just exec_prefix/lib
+ sed -i -e 's:${exec_prefix}/lib:${libdir}:' \
+ aclocal.m4 || die "sed failed"
+
+ sed -i -e "s/relid'/relid/" tclconfig/tcl.m4 || die
+
+ aclocal || die "aclocal failed"
+ autoconf || die "autoconf failed"
+}
+
+pkg_setup() {
+ if ! built_with_use dev-lang/tcl threads ; then
+ eerror "dev-lang/tcl was not merged with threading enabled."
+ eerror "please re-emerge dev-lang/tcl with USE=threads"
+ die "threading not enabled in dev-lang/tcl"
+ fi
+}
+
+src_compile() {
+ local myconf="--with-threads --with-tclinclude=/usr/include \
+ --with-tcl=/usr/$(get_libdir)"
+
+ if use gdbm ; then
+ myconf="${myconf} --with-gdbm"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog README
+}