summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-26 18:45:17 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-26 18:45:17 +0000
commit4fd6f2f438af5afa64eb646d21965487229378a3 (patch)
tree84270a534daded407414c3b701acea25c6c0dc6f /dev-tcltk
parentsci-libs/scikits_learn: Add missing dep for doc building, #451834 (diff)
downloadgentoo-2-4fd6f2f438af5afa64eb646d21965487229378a3.tar.gz
gentoo-2-4fd6f2f438af5afa64eb646d21965487229378a3.tar.bz2
gentoo-2-4fd6f2f438af5afa64eb646d21965487229378a3.zip
dev-tcltk/tclpython: Bump to EAPI=5 and new python eclasses; add py3 support, #509738
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tclpython/ChangeLog10
-rw-r--r--dev-tcltk/tclpython/metadata.xml2
-rw-r--r--dev-tcltk/tclpython/tclpython-4.1-r3.ebuild47
3 files changed, 56 insertions, 3 deletions
diff --git a/dev-tcltk/tclpython/ChangeLog b/dev-tcltk/tclpython/ChangeLog
index e5ab3803c29e..e2cdf764533e 100644
--- a/dev-tcltk/tclpython/ChangeLog
+++ b/dev-tcltk/tclpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/tclpython
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/ChangeLog,v 1.17 2011/05/23 07:17:52 tomka Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/ChangeLog,v 1.18 2014/10/26 18:45:17 jlec Exp $
+
+*tclpython-4.1-r3 (26 Oct 2014)
+
+ 26 Oct 2014; Justin Lecher <jlec@gentoo.org> +tclpython-4.1-r3.ebuild,
+ metadata.xml:
+ Bump to EAPI=5 and new python eclasses; add py3 support, #509738
23 May 2011; Thomas Kahle <tomka@gentoo.org> tclpython-4.1-r2.ebuild:
x86 stable per bug 364825
diff --git a/dev-tcltk/tclpython/metadata.xml b/dev-tcltk/tclpython/metadata.xml
index d9408d8ab078..70ac40499556 100644
--- a/dev-tcltk/tclpython/metadata.xml
+++ b/dev-tcltk/tclpython/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>tcltk</herd>
+ <herd>tcltk</herd>
</pkgmetadata>
diff --git a/dev-tcltk/tclpython/tclpython-4.1-r3.ebuild b/dev-tcltk/tclpython/tclpython-4.1-r3.ebuild
new file mode 100644
index 000000000000..2007324646af
--- /dev/null
+++ b/dev-tcltk/tclpython/tclpython-4.1-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/tclpython-4.1-r3.ebuild,v 1.1 2014/10/26 18:45:17 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="Python package for Tcl"
+HOMEPAGE="http://jfontain.free.fr/tclpython.htm"
+SRC_URI="http://jfontain.free.fr/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-lang/tcl"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local cfile="tclpython tclthread"
+ for src in ${cfile}; do
+ compile="$(tc-getCC) -shared -fPIC ${CFLAGS} -I$(python_get_includedir) -c ${src}.c"
+ einfo "${compile}"
+ eval "${compile}" || die
+ done
+
+ link="$(tc-getCC) -fPIC -shared ${LDFLAGS} -o tclpython.so.${PV} tclpython.o tclthread.o -lpthread -lutil $(python_get_LIBS) -ltcl"
+ einfo "${link}"
+ eval "${link}" || die
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/tclpython
+ doins tclpython.so.${PV} pkgIndex.tcl
+ fperms 775 /usr/$(get_libdir)/tclpython/tclpython.so.${PV}
+ dosym tclpython.so.${PV} /usr/$(get_libdir)/tclpython/tclpython.so
+
+ dodoc CHANGES INSTALL README
+ dohtml tclpython.htm
+}