summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-02 06:03:44 +0000
committerJustin Lecher <jlec@gentoo.org>2011-05-02 06:03:44 +0000
commit3c59d1f669deda554bbb2dd6ba94e49ea7b0ceec (patch)
tree52e493cc07509283261d221f5d8a3108b3d6571b /dev-tcltk
parentFix USE=static in other ebuilds too. (diff)
downloadgentoo-2-3c59d1f669deda554bbb2dd6ba94e49ea7b0ceec.tar.gz
gentoo-2-3c59d1f669deda554bbb2dd6ba94e49ea7b0ceec.tar.bz2
gentoo-2-3c59d1f669deda554bbb2dd6ba94e49ea7b0ceec.zip
Respect LDFLAGS, #336129
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/mysqltcl/ChangeLog9
-rw-r--r--dev-tcltk/mysqltcl/files/mysqltcl-3.05-ldflags.patch16
-rw-r--r--dev-tcltk/mysqltcl/mysqltcl-2.40.ebuild18
-rw-r--r--dev-tcltk/mysqltcl/mysqltcl-2.50.ebuild15
-rw-r--r--dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild28
5 files changed, 57 insertions, 29 deletions
diff --git a/dev-tcltk/mysqltcl/ChangeLog b/dev-tcltk/mysqltcl/ChangeLog
index c9f7fffc5b76..7d6b8ce130aa 100644
--- a/dev-tcltk/mysqltcl/ChangeLog
+++ b/dev-tcltk/mysqltcl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tcltk/mysqltcl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mysqltcl/ChangeLog,v 1.14 2010/03/24 21:30:28 robbat2 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mysqltcl/ChangeLog,v 1.15 2011/05/02 06:03:44 jlec Exp $
+
+ 02 May 2011; Justin Lecher <jlec@gentoo.org> mysqltcl-2.40.ebuild,
+ mysqltcl-2.50.ebuild, mysqltcl-3.05.ebuild,
+ +files/mysqltcl-3.05-ldflags.patch:
+ Respect LDFLAGS, #336129
24 Mar 2010; Robin H. Johnson <robbat2@gentoo.org> mysqltcl-3.05.ebuild:
Bug #264690: fix compile on non-symlink multilib systems.
diff --git a/dev-tcltk/mysqltcl/files/mysqltcl-3.05-ldflags.patch b/dev-tcltk/mysqltcl/files/mysqltcl-3.05-ldflags.patch
new file mode 100644
index 000000000000..5aa440332153
--- /dev/null
+++ b/dev-tcltk/mysqltcl/files/mysqltcl-3.05-ldflags.patch
@@ -0,0 +1,16 @@
+ Makefile.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 0552d56..e32a0b4 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -107,7 +107,7 @@ OBJEXT = @OBJEXT@
+ RANLIB = @RANLIB@
+ RANLIB_STUB = @RANLIB_STUB@
+ SHLIB_CFLAGS = @SHLIB_CFLAGS@
+-SHLIB_LD = @SHLIB_LD@
++SHLIB_LD = @SHLIB_LD@ $(LDFLAGS)
+ SHLIB_LD_LIBS = @SHLIB_LD_LIBS@ @MYSQL_LIBS@
+ STLIB_LD = @STLIB_LD@
+ #TCL_DEFS = @TCL_DEFS@
diff --git a/dev-tcltk/mysqltcl/mysqltcl-2.40.ebuild b/dev-tcltk/mysqltcl/mysqltcl-2.40.ebuild
index f66006d3b0dd..56ea667fd934 100644
--- a/dev-tcltk/mysqltcl/mysqltcl-2.40.ebuild
+++ b/dev-tcltk/mysqltcl/mysqltcl-2.40.ebuild
@@ -1,17 +1,20 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mysqltcl/mysqltcl-2.40.ebuild,v 1.6 2006/11/23 17:37:23 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mysqltcl/mysqltcl-2.40.ebuild,v 1.7 2011/05/02 06:03:44 jlec Exp $
DESCRIPTION="TCL MySQL Interface"
HOMEPAGE="http://www.xdobry.de/mysqltcl/"
SRC_URI="http://www.xdobry.de/mysqltcl/${P}.tar.gz"
+
IUSE=""
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86"
-DEPEND=">=dev-lang/tcl-8.1.0
+DEPEND="
+ dev-lang/tcl
virtual/mysql"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
@@ -21,13 +24,12 @@ src_unpack() {
}
src_compile() {
- econf || die
+ econf
emake || die
}
src_install() {
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING README README-msqltcl ChangeLog
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README README-msqltcl ChangeLog
dohtml doc/mysqltcl.html
- prepalldocs
-}
+} \ No newline at end of file
diff --git a/dev-tcltk/mysqltcl/mysqltcl-2.50.ebuild b/dev-tcltk/mysqltcl/mysqltcl-2.50.ebuild
index bc2070c9b859..5d61d27bc0cd 100644
--- a/dev-tcltk/mysqltcl/mysqltcl-2.50.ebuild
+++ b/dev-tcltk/mysqltcl/mysqltcl-2.50.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mysqltcl/mysqltcl-2.50.ebuild,v 1.6 2006/11/23 17:37:23 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mysqltcl/mysqltcl-2.50.ebuild,v 1.7 2011/05/02 06:03:44 jlec Exp $
DESCRIPTION="TCL MySQL Interface"
HOMEPAGE="http://www.xdobry.de/mysqltcl/"
@@ -11,17 +11,18 @@ SLOT="0"
KEYWORDS="~x86 ~amd64 ~ppc"
IUSE=""
-DEPEND=">=dev-lang/tcl-8.1.0
+DEPEND="
+ dev-lang/tcl
virtual/mysql"
+RDEPEND="${DEPEND}"
src_compile() {
- econf || die
+ econf
emake || die
}
src_install() {
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING README README-msqltcl ChangeLog
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README README-msqltcl ChangeLog
dohtml doc/mysqltcl.html
- prepalldocs
}
diff --git a/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild b/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild
index f46015347da3..ed4aa17d0644 100644
--- a/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild
+++ b/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild,v 1.2 2010/03/24 21:30:28 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild,v 1.3 2011/05/02 06:03:44 jlec Exp $
-inherit multilib
+EAPI=4
+
+inherit eutils multilib
DESCRIPTION="TCL MySQL Interface"
HOMEPAGE="http://www.xdobry.de/mysqltcl/"
@@ -13,18 +15,20 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""
-DEPEND=">=dev-lang/tcl-8.1.0
+DEPEND="
+ dev-lang/tcl
>=virtual/mysql-4.1"
RDEPEND="${DEPEND}"
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS README README-msqltcl ChangeLog
- dohtml doc/mysqltcl.html
- prepalldocs
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
}
-src_compile() {
- econf --with-mysql-lib=/usr/$(get_libdir)/mysql || die
- emake || die
+src_configure() {
+ econf --with-mysql-lib=/usr/$(get_libdir)/mysql
+}
+
+src_install() {
+ default
+ dohtml doc/mysqltcl.html
}