summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-02 22:13:19 +0000
committerJustin Lecher <jlec@gentoo.org>2012-01-02 22:13:19 +0000
commit2a4d61a2dba359cc8cfbd9a130e4469adf129846 (patch)
treeae6f0b8dcfa2191ee7fd4ea30b82c20ba7b40fe1 /dev-tcltk
parentSupport reading of compressed pci/usb databases #360849 by Samuli Suominen. (diff)
downloadgentoo-2-2a4d61a2dba359cc8cfbd9a130e4469adf129846.tar.gz
gentoo-2-2a4d61a2dba359cc8cfbd9a130e4469adf129846.tar.bz2
gentoo-2-2a4d61a2dba359cc8cfbd9a130e4469adf129846.zip
Moved to EAPI=4, handle static-libs correctly
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tdom/ChangeLog7
-rw-r--r--dev-tcltk/tdom/metadata.xml4
-rw-r--r--dev-tcltk/tdom/tdom-0.8.3.ebuild61
3 files changed, 38 insertions, 34 deletions
diff --git a/dev-tcltk/tdom/ChangeLog b/dev-tcltk/tdom/ChangeLog
index e827565fb77b..40dfdd892388 100644
--- a/dev-tcltk/tdom/ChangeLog
+++ b/dev-tcltk/tdom/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-tcltk/tdom
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tdom/ChangeLog,v 1.11 2011/01/24 13:12:11 fauli Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tdom/ChangeLog,v 1.12 2012/01/02 22:13:19 jlec Exp $
+
+ 02 Jan 2012; Justin Lecher <jlec@gentoo.org> tdom-0.8.3.ebuild, metadata.xml:
+ Moved to EAPI=4, handle static-libs correctly
24 Jan 2011; Christian Faulhammer <fauli@gentoo.org> tdom-0.8.2.ebuild:
stable x86, bug 351766
diff --git a/dev-tcltk/tdom/metadata.xml b/dev-tcltk/tdom/metadata.xml
index 8ea740992822..8de41d4281f0 100644
--- a/dev-tcltk/tdom/metadata.xml
+++ b/dev-tcltk/tdom/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>tcltk</herd>
-<longdescription>
+ <herd>tcltk</herd>
+ <longdescription>
tDOM combines high performance XML data processing with easy and
powerful Tcl scripting functionality. tDOM should be one of the fastest
ways to manipulate XML with a scripting language and uses very few
diff --git a/dev-tcltk/tdom/tdom-0.8.3.ebuild b/dev-tcltk/tdom/tdom-0.8.3.ebuild
index f8aa5a7b2e47..6f17856769ae 100644
--- a/dev-tcltk/tdom/tdom-0.8.3.ebuild
+++ b/dev-tcltk/tdom/tdom-0.8.3.ebuild
@@ -1,21 +1,22 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tdom/tdom-0.8.3.ebuild,v 1.1 2011/01/21 08:00:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tdom/tdom-0.8.3.ebuild,v 1.2 2012/01/02 22:13:19 jlec Exp $
-EAPI="3"
+EAPI=4
-inherit autotools eutils
+inherit autotools eutils multilib
MY_P="tDOM-${PV}"
DESCRIPTION="A XML/DOM/XPath/XSLT Implementation for Tcl"
-HOMEPAGE="http://tdom.github.com"
-SRC_URI="http://cloud.github.com/downloads/tDOM/${PN}/${MY_P}.tgz"
+HOMEPAGE="http://tdom.github.com/"
+#SRC_URI="http://cloud.github.com/downloads/tDOM/${PN}/${MY_P}.tgz"
+SRC_URI="mirror://github/tDOM/${PN}/${MY_P}.tgz"
LICENSE="MPL-1.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="threads"
+IUSE="static-libs threads"
DEPEND="
dev-lang/tcl
@@ -24,42 +25,37 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}/"${PN}-0.8.2.patch
+ "${FILESDIR}/"${PN}-0.8.2-soname.patch
+ "${FILESDIR}/"${P}-expat.patch
+ "${FILESDIR}/"${PN}-0.8.2-tnc.patch
+ )
+
src_prepare() {
- epatch \
- "${FILESDIR}/"${PN}-0.8.2.patch \
- "${FILESDIR}/"${PN}-0.8.2-soname.patch \
- "${FILESDIR}/"${P}-expat.patch \
- "${FILESDIR}/"${PN}-0.8.2-tnc.patch
+ epatch "${PATCHES[@]}"
eautoreconf
}
src_configure() {
- local myconf=""
-
- myconf="${myconf}
+ local myeconfargs=(
$(use_enable threads)
--enable-shared
--disable-tdomalloc
- --with-expat"
-
- cd "${S}"/unix
- ECONF_SOURCE=".." econf ${myconf}
+ --with-expat
+ )
- # compile tdomhtml
- cd "${S}"/extensions/tdomhtml
- econf
-
- # compile tnc
- cd "${S}"/extensions/tnc
- econf ${myconf}
+ cd "${S}"/unix && ECONF_SOURCE=".." econf ${myeconfargs}
+ cd "${S}"/extensions/tdomhtml && econf ${myeconfargs}
+ cd "${S}"/extensions/tnc && econf ${myeconfargs}
}
src_compile() {
local dir
- for dir in "${S}"/unix "${S}"/extensions/tdomhtml "${S}"/extensions/tnc; do
+ for dir in "${S}"/unix "${S}"/extensions/tnc; do
pushd ${dir} > /dev/null
- emake || die
+ emake
popd > /dev/null
done
}
@@ -67,11 +63,16 @@ src_compile() {
src_install() {
local dir
- dodoc CHANGES ChangeLog README* || die
+ dodoc CHANGES ChangeLog README*
for dir in "${S}"/unix "${S}"/extensions/tdomhtml "${S}"/extensions/tnc; do
pushd ${dir} > /dev/null
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install
popd > /dev/null
done
+
+ if ! use static-libs; then
+ einfo "Removing static libs ..."
+ rm -f "${ED}"/usr/$(get_libdir)/*.{a,la} || die
+ fi
}