summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-07-03 01:20:12 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-07-03 01:20:12 +0000
commit0bc21ba09aaa5ec78a11d78e21927043a58a1e79 (patch)
tree5716e5dda476a3f52da988609bb85dcb96ce3bc5 /dev-tcltk
parentmarked stable on x86 (diff)
downloadgentoo-2-0bc21ba09aaa5ec78a11d78e21927043a58a1e79.tar.gz
gentoo-2-0bc21ba09aaa5ec78a11d78e21927043a58a1e79.tar.bz2
gentoo-2-0bc21ba09aaa5ec78a11d78e21927043a58a1e79.zip
Fixed Bug 97737, Bug 97738.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/thread/ChangeLog6
-rw-r--r--dev-tcltk/thread/thread-2.6.1.ebuild14
2 files changed, 13 insertions, 7 deletions
diff --git a/dev-tcltk/thread/ChangeLog b/dev-tcltk/thread/ChangeLog
index df33738e6b2a..2c39db0b0d7b 100644
--- a/dev-tcltk/thread/ChangeLog
+++ b/dev-tcltk/thread/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/thread
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.1 2005/07/02 15:20:41 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.2 2005/07/03 01:20:12 matsuu Exp $
+
+ 03 Jul 2005; MATSUU Takuto <matsuu@gentoo.org> thread-2.6.1.ebuild:
+ Fixed with gdbm cofigure issue. Bug 97738.
+ Fixed DISCRIPTION. Bug 97739.
*thread-2.6.1 (02 Jul 2005)
diff --git a/dev-tcltk/thread/thread-2.6.1.ebuild b/dev-tcltk/thread/thread-2.6.1.ebuild
index 98cb09d318bd..0436f27ee3d2 100644
--- a/dev-tcltk/thread/thread-2.6.1.ebuild
+++ b/dev-tcltk/thread/thread-2.6.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.1.ebuild,v 1.1 2005/07/02 15:20:41 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.1.ebuild,v 1.2 2005/07/03 01:20:12 matsuu Exp $
inherit eutils
-DESCRIPTION="This is a sample skeleton ebuild file"
+DESCRIPTION="the Tcl Thread extension"
HOMEPAGE="http://www.tcl.tk/"
SRC_URI="mirror://sourceforge/tcl/${PN}${PV}.tar.gz"
@@ -27,10 +27,12 @@ pkg_setup() {
}
src_compile() {
- econf \
- --with-threads \
- --with-tclinclude=/usr/include \
- `use_with gdbm` || die "econf failed"
+ local myconf="--with-threads --with-tclinclude=/usr/include"
+
+ if use gdbm ; then
+ myconf="${myconf} --with-gdbm"
+ fi
+ econf ${myconf} || die "econf failed"
emake || die "emake failed"
}