summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-28 00:25:16 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-28 00:25:16 +0000
commit085b12a15f87d6f48fb2a1c1afce3ec89145cb83 (patch)
tree0d9e66160c2a4607ea3e99ee18d6faa90ba79ab1 /dev-tcltk
parentversion bump (diff)
downloadgentoo-2-085b12a15f87d6f48fb2a1c1afce3ec89145cb83.tar.gz
gentoo-2-085b12a15f87d6f48fb2a1c1afce3ec89145cb83.tar.bz2
gentoo-2-085b12a15f87d6f48fb2a1c1afce3ec89145cb83.zip
touchups
(Portage version: 2.1_pre5-r1)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tclx/tclx-8.3.5.ebuild32
1 files changed, 12 insertions, 20 deletions
diff --git a/dev-tcltk/tclx/tclx-8.3.5.ebuild b/dev-tcltk/tclx/tclx-8.3.5.ebuild
index 3f5449e65aa6..fa329b15f589 100644
--- a/dev-tcltk/tclx/tclx-8.3.5.ebuild
+++ b/dev-tcltk/tclx/tclx-8.3.5.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.3.5.ebuild,v 1.11 2005/05/04 11:28:35 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.3.5.ebuild,v 1.12 2006/02/28 00:25:16 vapier Exp $
inherit flag-o-matic eutils
-IUSE="X"
-
DESCRIPTION="A set of extensions to TCL"
HOMEPAGE="http://tclx.sourceforge.net"
SRC_URI="mirror://sourceforge/tclx/${PN}${PV}-src.tar.gz
@@ -14,22 +12,18 @@ SRC_URI="mirror://sourceforge/tclx/${PN}${PV}-src.tar.gz
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86 ppc alpha amd64 ~sparc"
+KEYWORDS="alpha amd64 ppc ~sparc x86"
+IUSE="X"
-DEPEND=">=sys-apps/sed-4
- >=dev-lang/tcl-8.4.6
+DEPEND=">=dev-lang/tcl-8.4.6
X? ( >=dev-lang/tk-8.4.6 )"
S=${WORKDIR}/${PN}${PV}
-# Not necessary ! see BUG #55238
-# Danny van Dyk <kugelfang@gentoo.org> 2004/08/30
-# [ $ARCH = alpha ] && append-flags -fPIC
-# [ "${ARCH}" = "amd64" ] && append-flags -fPIC
-
src_unpack() {
- unpack ${A} ; cd ${S}
- epatch ${FILESDIR}/${PN}-8.3-varinit.patch
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-8.3-varinit.patch
sed -i \
-e "/^TCLX_INST_MAN/ s:=.*:= \$\{TCLX_PREFIX\}/share/man:" \
@@ -39,7 +33,7 @@ src_unpack() {
src_compile() {
# we have to configure and build tcl before we can do tclx
- cd ${WORKDIR}/tcl8.4.6/unix
+ cd "${WORKDIR}"/tcl8.4.6/unix
econf || die "econf failed"
emake CFLAGS="${CFLAGS}" || die "emake in tcl/unix failed"
@@ -62,11 +56,9 @@ src_compile() {
}
src_install() {
- echo "installing tclx"
- cd ${S}/unix
- make INSTALL_ROOT=${D} install
- cd ${S}
+ cd "${S}"/unix
+ make INSTALL_ROOT="${D}" install || die
+ cd "${S}"
dodoc CHANGES README TO-DO doc/CONVERSION-NOTES
doman doc/*.[n3]
}
-