summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-27 10:21:45 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-27 10:21:45 +0000
commitc26662c813ecfab6dd2a6861ac16493bfccfaac5 (patch)
treee8f2b826e67dcc54a82be582114f6ba1ee439de3 /dev-tcltk/tix
parentAdded glibc's local USE flags (diff)
downloadgentoo-2-c26662c813ecfab6dd2a6861ac16493bfccfaac5.tar.gz
gentoo-2-c26662c813ecfab6dd2a6861ac16493bfccfaac5.tar.bz2
gentoo-2-c26662c813ecfab6dd2a6861ac16493bfccfaac5.zip
cleanup
Diffstat (limited to 'dev-tcltk/tix')
-rw-r--r--dev-tcltk/tix/tix-8.2.0.ebuild64
1 files changed, 17 insertions, 47 deletions
diff --git a/dev-tcltk/tix/tix-8.2.0.ebuild b/dev-tcltk/tix/tix-8.2.0.ebuild
index 30cff868049e..64a60951a2e1 100644
--- a/dev-tcltk/tix/tix-8.2.0.ebuild
+++ b/dev-tcltk/tix/tix-8.2.0.ebuild
@@ -1,40 +1,35 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/tix-8.2.0.ebuild,v 1.5 2003/03/25 22:13:02 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/tix-8.2.0.ebuild,v 1.6 2003/03/27 10:21:45 seemant Exp $
-IUSE="tcl tk threads shared"
-MY_P=${PN}${PV}
-S=${WORKDIR}/${MY_P}
+IUSE=""
+
+MY_P=${P/-/}
+S=${WORKDIR}/${MY_P}/unix
DESCRIPTION="A widget library for Tcl/Tk. Has been ported to Python and Perl, too."
HOMEPAGE="http://sourceforge.net/projects/tixlibrary/"
-SRC_URI="mirror://sourceforge/tixlibrary/tix8.2.0b1.tar.gz"
+SRC_URI="mirror://sourceforge/tixlibrary/${MY_P}b1.tar.gz"
LICENSE="as-is BSD"
SLOT="0"
KEYWORDS="~x86 ~ppc"
-DEPEND="dev-lang/tk"
-#RDEPEND=""
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ >=sys-apps/sed-4.0.5
+ dev-lang/tk"
fix_makefile() {
- mv ${S}/$1/Makefile ${S}/$1/Makefile_orig
- sed -e "s:$2:$3:" \
- ${S}/$1/Makefile_orig \
- > ${S}/$1/Makefile
+ sed -i "s:$1:$2:" ${S}/Makefile
}
src_unpack() {
unpack ${A}
- cd ${S}
- patch -p1 < ${FILESDIR}/${PF}-gentoo.diff || die
+ cd ${S}/..
+ epatch ${FILESDIR}/${PF}-gentoo.diff || die
}
src_compile() {
- cd ${S}/unix ; ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
+ econf \
--enable-gcc \
--with-tcl=/usr/lib \
--with-tk=/usr/lib \
@@ -42,38 +37,13 @@ src_compile() {
--enable-threads \
--enable-shared || die "./configure failed"
- echo "##"
- echo "## Fixing the Makefile..."
- echo "##"
- fix_makefile unix "\$(TK_SRC_DIR)" "/usr/lib/tk8.3/include"
+ ebegin "Fixing the Makefile..."
+ fix_makefile "\$(TK_SRC_DIR)" "/usr/lib/tk8.3/include"
+ eend $?
- # emake (previously known as pmake) is a script that calls the
- # standard GNU make with parallel building options for speedier
- # builds (especially on SMP systems). Try emake first. It might
- # not work for some packages, in which case you'll have to resort
- # to normal "make".
make || die
- #make test || die
- #emake || die
}
src_install() {
- # You must *personally verify* that this trick doesn't install
- # anything outside of DESTDIR; do this by reading and
- # understanding the install part of the Makefiles.
- #make DESTDIR=${D} install || die
- # For Makefiles that don't make proper use of DESTDIR, setting
- # prefix is often an alternative. However if you do this, then
- # you also need to specify mandir and infodir, since they were
- # passed to ./configure as absolute paths (overriding the prefix
- # setting).
- #make \
- # prefix=${D}/usr \
- # mandir=${D}/usr/share/man \
- # infodir=${D}/usr/share/info \
- # install || die
- # Again, verify the Makefiles! We don't want anything falling
- # outside of ${D}.
- #make install || die
- cd ${S}/unix ; einstall || die
+ einstall || die
}