summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-15 12:47:40 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-15 12:47:40 +0000
commit0f6a67c17593291aa03bd132942831af27b7ddb2 (patch)
tree682d85c9014b40dcddb167334feeb198fda70f8b /dev-tcltk/tdom
parentdev-java/jdbc-postgresql: version bump (diff)
downloadgentoo-2-0f6a67c17593291aa03bd132942831af27b7ddb2.tar.gz
gentoo-2-0f6a67c17593291aa03bd132942831af27b7ddb2.tar.bz2
gentoo-2-0f6a67c17593291aa03bd132942831af27b7ddb2.zip
Assigned RDEPEND explicitely, EAPI=3 some QA on ebuild style
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/tdom')
-rw-r--r--dev-tcltk/tdom/ChangeLog7
-rw-r--r--dev-tcltk/tdom/tdom-0.8.2.ebuild50
2 files changed, 36 insertions, 21 deletions
diff --git a/dev-tcltk/tdom/ChangeLog b/dev-tcltk/tdom/ChangeLog
index 271a35d90734..74e10352a249 100644
--- a/dev-tcltk/tdom/ChangeLog
+++ b/dev-tcltk/tdom/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-tcltk/tdom
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tdom/ChangeLog,v 1.5 2010/03/29 20:09:59 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tdom/ChangeLog,v 1.6 2011/01/15 12:47:40 jlec Exp $
+
+ 15 Jan 2011; Justin Lecher <jlec@gentoo.org> tdom-0.8.2.ebuild:
+ Assigned RDEPEND explicitely, EAPI=3 some QA on ebuild style
29 Mar 2010; Justin Lecher <jlec@gentoo.org> tdom-0.8.2.ebuild:
Keyworded for ~x86-linux ~amd64-linux, tested by me
diff --git a/dev-tcltk/tdom/tdom-0.8.2.ebuild b/dev-tcltk/tdom/tdom-0.8.2.ebuild
index 313b98c6a282..bf0994f5ce1b 100644
--- a/dev-tcltk/tdom/tdom-0.8.2.ebuild
+++ b/dev-tcltk/tdom/tdom-0.8.2.ebuild
@@ -1,10 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tdom/tdom-0.8.2.ebuild,v 1.2 2010/03/29 20:09:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tdom/tdom-0.8.2.ebuild,v 1.3 2011/01/15 12:47:40 jlec Exp $
+
+EAPI="3"
inherit autotools eutils
MY_P="tDOM-${PV}"
+
DESCRIPTION="A XML/DOM/XPath/XSLT Implementation for Tcl"
HOMEPAGE="http://www.tdom.org/"
SRC_URI="http://www.tdom.org/files/${MY_P}.tgz"
@@ -14,43 +17,52 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="threads"
-DEPEND=">=dev-lang/tcl-8.4.3
- >=dev-libs/expat-2.0.1"
+DEPEND="
+ dev-lang/tcl
+ dev-libs/expat"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- #sed -i -e "s/relid'/relid/" configure* tclconfig/tcl.m4 \
- # extensions/tnc/configure extensions/example/{configure,tcl.m4} || die
- epatch "${FILESDIR}/${P}.patch"
- epatch "${FILESDIR}/${P}-expat.patch"
- epatch "${FILESDIR}/${P}-tnc.patch"
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}.patch" \
+ "${FILESDIR}/${P}-expat.patch" \
+ "${FILESDIR}/${P}-tnc.patch"
eautoreconf
}
-src_compile() {
+src_configure() {
local myconf=""
- myconf="${myconf} $(use_enable threads)
+ myconf="${myconf}
+ $(use_enable threads)
--enable-shared
--disable-tdomalloc
--with-expat"
cd "${S}"/unix
- ECONF_SOURCE=".." econf ${myconf} || die "failed to configure"
+ ECONF_SOURCE=".." econf ${myconf}
+
+ # compile tdomhtml
+ cd "${S}"/extensions/tdomhtml
+ econf
+
+ # compile tnc
+ cd "${S}"/extensions/tnc
+ econf ${myconf}
+}
+
+src_compile() {
+ cd "${S}"/unix
emake || die "failed to compile tdom"
# compile tdomhtml
cd "${S}"/extensions/tdomhtml
- econf || die "fail to configure tdomhtml"
emake || die "fail to compile tdomhtml"
# compile tnc
cd "${S}"/extensions/tnc
- econf ${myconf} || die "failed to configure tnc"
emake || die "failed to compile tnc"
}
@@ -65,5 +77,5 @@ src_install() {
emake DESTDIR="${D}" install || die
cd "${S}"
- dodoc CHANGES ChangeLog README*
+ dodoc CHANGES ChangeLog README* || die
}