summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-07 17:18:14 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-07 17:18:14 +0000
commit1f3dd0f574920641a4af1232093c52bbcd6041d3 (patch)
treea5b7900d16328bac5bbe2c317d5e239f1b77457b /dev-tcltk/tclxml/tclxml-3.1-r2.ebuild
parentrestricting tests, upstream does not care about them (diff)
downloadgentoo-2-1f3dd0f574920641a4af1232093c52bbcd6041d3.tar.gz
gentoo-2-1f3dd0f574920641a4af1232093c52bbcd6041d3.tar.bz2
gentoo-2-1f3dd0f574920641a4af1232093c52bbcd6041d3.zip
Respect LDFLAGS
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/tclxml/tclxml-3.1-r2.ebuild')
-rw-r--r--dev-tcltk/tclxml/tclxml-3.1-r2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-tcltk/tclxml/tclxml-3.1-r2.ebuild b/dev-tcltk/tclxml/tclxml-3.1-r2.ebuild
index a995ef84eea1..ddba3959d831 100644
--- a/dev-tcltk/tclxml/tclxml-3.1-r2.ebuild
+++ b/dev-tcltk/tclxml/tclxml-3.1-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-3.1-r2.ebuild,v 1.4 2010/12/07 12:06:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-3.1-r2.ebuild,v 1.5 2010/12/07 17:18:14 jlec Exp $
-inherit autotools eutils
+inherit autotools eutils toolchain-funcs
DESCRIPTION="Pure Tcl implementation of an XML parser."
HOMEPAGE="http://tclxml.sourceforge.net/"
@@ -39,6 +39,9 @@ src_unpack() {
}
src_compile() {
+ export LDFLAGS_OPTIMIZE="${LDFLAGS}"
+ tc-export CC
+
econf ${myconf} \
--with-tclinclude="${EPREFIX}"/usr/include \
--with-tcl="${EPREFIX}"/usr/$(get_libdir) \