summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-07 12:49:48 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-07 12:49:48 +0000
commita114a9c4518155f571b5c3e7eef16f23d6ed5138 (patch)
tree46bd3a67dce12da64095296df12d09ed621c9a3a /dev-tcltk/tcldom
parentVersion bump (diff)
downloadgentoo-2-a114a9c4518155f571b5c3e7eef16f23d6ed5138.tar.gz
gentoo-2-a114a9c4518155f571b5c3e7eef16f23d6ed5138.tar.bz2
gentoo-2-a114a9c4518155f571b5c3e7eef16f23d6ed5138.zip
Respecting multilib and LDFLAGS, #290090 & #341883
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/tcldom')
-rw-r--r--dev-tcltk/tcldom/ChangeLog6
-rw-r--r--dev-tcltk/tcldom/tcldom-2.6.ebuild33
-rw-r--r--dev-tcltk/tcldom/tcldom-3.1.ebuild25
3 files changed, 21 insertions, 43 deletions
diff --git a/dev-tcltk/tcldom/ChangeLog b/dev-tcltk/tcldom/ChangeLog
index 2662ae29805d..3174c6b53497 100644
--- a/dev-tcltk/tcldom/ChangeLog
+++ b/dev-tcltk/tcldom/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/tcldom
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcldom/ChangeLog,v 1.12 2010/10/20 09:58:21 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcldom/ChangeLog,v 1.13 2010/12/07 12:49:41 jlec Exp $
+
+ 07 Dec 2010; Justin Lecher <jlec@gentoo.org> +files/3.1-ldflags.patch,
+ -tcldom-2.6.ebuild, tcldom-3.1.ebuild:
+ Respecting multilib and LDFLAGS, #290090 & #341883
20 Oct 2010; Christian Faulhammer <fauli@gentoo.org> tcldom-3.1.ebuild:
stable x86, bug 341645
diff --git a/dev-tcltk/tcldom/tcldom-2.6.ebuild b/dev-tcltk/tcldom/tcldom-2.6.ebuild
deleted file mode 100644
index 905527ee9488..000000000000
--- a/dev-tcltk/tcldom/tcldom-2.6.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcldom/tcldom-2.6.ebuild,v 1.6 2006/06/04 02:34:19 matsuu Exp $
-
-DESCRIPTION="Document Object Model For Tcl"
-HOMEPAGE="http://tclxml.sourceforge.net/tcldom.html"
-SRC_URI="mirror://sourceforge/tclxml/${P}.tar.gz"
-IUSE=""
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 ~ppc ~amd64"
-
-DEPEND=">=dev-lang/tcl-8.3.3"
-RDEPEND="${DEPEND}
- >=dev-tcltk/tclxml-2.6"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # bug 131148
- sed -i -e "s/relid'/relid/" \
- {,src-libxml2/}configure {config,tclconfig}/tcl.m4 || die
-}
-
-src_compile() {
- econf || die
- make || die
-}
-
-src_install() {
- einstall || die
- dodoc ChangeLog LICENSE README RELNOTES
-}
diff --git a/dev-tcltk/tcldom/tcldom-3.1.ebuild b/dev-tcltk/tcldom/tcldom-3.1.ebuild
index 3c3e236421e3..9d34684a673a 100644
--- a/dev-tcltk/tcldom/tcldom-3.1.ebuild
+++ b/dev-tcltk/tcldom/tcldom-3.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcldom/tcldom-3.1.ebuild,v 1.3 2010/10/20 09:58:21 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcldom/tcldom-3.1.ebuild,v 1.4 2010/12/07 12:49:41 jlec Exp $
-inherit eutils
+inherit eutils multilib toolchain-funcs
DESCRIPTION="Document Object Model For Tcl"
HOMEPAGE="http://tclxml.sourceforge.net/tcldom.html"
@@ -17,10 +17,15 @@ DEPEND=">=dev-lang/tcl-8.3.3
>=dev-tcltk/tcllib-1.2
~dev-tcltk/tclxml-3.1
expat? ( dev-libs/expat )"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+
cd "${S}/library"
sed -e "s/@VERSION@/${PV}/" \
-e "s/@Tcldom_LIB_FILE@@/UNSPECIFIED/" \
@@ -31,19 +36,21 @@ src_unpack() {
}
src_compile() {
- local myconf=""
+ local myconf="--with-tcl=/usr/$(get_libdir)"
+
+ tc-export CC
use threads && myconf="${myconf} --enable-threads"
if use xml ; then
cd "${S}/src-libxml2"
- econf ${myconf} || die
+ econf ${myconf}
emake || die
fi
if use expat ; then
cd "${S}/src"
- econf ${myconf} || die
- emake || die
+ LDFLAGS="${LDFLAGS}" econf ${myconf}
+ emake LDFLAGS_OPTIMIZE="${LDFLAGS}" || die
fi
}
@@ -61,7 +68,7 @@ src_install() {
fi
cd "${S}"
- dodoc ChangeLog LICENSE README RELNOTES
- docinto examples; dodoc examples/*
- dohtml docs/*.html
+ dodoc ChangeLog README RELNOTES || die
+ docinto examples; dodoc examples/* || die
+ dohtml docs/*.html || die
}