summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2004-08-28 18:14:08 +0000
committerDoug Goldstein <cardoe@gentoo.org>2004-08-28 18:14:08 +0000
commit40c8f8efa9c92db7c16f132d101ec2c28c406cf4 (patch)
treee9519e6242e7b769065622db8372d8289478a1e7 /dev-tcltk/otcl
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-40c8f8efa9c92db7c16f132d101ec2c28c406cf4.tar.gz
gentoo-2-40c8f8efa9c92db7c16f132d101ec2c28c406cf4.tar.bz2
gentoo-2-40c8f8efa9c92db7c16f132d101ec2c28c406cf4.zip
More complete fix
Diffstat (limited to 'dev-tcltk/otcl')
-rw-r--r--dev-tcltk/otcl/ChangeLog6
-rw-r--r--dev-tcltk/otcl/otcl-1.8-r3.ebuild12
2 files changed, 15 insertions, 3 deletions
diff --git a/dev-tcltk/otcl/ChangeLog b/dev-tcltk/otcl/ChangeLog
index c9315f2721c6..f824988e7cf0 100644
--- a/dev-tcltk/otcl/ChangeLog
+++ b/dev-tcltk/otcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/otcl
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/ChangeLog,v 1.13 2004/08/28 17:20:12 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/ChangeLog,v 1.14 2004/08/28 18:14:08 cardoe Exp $
+
+ 28 Aug 2004; Doug Goldstein <cardoe@gentoo.org> otcl-1.8-r3.ebuild:
+ That fix only worked on one system... not the other... this is the permenant
+ fix by fixing the Makefile
*otcl-1.8-r3 (28 Aug 2004)
diff --git a/dev-tcltk/otcl/otcl-1.8-r3.ebuild b/dev-tcltk/otcl/otcl-1.8-r3.ebuild
index a5d2a067c14a..caec9413086c 100644
--- a/dev-tcltk/otcl/otcl-1.8-r3.ebuild
+++ b/dev-tcltk/otcl/otcl-1.8-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/otcl-1.8-r3.ebuild,v 1.1 2004/08/28 17:20:12 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/otcl-1.8-r3.ebuild,v 1.2 2004/08/28 18:14:08 cardoe Exp $
inherit eutils
@@ -10,7 +10,7 @@ HOMEPAGE="http://sourceforge.net/projects/${SF_PN}/"
SRC_URI="mirror://sourceforge/${SF_PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc"
+KEYWORDS="~x86 sparc ~ppc"
IUSE=""
DEPEND=">=dev-lang/tcl-8.3.2
>=dev-lang/tk-8.3.2"
@@ -26,8 +26,16 @@ src_compile() {
tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
myconf="--with-tcl-ver=${tclv} --with-tk-ver=${tkv}"
CFLAGS="${CFLAGS} -I/usr/lib/tcl${tkv}/include/generic"
+
+ sed -i \
+ -e "s/) otkAppInit.c/) otkAppInit.c otcl.c/" \
+ -e "s/) otclAppInit.c/) otclAppInit.c otcl.c/" \
+ -e "" "${S}/Makefile.in" \
+ || die "sed Makefile failed"
+
econf ${myconf} || die "econf failed"
emake all || die "emake all failed"
+ emake libotcl.so || die "emake libotcl.so failed"
}
src_install() {