summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-20 07:27:46 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-20 07:27:46 +0000
commit82a019c5edd806a850fa305756725ac17eea8ae3 (patch)
tree70268c7a705d518bce0c38da520c099c40a2f9ff /dev-tcltk/expect
parentFix cctbx version (diff)
downloadgentoo-2-82a019c5edd806a850fa305756725ac17eea8ae3.tar.gz
gentoo-2-82a019c5edd806a850fa305756725ac17eea8ae3.tar.bz2
gentoo-2-82a019c5edd806a850fa305756725ac17eea8ae3.zip
Clean up ebuild and fix missing prototype warnings #337943 by David J Cozatt.
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/expect')
-rw-r--r--dev-tcltk/expect/ChangeLog6
-rw-r--r--dev-tcltk/expect/expect-5.44.1.15.ebuild47
-rw-r--r--dev-tcltk/expect/files/expect-5.44.1.15-headers.patch76
3 files changed, 100 insertions, 29 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 6180a88edea4..4fd8e466ff0c 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/expect
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.80 2010/08/07 16:57:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.81 2010/09/20 07:27:45 vapier Exp $
+
+ 20 Sep 2010; Mike Frysinger <vapier@gentoo.org> expect-5.44.1.15.ebuild,
+ +files/expect-5.44.1.15-headers.patch:
+ Clean up ebuild and fix missing prototype warnings #337943 by David J Cozatt.
07 Aug 2010; Raúl Porcel <armin76@gentoo.org> expect-5.44.1.15.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #324951
diff --git a/dev-tcltk/expect/expect-5.44.1.15.ebuild b/dev-tcltk/expect/expect-5.44.1.15.ebuild
index 825eafc78e82..3f6ce55d48b1 100644
--- a/dev-tcltk/expect/expect-5.44.1.15.ebuild
+++ b/dev-tcltk/expect/expect-5.44.1.15.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.44.1.15.ebuild,v 1.13 2010/08/07 16:57:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.44.1.15.ebuild,v 1.14 2010/09/20 07:27:45 vapier Exp $
EAPI="3"
-WANT_AUTOCONF="2.5"
inherit autotools eutils
DESCRIPTION="tool for automating interactive applications"
@@ -23,21 +22,18 @@ DEPEND=">=dev-lang/tcl-8.2[threads?]
RDEPEND="${DEPEND}"
src_prepare() {
- # fix install_name on darwin
- [[ ${CHOST} == *-darwin* ]] && \
- epatch "${FILESDIR}"/${P}-darwin.patch
-
- sed -i "s#/usr/local/bin#${EPREFIX}/usr/bin#" expect.man
- sed -i "s#/usr/local/bin#${EPREFIX}/usr/bin#" expectk.man
- #stops any example scripts being installed by default
+ sed -i "s#/usr/local/bin#${EPREFIX}/usr/bin#" expect{,k}.man || die
+ # stops any example scripts being installed by default
sed -i \
-e '/^install:/s/install-libraries //' \
-e 's/^SCRIPTS_MANPAGES = /_&/' \
Makefile.in
- epatch "${FILESDIR}/${P}-gfbsd.patch"
- epatch "${FILESDIR}/${P}-ldflags.patch"
- epatch "${FILESDIR}/${P}_with-tk-no.patch"
+ epatch "${FILESDIR}"/${P}-gfbsd.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch "${FILESDIR}"/${P}_with-tk-no.patch
+ epatch "${FILESDIR}"/${P}-headers.patch #337943
+ sed -i 's:ifdef HAVE_SYS_WAIT_H:ifndef NO_SYS_WAIT_H:' *.c
eautoconf
}
@@ -79,26 +75,21 @@ src_test() {
emake test || die "emake test failed"
}
-src_install() {
- dodir /usr/$(get_libdir)
- emake install DESTDIR="${D}" || die "make install failed"
+expect_make_var() {
+ touch pkgIndex.tcl-hand
+ printf 'all:;echo $('$1')\ninclude Makefile' | emake -s -f -
+ rm -f pkgIndex.tcl-hand
+}
+src_install() {
+ emake install DESTDIR="${D}" || die
dodoc ChangeLog FAQ HISTORY NEWS README
- #install examples if 'doc' is set
+ # install examples if 'doc' is set
if use doc ; then
- docinto examples
- local scripts=$(make -qp | \
- sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
insinto /usr/share/doc/${PF}/examples
- for s in ${scripts}; do
- doins example/${s} || die
- done
- local scripts_manpages=$(make -qp | \
- sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
- for m in ${scripts_manpages}; do
- dodoc example/${m}.man
- done
- dodoc example/README
+ doins $(printf 'example/%s ' $(expect_make_var SCRIPTS)) || die
+ docinto examples
+ dodoc example/README $(printf 'example/%s.man ' $(expect_make_var _SCRIPTS_MANPAGES)) || die
fi
}
diff --git a/dev-tcltk/expect/files/expect-5.44.1.15-headers.patch b/dev-tcltk/expect/files/expect-5.44.1.15-headers.patch
new file mode 100644
index 000000000000..33253bf381cc
--- /dev/null
+++ b/dev-tcltk/expect/files/expect-5.44.1.15-headers.patch
@@ -0,0 +1,76 @@
+https://sourceforge.net/tracker/?func=detail&aid=3071706&group_id=13179&atid=113179
+
+--- a/exp_clib.c
++++ b/exp_clib.c
+@@ -15,6 +15,12 @@
+ #endif
+ #include <sys/types.h>
+ #include <sys/ioctl.h>
++#ifdef HAVE_UNISTD_H
++# include <unistd.h>
++#endif
++#ifdef HAVE_SYS_WAIT_H
++#include <sys/wait.h>
++#endif
+
+ #ifdef TIME_WITH_SYS_TIME
+ # include <sys/time.h>
+--- a/exp_trap.c
++++ b/exp_trap.c
+@@ -13,6 +13,7 @@
+ #include <stdio.h>
+ #include <signal.h>
+ #include <sys/types.h>
++#include <string.h>
+
+ #ifdef HAVE_SYS_WAIT_H
+ #include <sys/wait.h>
+--- a/pty_termios.c
++++ b/pty_termios.c
+@@ -9,6 +9,8 @@
+
+ #include <stdio.h>
+ #include <signal.h>
++#include <string.h>
++#include <pty.h>
+
+ #if defined(SIGCLD) && !defined(SIGCHLD)
+ #define SIGCHLD SIGCLD
+@@ -100,6 +100,7 @@
+
+ #include "exp_tty_in.h"
+ #include "exp_rename.h"
++#include "exp_int.h"
+ #include "exp_pty.h"
+
+ void expDiagLog();
+--- a/exp_chan.c
++++ b/exp_chan.c
+@@ -34,6 +34,7 @@
+ #include "exp_rename.h"
+ #include "exp_prog.h"
+ #include "exp_command.h"
++#include "exp_event.h"
+ #include "exp_log.h"
+ #include "tcldbg.h" /* Dbg_StdinMode */
+
+--- a/exp_clib.c
++++ b/exp_clib.c
+@@ -1955,6 +1955,7 @@
+
+ #include "expect.h"
+ #include "exp_int.h"
++EXTERN void exp_init_tty _ANSI_ARGS_((void));
+
+ /* exp_glob.c - expect functions for doing glob
+ *
+--- a/exp_tty.h
++++ b/exp_tty.h
+@@ -17,6 +17,7 @@
+
+ void exp_tty_raw(int set);
+ void exp_tty_echo(int set);
++int exp_tty_cooked_echo(Tcl_Interp *interp, exp_tty *tty_old, int *was_raw, int *was_echo);
+ void exp_tty_break(Tcl_Interp *interp, int fd);
+ int exp_tty_raw_noecho(Tcl_Interp *interp, exp_tty *tty_old, int *was_raw, int *was_echo);
+ int exp_israw(void);