summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-17 22:25:42 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-17 22:25:42 +0000
commit44da9fac633fe6e16131f5883a61f111655cf323 (patch)
tree80d48f4eef7b0a9b5ce187cc200163134b4f0cb1 /dev-tcltk/expect
parentVersion bump with an ebuild cleanup. Migrate to the xorg-2 eclass, remove pat... (diff)
downloadgentoo-2-44da9fac633fe6e16131f5883a61f111655cf323.tar.gz
gentoo-2-44da9fac633fe6e16131f5883a61f111655cf323.tar.bz2
gentoo-2-44da9fac633fe6e16131f5883a61f111655cf323.zip
Punt old version with known bugs.
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/expect')
-rw-r--r--dev-tcltk/expect/ChangeLog7
-rw-r--r--dev-tcltk/expect/expect-5.42.1-r1.ebuild102
-rw-r--r--dev-tcltk/expect/expect-5.42.1-r2.ebuild106
-rw-r--r--dev-tcltk/expect/files/expect-5.42.1-missing-includes.patch33
-rw-r--r--dev-tcltk/expect/files/expect-5.42.1-multilib.patch11
5 files changed, 6 insertions, 253 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 4fd8e466ff0c..26cf3196bcc2 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tcltk/expect
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.81 2010/09/20 07:27:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.82 2010/12/17 22:25:42 vapier Exp $
+
+ 17 Dec 2010; Mike Frysinger <vapier@gentoo.org> -expect-5.42.1-r1.ebuild,
+ -expect-5.42.1-r2.ebuild, -files/expect-5.42.1-missing-includes.patch,
+ -files/expect-5.42.1-multilib.patch:
+ Punt old version with known bugs.
20 Sep 2010; Mike Frysinger <vapier@gentoo.org> expect-5.44.1.15.ebuild,
+files/expect-5.44.1.15-headers.patch:
diff --git a/dev-tcltk/expect/expect-5.42.1-r1.ebuild b/dev-tcltk/expect/expect-5.42.1-r1.ebuild
deleted file mode 100644
index 11d7f2d6933a..000000000000
--- a/dev-tcltk/expect/expect-5.42.1-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.42.1-r1.ebuild,v 1.13 2008/03/10 00:21:05 ricmm Exp $
-
-WANT_AUTOCONF="2.1"
-inherit autotools eutils
-
-DESCRIPTION="tool for automating interactive applications"
-HOMEPAGE="http://expect.nist.gov/"
-SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="X doc"
-
-# We need dejagnu for src_test, but dejagnu needs expect
-# to compile/run, so we cant add dejagnu to DEPEND :/
-DEPEND=">=dev-lang/tcl-8.2
- X? ( >=dev-lang/tk-8.2 )"
-RDEPEND="${DEPEND}"
-
-NON_MICRO_V=${P%.[0-9]}
-S=${WORKDIR}/${NON_MICRO_V}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-multilib.patch
-
- # fix the rpath being set to /var/tmp/portage/...
- epatch ${FILESDIR}/expect-5.39.0-libdir.patch
-
- sed -i 's#/usr/local/bin#/usr/bin#' expect.man
- sed -i 's#/usr/local/bin#/usr/bin#' expectk.man
- #stops any example scripts being installed by default
- sed -i \
- -e '/^install:/s/install-libraries //' \
- -e 's/^SCRIPTS_MANPAGES = /_&/' \
- Makefile.in
- eautoconf
-}
-
-src_compile() {
- local myconf
- local tclv
- local tkv
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- #tkv isn't really needed, included for symmetry and the future
- #tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
-
- #configure needs to find the files tclConfig.sh and tclInt.h
- myconf="--with-tcl=/usr/$(get_libdir) --with-tclinclude=/usr/$(get_libdir)/tcl${tclv}/include/generic"
-
- if use X ; then
- #--with-x is enabled by default
- #configure needs to find the file tkConfig.sh and tk.h
- #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
- myconf="$myconf --with-tk=/usr/$(get_libdir)"
- else
- #configure knows that tk depends on X so just disable X
- myconf="$myconf --without-x"
- fi
-
- econf $myconf --enable-shared || die "econf failed"
- emake || die "emake failed"
-}
-
-src_test() {
- # we need dejagnu to do tests ... but dejagnu needs
- # expect ... so don't do tests unless we have dejagnu
- type -p runtest || return 0
- make check || die "make check failed"
-}
-
-src_install() {
- dodir /usr/$(get_libdir)
- make install INSTALL_ROOT=${D} || die "make install failed"
-
- dodoc ChangeLog FAQ HISTORY NEWS README
-
- local static_lib="lib${NON_MICRO_V/-/}.a"
- rm ${D}/usr/$(get_libdir)/${NON_MICRO_V/-/}/${static_lib}
-
- #install examples if 'doc' is set
- if use doc ; then
- docinto examples
- local scripts=$(make -qp | \
- sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
- exeinto /usr/share/doc/${PF}/examples
- doexe ${scripts}
- local scripts_manpages=$(make -qp | \
- sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
- for m in ${scripts_manpages}; do
- dodoc example/${m}.man
- done
- dodoc example/README
- fi
-}
diff --git a/dev-tcltk/expect/expect-5.42.1-r2.ebuild b/dev-tcltk/expect/expect-5.42.1-r2.ebuild
deleted file mode 100644
index a67ae00d9f61..000000000000
--- a/dev-tcltk/expect/expect-5.42.1-r2.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.42.1-r2.ebuild,v 1.1 2009/06/07 17:01:04 mescalinum Exp $
-
-WANT_AUTOCONF="2.1"
-inherit autotools eutils
-
-DESCRIPTION="tool for automating interactive applications"
-HOMEPAGE="http://expect.nist.gov/"
-SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="X doc"
-
-# We need dejagnu for src_test, but dejagnu needs expect
-# to compile/run, so we cant add dejagnu to DEPEND :/
-DEPEND=">=dev-lang/tcl-8.2
- X? ( >=dev-lang/tk-8.2 )"
-RDEPEND="${DEPEND}"
-
-NON_MICRO_V=${P%.[0-9]}
-S=${WORKDIR}/${NON_MICRO_V}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-multilib.patch
-
- # fix the rpath being set to /var/tmp/portage/...
- epatch ${FILESDIR}/expect-5.39.0-libdir.patch
-
- sed -i 's#/usr/local/bin#/usr/bin#' expect.man
- sed -i 's#/usr/local/bin#/usr/bin#' expectk.man
- #stops any example scripts being installed by default
- sed -i \
- -e '/^install:/s/install-libraries //' \
- -e 's/^SCRIPTS_MANPAGES = /_&/' \
- Makefile.in
-
- # fix implicit missing declarations (bug 204878)
- epatch "${FILESDIR}"/"${P}"-missing-includes.patch
-
- eautoconf
-}
-
-src_compile() {
- local myconf
- local tclv
- local tkv
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- #tkv isn't really needed, included for symmetry and the future
- #tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
-
- #configure needs to find the files tclConfig.sh and tclInt.h
- myconf="--with-tcl=/usr/$(get_libdir) --with-tclinclude=/usr/$(get_libdir)/tcl${tclv}/include/generic"
-
- if use X ; then
- #--with-x is enabled by default
- #configure needs to find the file tkConfig.sh and tk.h
- #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
- myconf="$myconf --with-tk=/usr/$(get_libdir)"
- else
- #configure knows that tk depends on X so just disable X
- myconf="$myconf --without-x"
- fi
-
- econf $myconf --enable-shared || die "econf failed"
- emake || die "emake failed"
-}
-
-src_test() {
- # we need dejagnu to do tests ... but dejagnu needs
- # expect ... so don't do tests unless we have dejagnu
- type -p runtest || return 0
- make check || die "make check failed"
-}
-
-src_install() {
- dodir /usr/$(get_libdir)
- make install INSTALL_ROOT=${D} || die "make install failed"
-
- dodoc ChangeLog FAQ HISTORY NEWS README
-
- local static_lib="lib${NON_MICRO_V/-/}.a"
- rm ${D}/usr/$(get_libdir)/${NON_MICRO_V/-/}/${static_lib}
-
- #install examples if 'doc' is set
- if use doc ; then
- docinto examples
- local scripts=$(make -qp | \
- sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
- exeinto /usr/share/doc/${PF}/examples
- doexe ${scripts}
- local scripts_manpages=$(make -qp | \
- sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
- for m in ${scripts_manpages}; do
- dodoc example/${m}.man
- done
- dodoc example/README
- fi
-}
diff --git a/dev-tcltk/expect/files/expect-5.42.1-missing-includes.patch b/dev-tcltk/expect/files/expect-5.42.1-missing-includes.patch
deleted file mode 100644
index ec4ce5184eb2..000000000000
--- a/dev-tcltk/expect/files/expect-5.42.1-missing-includes.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -urN work.orig/expect-5.42/exp_glob.c work/expect-5.42/exp_glob.c
---- work.orig/expect-5.42/exp_glob.c 2009-06-02 00:07:02.429807485 -0400
-+++ work/expect-5.42/exp_glob.c 2009-06-02 00:09:05.039817979 -0400
-@@ -11,6 +11,7 @@
-
- */
-
-+#include <string.h>
- #include "expect_cf.h"
- #include "tcl.h"
- #include "exp_int.h"
-diff -urN work.orig/expect-5.42/exp_main_exp.c work/expect-5.42/exp_main_exp.c
---- work.orig/expect-5.42/exp_main_exp.c 2009-06-02 00:07:02.429807485 -0400
-+++ work/expect-5.42/exp_main_exp.c 2009-06-02 00:08:09.867365455 -0400
-@@ -9,6 +9,7 @@
-
- #include "expect_cf.h"
- #include <stdio.h>
-+#include <stdlib.h>
- #include "tcl.h"
- #include "expect_tcl.h"
-
-diff -urN work.orig/expect-5.42/pty_termios.c work/expect-5.42/pty_termios.c
---- work.orig/expect-5.42/pty_termios.c 2009-06-02 00:07:02.449818499 -0400
-+++ work/expect-5.42/pty_termios.c 2009-06-02 00:08:41.878505396 -0400
-@@ -8,6 +8,7 @@
- */
-
- #include <stdio.h>
-+#include <string.h>
- #include <signal.h>
-
- #if defined(SIGCLD) && !defined(SIGCHLD)
diff --git a/dev-tcltk/expect/files/expect-5.42.1-multilib.patch b/dev-tcltk/expect/files/expect-5.42.1-multilib.patch
deleted file mode 100644
index 9257537349d5..000000000000
--- a/dev-tcltk/expect/files/expect-5.42.1-multilib.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- expect-5.42/configure.in.orig 2004-12-21 03:02:36.095170881 -0800
-+++ expect-5.42/configure.in 2004-12-21 03:03:08.987170537 -0800
-@@ -1141,7 +1141,7 @@
- fi
-
- EXP_BUILD_LIB_SPEC="-L`pwd` -lexpect${EXP_LIB_VERSION}${DBGX}"
--EXP_LIB_SPEC="-L\${INSTALL_ROOT}\${exec_prefix}/lib -lexpect${EXP_LIB_VERSION}${DBGX}"
-+EXP_LIB_SPEC="-L\${libdir} -lexpect${EXP_LIB_VERSION}${DBGX}"
- EXP_UNSHARED_LIB_FILE=libexpect${EXP_LIB_VERSION}${DBGX}.a
-
- # The TCL_SHARED_LIB_SUFFIX macro below relies on the DBGX macro,