summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPanagiotis Christopoulos <pchrist@gentoo.org>2010-12-24 16:46:11 +0000
committerPanagiotis Christopoulos <pchrist@gentoo.org>2010-12-24 16:46:11 +0000
commitd3c579422207910af183b20f5db12ccc1f07ec52 (patch)
tree74b37bf58ab000b4dab2da467bb54b5235f563b7 /dev-scheme
parentVersion bump. (diff)
downloadgentoo-2-d3c579422207910af183b20f5db12ccc1f07ec52.tar.gz
gentoo-2-d3c579422207910af183b20f5db12ccc1f07ec52.tar.bz2
gentoo-2-d3c579422207910af183b20f5db12ccc1f07ec52.zip
Bumped guile to 1.8.8. This is a maintainance release of the 1.8.x series
(Portage version: 2.1.9.26/cvs/Linux i686)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/guile/ChangeLog8
-rw-r--r--dev-scheme/guile/guile-1.8.8.ebuild101
2 files changed, 108 insertions, 1 deletions
diff --git a/dev-scheme/guile/ChangeLog b/dev-scheme/guile/ChangeLog
index 9bfe6c235da5..ad43e373960d 100644
--- a/dev-scheme/guile/ChangeLog
+++ b/dev-scheme/guile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-scheme/guile
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/ChangeLog,v 1.81 2010/11/14 16:05:58 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/ChangeLog,v 1.82 2010/12/24 16:46:11 pchrist Exp $
+
+*guile-1.8.8 (24 Dec 2010)
+
+ 24 Dec 2010; Panagiotis Christopoulos <pchrist@gentoo.org>
+ +guile-1.8.8.ebuild:
+ Bumped guile to 1.8.8. This is a maintainance release of the 1.8.x series
14 Nov 2010; Justin Lecher <jlec@gentoo.org> guile-1.6.8.ebuild,
guile-1.8.4.ebuild, guile-1.8.4-r1.ebuild, guile-1.8.5.ebuild,
diff --git a/dev-scheme/guile/guile-1.8.8.ebuild b/dev-scheme/guile/guile-1.8.8.ebuild
new file mode 100644
index 000000000000..d46c2524c80e
--- /dev/null
+++ b/dev-scheme/guile/guile-1.8.8.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.8.ebuild,v 1.1 2010/12/24 16:46:11 pchrist Exp $
+
+EAPI=3
+inherit eutils flag-o-matic elisp-common
+
+DESCRIPTION="Scheme interpreter"
+HOMEPAGE="http://www.gnu.org/software/guile/"
+SRC_URI="mirror://gnu/guile/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="networking +regex discouraged +deprecated elisp emacs nls debug-freelist debug-malloc debug +threads"
+RESTRICT="!regex? ( test )"
+
+DEPEND="
+ >=dev-libs/gmp-4.1
+ >=sys-devel/libtool-1.5.6
+ sys-devel/gettext
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+# Guile seems to contain some slotting support, /usr/share/guile/ is slotted,
+# but there are lots of collisions. Most in /usr/share/libguile. Therefore
+# I'm slotting this in the same slot as guile-1.6* for now.
+SLOT="12"
+MAJOR="1.8"
+
+src_configure() {
+ # see bug #178499
+ filter-flags -ftree-vectorize
+
+ #will fail for me if posix is disabled or without modules -- hkBst
+ econf \
+ --disable-error-on-warning \
+ --disable-static \
+ --enable-posix \
+ $(use_enable networking) \
+ $(use_enable regex) \
+ $(use deprecated || use_enable discouraged) \
+ $(use_enable deprecated) \
+ $(use_enable elisp) \
+ $(use_enable nls) \
+ --disable-rpath \
+ $(use_enable debug-freelist) \
+ $(use_enable debug-malloc) \
+ $(use_enable debug guile-debug) \
+ $(use_with threads) \
+ --with-modules \
+ EMACS=no
+}
+
+src_compile() {
+ emake || die "make failed"
+
+ # Above we have disabled the build system's Emacs support;
+ # for USE=emacs we compile (and install) the files manually
+ if use emacs; then
+ cd emacs
+ elisp-compile *.el || die
+ fi
+}
+
+src_install() {
+ einstall || die "install failed"
+
+ dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README THANKS || die
+
+ # texmacs needs this, closing bug #23493
+ dodir /etc/env.d
+ echo "GUILE_LOAD_PATH=\"${EPREFIX}/usr/share/guile/${MAJOR}\"" > "${ED}"/etc/env.d/50guile
+
+ # necessary for registering slib, see bug 206896
+ keepdir /usr/share/guile/site
+
+ if use emacs; then
+ elisp-install ${PN} emacs/*.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" || die
+ fi
+}
+
+pkg_postinst() {
+ [ "${EROOT}" == "/" ] && pkg_config
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
+
+pkg_config() {
+ if has_version dev-scheme/slib; then
+ einfo "Registering slib with guile"
+ install_slib_for_guile
+ fi
+}
+
+_pkg_prerm() {
+ rm -f "${EROOT}"/usr/share/guile/site/slibcat
+}