summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2010-10-06 19:13:29 +0000
committerTomás Touceda <chiiph@gentoo.org>2010-10-06 19:13:29 +0000
commit2da6bb3d49269fb3c2ada7bd49535378f9153498 (patch)
tree24e732a07937691440989b5551dbb68aac6e5324 /dev-scheme
parentFixed yaboot package manifest for incorrect file. (diff)
downloadgentoo-2-2da6bb3d49269fb3c2ada7bd49535378f9153498.tar.gz
gentoo-2-2da6bb3d49269fb3c2ada7bd49535378f9153498.tar.bz2
gentoo-2-2da6bb3d49269fb3c2ada7bd49535378f9153498.zip
Version bump and remove 3.3a
(Portage version: 2.2_rc88/cvs/Linux i686)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/bigloo/ChangeLog8
-rw-r--r--dev-scheme/bigloo/bigloo-3.3a_p5.ebuild113
-rw-r--r--dev-scheme/bigloo/bigloo-3.4a_p3.ebuild218
-rw-r--r--dev-scheme/bigloo/metadata.xml43
4 files changed, 257 insertions, 125 deletions
diff --git a/dev-scheme/bigloo/ChangeLog b/dev-scheme/bigloo/ChangeLog
index 9b04a5b77a27..0fb69f6839bc 100644
--- a/dev-scheme/bigloo/ChangeLog
+++ b/dev-scheme/bigloo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-scheme/bigloo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/ChangeLog,v 1.40 2010/05/09 22:15:50 chiiph Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/ChangeLog,v 1.41 2010/10/06 19:13:29 chiiph Exp $
+
+*bigloo-3.4a_p3 (06 Oct 2010)
+
+ 06 Oct 2010; Tomas Touceda <chiiph@gentoo.org> -bigloo-3.3a_p5.ebuild,
+ +bigloo-3.4a_p3.ebuild, metadata.xml:
+ Version bump and remove 3.3a
09 May 2010; Tomas Touceda <chiiph@gentoo.org> bigloo-3.0c_p4.ebuild:
Patch to prevent prestripping wrt bug 251925. Thanks to Christophe
diff --git a/dev-scheme/bigloo/bigloo-3.3a_p5.ebuild b/dev-scheme/bigloo/bigloo-3.3a_p5.ebuild
deleted file mode 100644
index db2f118245cb..000000000000
--- a/dev-scheme/bigloo/bigloo-3.3a_p5.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.3a_p5.ebuild,v 1.3 2010/04/18 16:11:39 chiiph Exp $
-
-EAPI="2"
-
-inherit elisp-common multilib eutils flag-o-matic java-pkg-opt-2
-
-MY_P=${PN}${PV/_p/-}
-MY_P=${MY_P/_alpha/-alpha}
-MY_P=${MY_P/_beta/-beta}
-
-DESCRIPTION="Bigloo is a Scheme implementation."
-HOMEPAGE="http://www-sop.inria.fr/indes/fp/Bigloo/bigloo.html"
-SRC_URI="ftp://ftp-sop.inria.fr/indes/fp/Bigloo/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-# bug 254916 for >=dev-libs/boehm-gc-7.1
-DEPEND=">=dev-libs/boehm-gc-7.1[threads?]
- emacs? ( virtual/emacs )
- java? ( >=virtual/jdk-1.5 app-arch/zip )
- ssl? ( dev-libs/openssl )
- gstreamer? ( media-libs/gstreamer
- media-libs/gst-plugins-base )"
-
-RDEPEND="${DEPEND}
- java? ( >=virtual/jre-1.5 )"
-
-S=${WORKDIR}/${MY_P}
-
-SITEFILE="50bigloo-gentoo.el"
-
-IUSE="emacs java ssl threads gstreamer"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-no_strip.patch"
-
- # Removing bundled boehm-gc
- rm -rf gc || die
-}
-
-src_configure() {
- filter-flags -fomit-frame-pointer
-
- if ! use threads && use gstreamer; then
- eerror "You must enable threads in order to build with gstreamer support"
- die
- fi
-
- # Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
- # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
- ./configure \
- $(use java && echo "--jvm=yes --java=$(java-config --java) --javac=$(java-config --javac)") \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --libdir=/usr/$(get_libdir) \
- --docdir=/usr/share/doc/${PF} \
- --lispdir="${SITELISP}/${PN}" \
- --benchmark=yes \
- --sharedbde=no \
- --sharedcompiler=no \
- --customgc=no \
- --coflags="" \
- --strip=no \
- --bee=$(if use emacs; then echo full; else echo partial; fi) \
- $(use_enable threads fthread) \
- $(use_enable threads pthread) \
- $(use_enable gstreamer) \
- $(use_enable ssl) \
- || die "configure failed"
-
-}
-
-src_compile() {
- emake -j1 || die "emake failed"
-
- if use emacs; then
- einfo "Compiling bee..."
- emake -j1 compile-bee || die "compiling bee failed"
- fi
-}
-
-# default thinks that target doesn't exist
-src_test() {
- echo ">>> Test phase [test]: ${CATEGORY}/${PF}"
- emake test || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
-
- if use emacs; then
- emake DESTDIR="${D}" install-bee || die "install-bee failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- if use emacs; then
- elog "In order to use the bee-mode, add"
- elog " (require 'bmacs)"
- elog "to your ~/.emacs file"
- fi
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/bigloo/bigloo-3.4a_p3.ebuild b/dev-scheme/bigloo/bigloo-3.4a_p3.ebuild
new file mode 100644
index 000000000000..aa5dc7c019d8
--- /dev/null
+++ b/dev-scheme/bigloo/bigloo-3.4a_p3.ebuild
@@ -0,0 +1,218 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.4a_p3.ebuild,v 1.1 2010/10/06 19:13:29 chiiph Exp $
+
+EAPI="3"
+
+inherit elisp-common multilib eutils flag-o-matic java-pkg-opt-2
+
+MY_P=${PN}${PV/_p/-}
+MY_P=${MY_P/_alpha*/-alpha}
+MY_P=${MY_P/_beta*/-beta}
+
+BGL_RELEASE=${PV/_*/}
+PATCHSET="1"
+
+DESCRIPTION="Bigloo is a Scheme implementation."
+HOMEPAGE="http://www-sop.inria.fr/indes/fp/Bigloo/bigloo.html"
+SRC_URI="ftp://ftp-sop.inria.fr/members/Cyprien.Nicolas/mirror/bigloo-${BGL_RELEASE}-patchset-${PATCHSET}.tbz2
+ ftp://ftp-sop.inria.fr/indes/fp/Bigloo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bglpkg calendar crypto debug doc emacs gmp gstreamer java mail multimedia packrat sqlite srfi1 srfi27 ssl text threads web"
+
+# bug 254916 for >=dev-libs/boehm-gc-7.1
+DEPEND=">=dev-libs/boehm-gc-7.1[threads?]
+ emacs? ( virtual/emacs )
+ gmp? ( dev-libs/gmp )
+ gstreamer? ( media-libs/gstreamer media-libs/gst-plugins-base )
+ java? ( >=virtual/jdk-1.5 app-arch/zip )
+ sqlite? ( dev-db/sqlite:3 )
+ ssl? ( dev-libs/openssl )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P/-[ab]*/}
+
+SITEFILE="50bigloo-gentoo.el"
+
+pkg_setup() {
+ if use gstreamer; then
+ if ! use threads; then
+ die "USE Dependency: 'gstreamer' needs 'threads'. You may enable 'threads', or disable 'gstreamer'."
+ fi
+
+ if ! use multimedia; then
+ die "USE Dependency: 'gstreamer' needs 'multimedia'."
+ fi
+ fi
+
+ if use packrat && ! use srfi1; then
+ die "USE Dependency: 'packrat' needs 'srfi1'."
+ fi
+
+ if use srfi27; then
+ # 'dev-scheme/bigloo srfi27' should be added in arch/amd64/package.use.mask
+ if use amd64; then
+ ewarn "srfi27 is known to only work on 32-bit architectures." \
+ "The USE is ignored on amd64."
+ elif ! use gmp; then
+ die "USE Dependency: 'srfi27' needs 'gmp'."
+ fi
+ fi
+
+ if use bglpkg && ! (use sqlite && use web); then
+ die "USE Dependency: 'bglpkg' needs both 'sqlite' and 'web'."
+ fi
+
+ java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ EPATCH_SOURCE="${WORKDIR}/patches" EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" epatch
+
+ # bglmem is not built according to the EFLAGS
+ # (which forces LDFLAGS, see emake below)
+ ebegin "Adding EFLAGS to BMEMFLAGS"
+ sed -i 's/BMEMFLAGS[^=]\+= /&$(EFLAGS) /' bde/bmem/Makefile
+ eend $?
+
+ # Removing bundled boehm-gc
+ rm -rf gc || die
+}
+
+src_configure() {
+ filter-flags -fomit-frame-pointer
+
+ local myconf=""
+
+ # Filter Zile emacs replacement. Bug #336717
+ if use emacs; then
+ myconf="--bee=full --emacs=${EMACS} --lispdir=${SITELISP}/${PN}"
+ else
+ myconf="--emacs=false"
+ fi
+
+ # dev-java/ibm-jdk-bin fails during configure, bug #331279
+ # api/crypto java tests show failures, I'm looking into it
+ if use java; then
+ sed -e "s/^\(jcflags=\)\(.*\)/\\1\"\\2 $(java-pkg_javac-args)\"/" \
+ -e 's/jcflags=$jcflags/jcflags="$jcflags"/'\
+ -i configure
+ myconf="${myconf}
+ --jvm=yes"
+ fi
+
+ # No pkglib/pkgcomp in IUSE, I don't see any need besides bglpkg
+ # One or the other could be added upon user request
+ if use bglpkg; then
+ myconf="${myconf}
+ --enable-bglpkg --enable-pkgcomp --enable-pkglib"
+ else
+ myconf="${myconf}
+ --disable-bglpkg --disable-pkgcomp --disable-pkglib"
+ fi
+
+ # srfi27 management
+ if use amd64; then
+ myconf="${myconf}
+ --disable-srfi27"
+ else
+ myconf="${myconf}
+ $(use_enable srfi27)"
+ fi
+
+ # Put every non quoted configure opt into myconf, for the einfo below
+ myconf="
+ --prefix=/usr
+ --libdir=/usr/$(get_libdir)
+ --benchmark=yes
+ --coflags=
+ --customgc=no
+ --sharedbde=no
+ --sharedcompiler=no
+ --strip=no
+ $(use debug && echo --debug)
+ ${myconf}
+ $(use_enable calendar)
+ $(use_enable crypto)
+ $(use_enable gmp)
+ $(use_enable gstreamer)
+ $(use_enable mail)
+ $(use_enable multimedia)
+ $(use_enable packrat)
+ $(use_enable sqlite)
+ $(use_enable srfi1)
+ $(use_enable ssl)
+ $(use_enable text)
+ $(use_enable threads)
+ $(use_enable web)
+"
+
+ einfo "Configuring bigloo with:" \
+ "--ldflags=\"${LDFLAGS}\" $(echo ${myconf} | sed 's/\n\t\t/ /g')"
+
+ # Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
+ # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
+ ./configure --ldflags="${LDFLAGS}" ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake EFLAGS='-ldopt "$(LDFLAGS)"' || die "emake failed"
+
+ if use emacs; then
+ einfo "Compiling bee..."
+ emake -j1 compile-bee EFLAGS='-ldopt "$(LDFLAGS)"' || die "compiling bee failed"
+ fi
+}
+
+# default thinks that target doesn't exist
+src_test() {
+ emake -j1 test || die "emake test failed"
+}
+
+src_install() {
+ # Makefile:671:install: install-progs install-docs
+ emake DESTDIR="${D}" install-progs || die "install failed"
+
+ if use emacs; then
+ einfo "Installing bee..."
+ emake DESTDIR="${D}" install-bee || die "install-bee failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ else
+ # Fix EMACS*=false in Makefile.config
+ sed -i 's:^\(EMACS=\).*$:\1:' "${D}"/usr/$(get_libdir)/bigloo/${BGL_RELEASE}/Makefile.config \
+ || die "dosed EMACS failed"
+ sed -i 's:^\(EMACSBRAND=\).*$:\1:' "${D}"/usr/$(get_libdir)/bigloo/${BGL_RELEASE}/Makefile.config \
+ || die "dosed EMACSBRAND failed"
+ fi
+
+ dodoc ChangeLog README || die "dodoc failed"
+ newdoc LICENSE COPYING || die "newdoc failed"
+
+ cd "${S}/manuals"
+ if use doc; then
+ dohtml -r . || die "dohtml failed"
+ doinfo *.info* || die "doinfo failed"
+ fi
+
+ for man in *.man; do
+ newman ${man} ${man/.man/.1} || die "newman ${man} ${man/.man/.1} failed"
+ done
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "In order to use the bee-mode, add"
+ elog " (require 'bmacs)"
+ elog "to your ~/.emacs file"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-scheme/bigloo/metadata.xml b/dev-scheme/bigloo/metadata.xml
index 9bf5a6a8f8ae..f5d2c5e98d0e 100644
--- a/dev-scheme/bigloo/metadata.xml
+++ b/dev-scheme/bigloo/metadata.xml
@@ -1,15 +1,36 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>scheme</herd>
-<longdescription>
-Bigloo is a Scheme implementation devoted to one goal: enabling Scheme
-based programming style where C(++) is usually required. Bigloo attempts
-to make Scheme practical by offering features usually presented by
-traditional programming languages but not offered by Scheme and functional
-programming. Bigloo compiles Scheme modules. It delivers small and fast
-stand alone binary executables. Bigloo enables full connections between
-Scheme and C programs, between Scheme and Java programs, and between
-Scheme and C# programs.
-</longdescription>
+ <herd>scheme</herd>
+ <longdescription>
+ Bigloo is a Scheme implementation devoted to one goal: enabling Scheme
+ based programming style where C(++) is usually required. Bigloo attempts
+ to make Scheme practical by offering features usually presented by
+ traditional programming languages but not offered by Scheme and functional
+ programming. Bigloo compiles Scheme modules. It delivers small and fast
+ stand alone binary executables. Bigloo enables full connections between
+ Scheme and C programs, between Scheme and Java programs, and between
+ Scheme and C# programs.
+ </longdescription>
+ <use>
+ <flag name="bglpkg">Build bglpkg binary, which can be use to access scmpkg servers</flag>
+ <flag name="calendar">Build the embedded library for calendar programming</flag>
+ <flag name="crypto">Build the embedded cryptographic library</flag>
+ <flag name="debug">Enable extra debug codepaths</flag>
+ <flag name="doc">Install Bigloo Manual (HTML docs of Bigloo and r5rs)</flag>
+ <flag name="emacs">Build and install the Bigloo Developement Environment for Emacs (aka bee-mode)</flag>
+ <flag name="gmp">Adds support for <pkg>dev-libs/gmp</pkg> (GNU MP library)</flag>
+ <flag name="gstreamer">Adds support for <pkg>media-libs/gstreamer</pkg></flag>
+ <flag name="java">Enable the JVM backend for the Bigloo compiler</flag>
+ <flag name="mail">Mail library for email management (e.g. maildir and imap support)</flag>
+ <flag name="multimedia">Build multimedia library (e.g. for managing images). Needed for <pkg>dev-scheme/hop</pkg></flag>
+ <flag name="packrat">Bigloo port of Tony Garnock-Jones' packrat parser</flag>
+ <flag name="sqlite">Use the system-wide <pkg>dev-db/sqlite</pkg></flag>
+ <flag name="srfi1">Build the srfi1 library: List library</flag>
+ <flag name="srfi27">Build the srfi27 library: Source of Random Bits (32bit-arch only)</flag>
+ <flag name="ssl">Adds support for SSL connections through <pkg>dev-libs/openssl</pkg></flag>
+ <flag name="threads">Enable thread support, it depends on <pkg>dev-libs/boehm-gc</pkg> built with threads use flag</flag>
+ <flag name="text">Library for dealing with text (e.g. BibTeX parser)</flag>
+ <flag name="web">Library for web programming (e.g. XML, CGI parsers). Needed for <pkg>dev-scheme/hop</pkg></flag>
+ </use>
</pkgmetadata>