summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-12-03 16:40:26 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-12-03 16:40:26 +0000
commit16a4f3f1baa121b717e26d33d840bf09cf106e67 (patch)
tree231d1ecebb5cf770c1ad888074998198ddd0a2dc /dev-scheme
parentRegression fix, default to -nolisten tcp again, thanks to amne for reporting. (diff)
downloadgentoo-2-16a4f3f1baa121b717e26d33d840bf09cf106e67.tar.gz
gentoo-2-16a4f3f1baa121b717e26d33d840bf09cf106e67.tar.bz2
gentoo-2-16a4f3f1baa121b717e26d33d840bf09cf106e67.zip
bump
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/bigloo/ChangeLog7
-rw-r--r--dev-scheme/bigloo/bigloo-3.0c.ebuild73
-rw-r--r--dev-scheme/bigloo/files/digest-bigloo-3.0c3
3 files changed, 82 insertions, 1 deletions
diff --git a/dev-scheme/bigloo/ChangeLog b/dev-scheme/bigloo/ChangeLog
index ef2963baf286..d7abc82c0791 100644
--- a/dev-scheme/bigloo/ChangeLog
+++ b/dev-scheme/bigloo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-scheme/bigloo
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/ChangeLog,v 1.21 2007/09/24 12:35:11 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/ChangeLog,v 1.22 2007/12/03 16:40:25 hkbst Exp $
+
+*bigloo-3.0c (03 Dec 2007)
+
+ 03 Dec 2007; Marijn Schouten <hkBst@gentoo.org> +bigloo-3.0c.ebuild:
+ bump
*bigloo-3.0b_p2 (24 Sep 2007)
diff --git a/dev-scheme/bigloo/bigloo-3.0c.ebuild b/dev-scheme/bigloo/bigloo-3.0c.ebuild
new file mode 100644
index 000000000000..b7afa589f7dc
--- /dev/null
+++ b/dev-scheme/bigloo/bigloo-3.0c.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.0c.ebuild,v 1.1 2007/12/03 16:40:25 hkbst Exp $
+
+inherit elisp-common multilib
+
+MY_P=${PN}${PV/_p/-}
+
+DESCRIPTION="Bigloo is a Scheme implementation."
+HOMEPAGE="http://www-sop.inria.fr/mimosa/fp/Bigloo/bigloo.html"
+SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Bigloo/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="emacs? ( virtual/emacs )
+ java? ( virtual/jdk )"
+
+S=${WORKDIR}/${MY_P%-*}
+
+SITEFILE="50bigloo-gentoo.el"
+
+IUSE="emacs java"
+# fullbee"
+
+src_compile() {
+ use emacs && elisp-comp etc/*.el
+
+ # Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
+ # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
+ ./configure \
+ $(use java && echo "--jvm=yes --java=$(java-config --java) --javac=$(java-config --javac)") \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --libdir=/usr/$(get_libdir) \
+ --docdir=/usr/share/doc/${PF} \
+ --benchmark=yes \
+ --sharedbde=no \
+ --sharedcompiler=no \
+ --coflags="" || die "configure failed"
+
+# --bee=$(if use fullbee; then echo full; else echo partial; fi) \
+
+ # parallel build is broken
+ emake -j1 || die "emake failed"
+}
+
+src_install () {
+# dodir /etc/env.d
+# echo "LDPATH=/usr/$(get_libdir)/bigloo/${PV}/" > ${D}/etc/env.d/25bigloo
+
+ # make the links created not point to DESTDIR, since that is only a temporary home
+ sed 's/ln -s $(DESTDIR)/ln -s /' -i Makefile.misc
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+
+ if use emacs; then
+ elisp-install ${PN} etc/*.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+# einfo "Compiling bee..."
+# emake compile-bee || die "compiling bee failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-scheme/bigloo/files/digest-bigloo-3.0c b/dev-scheme/bigloo/files/digest-bigloo-3.0c
new file mode 100644
index 000000000000..ee46d823e5fb
--- /dev/null
+++ b/dev-scheme/bigloo/files/digest-bigloo-3.0c
@@ -0,0 +1,3 @@
+MD5 11300e657ba37eb5c8a4847986980e18 bigloo3.0c.tar.gz 11771507
+RMD160 06fc038ede875f8833d95ddc607a3201a0d62a14 bigloo3.0c.tar.gz 11771507
+SHA256 53018455dbc728e05d901eb734f779a41387a6db8595fddb1430713f6705092b bigloo3.0c.tar.gz 11771507