summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2009-04-24 09:48:43 +0000
committerMarijn Schouten <hkbst@gentoo.org>2009-04-24 09:48:43 +0000
commitbe8ef119e570858cfb0f4e33590fce21a294a73d (patch)
treebf5341e23a947fe2e4bbd3638cf2f000bb30aba9 /dev-scheme/gambit
parentManifest fix, upstream seems to have changed xfc_foprocessor-4_3_0.zip (diff)
downloadgentoo-2-be8ef119e570858cfb0f4e33590fce21a294a73d.tar.gz
gentoo-2-be8ef119e570858cfb0f4e33590fce21a294a73d.tar.bz2
gentoo-2-be8ef119e570858cfb0f4e33590fce21a294a73d.zip
bump
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-scheme/gambit')
-rw-r--r--dev-scheme/gambit/ChangeLog7
-rw-r--r--dev-scheme/gambit/gambit-4.4.3.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-scheme/gambit/ChangeLog b/dev-scheme/gambit/ChangeLog
index e977ac6db62d..549e52af2eb1 100644
--- a/dev-scheme/gambit/ChangeLog
+++ b/dev-scheme/gambit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-scheme/gambit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.23 2009/03/16 21:14:49 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.24 2009/04/24 09:48:43 hkbst Exp $
+
+*gambit-4.4.3 (24 Apr 2009)
+
+ 24 Apr 2009; Marijn Schouten <hkBst@gentoo.org> +gambit-4.4.3.ebuild:
+ bump
*gambit-4.4.2 (16 Mar 2009)
diff --git a/dev-scheme/gambit/gambit-4.4.3.ebuild b/dev-scheme/gambit/gambit-4.4.3.ebuild
new file mode 100644
index 000000000000..67e39da4352d
--- /dev/null
+++ b/dev-scheme/gambit/gambit-4.4.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.4.3.ebuild,v 1.1 2009/04/24 09:48:43 hkbst Exp $
+
+inherit elisp-common
+
+MY_PN=gambc
+MY_PV=${PV//./_}
+MY_P=${MY_PN}-v${MY_PV}
+
+DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
+HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
+SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+#gsc is now Gambit Scheme Compiler and not ghostscript.
+#only app-text/ghostscript-gpl-8.64 has freed gsc yet.
+DEPEND="emacs? ( virtual/emacs )
+ !app-text/ghostscript-esp
+ !app-text/ghostscript-gnu
+ !<app-text/ghostscript-gpl-8.64"
+RDEPEND=""
+
+SITEFILE="50gambit-gentoo.el"
+
+S=${WORKDIR}/${MY_P} #-devel
+
+IUSE="emacs static"
+
+src_compile() {
+ econf $(use_enable !static shared) --docdir=/usr/share/doc/${PF} --enable-single-host --disable-absolute-shared-libs
+
+ emake bootstrap || die
+
+ if use emacs; then
+ elisp-compile misc/*.el || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}