summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2008-06-03 10:12:53 +0000
committerMarijn Schouten <hkbst@gentoo.org>2008-06-03 10:12:53 +0000
commit6d15325c285327f77cd21e0b3acbb1b77c8cf846 (patch)
treecad26ac08cce5c7bafdd629756ea78c9c0a08c88 /dev-scheme/bigloo
parentVersion bump (diff)
downloadgentoo-2-6d15325c285327f77cd21e0b3acbb1b77c8cf846.tar.gz
gentoo-2-6d15325c285327f77cd21e0b3acbb1b77c8cf846.tar.bz2
gentoo-2-6d15325c285327f77cd21e0b3acbb1b77c8cf846.zip
bump
(Portage version: 2.1.5.3)
Diffstat (limited to 'dev-scheme/bigloo')
-rw-r--r--dev-scheme/bigloo/ChangeLog10
-rw-r--r--dev-scheme/bigloo/bigloo-3.1a.ebuild75
2 files changed, 84 insertions, 1 deletions
diff --git a/dev-scheme/bigloo/ChangeLog b/dev-scheme/bigloo/ChangeLog
index 4d2145128f18..1e6abc5e2c25 100644
--- a/dev-scheme/bigloo/ChangeLog
+++ b/dev-scheme/bigloo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-scheme/bigloo
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/ChangeLog,v 1.25 2008/04/28 18:05:41 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/ChangeLog,v 1.26 2008/06/03 10:12:53 hkbst Exp $
+
+*bigloo-3.1a (03 Jun 2008)
+
+ 03 Jun 2008; Marijn Schouten <hkBst@gentoo.org> +bigloo-3.1a.ebuild:
+ bump:
+ * Support for an exact arithmetic (big numbers).
+ * A new version of the garbage collector (Boehm's collector v7.1).
+ * Major improvement in the implementation of the multi-threading.
28 Apr 2008; nixnut <nixnut@gentoo.org> bigloo-3.0c_p4.ebuild:
Stable on ppc wrt bug 219012
diff --git a/dev-scheme/bigloo/bigloo-3.1a.ebuild b/dev-scheme/bigloo/bigloo-3.1a.ebuild
new file mode 100644
index 000000000000..5b68761e168f
--- /dev/null
+++ b/dev-scheme/bigloo/bigloo-3.1a.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.1a.ebuild,v 1.1 2008/06/03 10:12:53 hkbst Exp $
+
+inherit elisp-common multilib
+
+MY_P=${PN}${PV/_p/-}
+MY_P=${MY_P/_alpha/-alpha}
+MY_P=${MY_P/_beta/-beta}
+
+DESCRIPTION="Bigloo is a Scheme implementation."
+HOMEPAGE="http://www-sop.inria.fr/mimosa/fp/Bigloo/bigloo.html"
+SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Bigloo/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="emacs? ( virtual/emacs )
+ java? ( virtual/jdk )"
+
+S=${WORKDIR}/${MY_P%-*}
+
+SITEFILE="50bigloo-gentoo.el"
+
+IUSE="emacs java"
+# fullbee"
+
+src_compile() {
+ use emacs && elisp-comp etc/*.el
+
+ # Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
+ # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
+ ./configure \
+ $(use java && echo "--jvm=yes --java=$(java-config --java) --javac=$(java-config --javac)") \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --libdir=/usr/$(get_libdir) \
+ --docdir=/usr/share/doc/${PF} \
+ --benchmark=yes \
+ --sharedbde=no \
+ --sharedcompiler=no \
+ --coflags="" || die "configure failed"
+
+# --bee=$(if use fullbee; then echo full; else echo partial; fi) \
+
+ # parallel build is broken
+ emake -j1 || die "emake failed"
+}
+
+src_install () {
+# dodir /etc/env.d
+# echo "LDPATH=/usr/$(get_libdir)/bigloo/${PV}/" > ${D}/etc/env.d/25bigloo
+
+ # make the links created not point to DESTDIR, since that is only a temporary home
+ sed 's/ln -s $(DESTDIR)/ln -s /' -i Makefile.misc
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+
+ if use emacs; then
+ elisp-install ${PN} etc/*.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+# einfo "Compiling bee..."
+# emake compile-bee || die "compiling bee failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}