summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-07-19 07:25:57 +0000
committerHans de Graaff <graaff@gentoo.org>2011-07-19 07:25:57 +0000
commitfaf2c33807a6dd1647096933c30834ebc02b883d (patch)
tree304708c033e37434b4b7c88a62d712bed5693ca8 /dev-ruby
parentInitial import. New dependency of dev-util/cucumber-rails. (diff)
downloadgentoo-2-faf2c33807a6dd1647096933c30834ebc02b883d.tar.gz
gentoo-2-faf2c33807a6dd1647096933c30834ebc02b883d.tar.bz2
gentoo-2-faf2c33807a6dd1647096933c30834ebc02b883d.zip
Version bump. Drop x86 keyword, bug 375153.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/oauth2/ChangeLog7
-rw-r--r--dev-ruby/oauth2/oauth2-0.4.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/oauth2/ChangeLog b/dev-ruby/oauth2/ChangeLog
index 96e7d162ad5f..639d95ba2625 100644
--- a/dev-ruby/oauth2/ChangeLog
+++ b/dev-ruby/oauth2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/oauth2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.8 2011/01/02 13:45:07 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.9 2011/07/19 07:25:57 graaff Exp $
+
+*oauth2-0.4.1 (19 Jul 2011)
+
+ 19 Jul 2011; Hans de Graaff <graaff@gentoo.org> +oauth2-0.4.1.ebuild:
+ Version bump. Drop x86 keyword, bug 375153.
02 Jan 2011; Hans de Graaff <graaff@gentoo.org> -oauth2-0.0.10.ebuild:
Remove old version.
diff --git a/dev-ruby/oauth2/oauth2-0.4.1.ebuild b/dev-ruby/oauth2/oauth2-0.4.1.ebuild
new file mode 100644
index 000000000000..183faf8b5db7
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-0.4.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.4.1.ebuild,v 1.1 2011/07/19 07:25:57 graaff Exp $
+
+EAPI="2"
+
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="rerdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
+HOMEPAGE="http://github.com/intridea/oauth2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/faraday-0.6.1 >=dev-ruby/multi_json-0.0.5"
+ruby_add_bdepend test ">=dev-ruby/rspec-2.5.0:2"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e "/[Bb]undler/d" -e "/[Ss]imple[Cc]ov/d" spec/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S rspec spec || die
+}