summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-12-16 09:34:08 +0000
committerHans de Graaff <graaff@gentoo.org>2012-12-16 09:34:08 +0000
commitece21f89c67160dc87b68b9f8d2b1da1c6c70ccb (patch)
treeb6eb088959b9f29e3aed2ffca71380f207fb555f /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-ece21f89c67160dc87b68b9f8d2b1da1c6c70ccb.tar.gz
gentoo-2-ece21f89c67160dc87b68b9f8d2b1da1c6c70ccb.tar.bz2
gentoo-2-ece21f89c67160dc87b68b9f8d2b1da1c6c70ccb.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/configliere/ChangeLog7
-rw-r--r--dev-ruby/configliere/configliere-0.4.18.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-ruby/configliere/ChangeLog b/dev-ruby/configliere/ChangeLog
index 2b7dd9e84a5a..87c000de1011 100644
--- a/dev-ruby/configliere/ChangeLog
+++ b/dev-ruby/configliere/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/configliere
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/configliere/ChangeLog,v 1.1 2012/09/29 06:17:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/configliere/ChangeLog,v 1.2 2012/12/16 09:34:08 graaff Exp $
+
+*configliere-0.4.18 (16 Dec 2012)
+
+ 16 Dec 2012; Hans de Graaff <graaff@gentoo.org> +configliere-0.4.18.ebuild:
+ Version bump.
*configliere-0.4.17 (29 Sep 2012)
diff --git a/dev-ruby/configliere/configliere-0.4.18.ebuild b/dev-ruby/configliere/configliere-0.4.18.ebuild
new file mode 100644
index 000000000000..011b85edebd4
--- /dev/null
+++ b/dev-ruby/configliere/configliere-0.4.18.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/configliere/configliere-0.4.18.ebuild,v 1.1 2012/12/16 09:34:08 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.textile README.textile FEATURES.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Settings manager for Ruby scripts"
+HOMEPAGE="https://github.com/infochimps-labs/configliere"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/highline-1.5.2
+ >=dev-ruby/multi_json-1.1"
+
+RUBY_PATCHES=( ${PN}-0.4.17-nobundler.patch )
+
+all_ruby_prepare() {
+ rm Gemfile* || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}