summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-05-07 05:24:26 +0000
committerHans de Graaff <graaff@gentoo.org>2013-05-07 05:24:26 +0000
commite6af313762df53f28ddae9dcb88b6670fc6e7dd3 (patch)
tree2dcc63f2e3c42903cbc3ee382377d1b12136f4fe /dev-ruby
parentFix for Prefix, bug #468786 (diff)
downloadgentoo-2-e6af313762df53f28ddae9dcb88b6670fc6e7dd3.tar.gz
gentoo-2-e6af313762df53f28ddae9dcb88b6670fc6e7dd3.tar.bz2
gentoo-2-e6af313762df53f28ddae9dcb88b6670fc6e7dd3.zip
Version bump.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/minitest/ChangeLog7
-rw-r--r--dev-ruby/minitest/minitest-4.7.4.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-ruby/minitest/ChangeLog b/dev-ruby/minitest/ChangeLog
index 782cbe3514ef..f8a269ea08b2 100644
--- a/dev-ruby/minitest/ChangeLog
+++ b/dev-ruby/minitest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/minitest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.110 2013/04/14 11:40:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.111 2013/05/07 05:24:26 graaff Exp $
+
+*minitest-4.7.4 (07 May 2013)
+
+ 07 May 2013; Hans de Graaff <graaff@gentoo.org> +minitest-4.7.4.ebuild:
+ Version bump.
14 Apr 2013; Agostino Sarubbo <ago@gentoo.org> minitest-4.5.0.ebuild:
Stable for sh, wrt bug #464512
diff --git a/dev-ruby/minitest/minitest-4.7.4.ebuild b/dev-ruby/minitest/minitest-4.7.4.ebuild
new file mode 100644
index 000000000000..2421df7c6a26
--- /dev/null
+++ b/dev-ruby/minitest/minitest-4.7.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/minitest-4.7.4.ebuild,v 1.1 2013/05/07 05:24:26 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="minitest/unit is a small and fast replacement for ruby's huge and slow test/unit."
+HOMEPAGE="https://github.com/seattlerb/minitest"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/hoe dev-ruby/rdoc )"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Remove failing tests. Upstream claims that these are all
+ # bugs in jruby. By removing the failing tests we can at
+ # least run the remainder. See bug 321055 for details.
+ rm -f test/minitest/test_minitest_unit.rb || die
+ # Also add minitest_mock since there are jruby-specific failures.
+ rm -f test/minitest/test_minitest_mock.rb || die
+
+ # Our jruby throws a slightly different error
+ sed -i -e 's/not :xxx/not \\"xxx\\"/' test/minitest/test_minitest_spec.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ # JRuby 1.6.x has threading bugs that are triggered by
+ # minitests 4's new parallel test support. Should be fixed
+ # in JRuby 1.7.
+ N=1 ${RUBY} -Ilib:bin:test:. -S testrb test || die
+ ;;
+ *)
+ ${RUBY} -Ilib:bin:test:. -S testrb test || die
+ ;;
+ esac
+}