summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-07-30 19:38:31 +0000
committerHans de Graaff <graaff@gentoo.org>2012-07-30 19:38:31 +0000
commite40e26e9df2368d5515c92589a6ca46dba027856 (patch)
treead5c67203aaa0ac6613d501dc00389a5720fd869 /dev-ruby
parentold (diff)
downloadgentoo-2-e40e26e9df2368d5515c92589a6ca46dba027856.tar.gz
gentoo-2-e40e26e9df2368d5515c92589a6ca46dba027856.tar.bz2
gentoo-2-e40e26e9df2368d5515c92589a6ca46dba027856.zip
Version bump, fixes bug 422939.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/bundler/ChangeLog7
-rw-r--r--dev-ruby/bundler/bundler-1.1.5.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-ruby/bundler/ChangeLog b/dev-ruby/bundler/ChangeLog
index 8ef3e824555c..6b4fc724b583 100644
--- a/dev-ruby/bundler/ChangeLog
+++ b/dev-ruby/bundler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/bundler
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.39 2012/06/18 06:12:30 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.40 2012/07/30 19:38:31 graaff Exp $
+
+*bundler-1.1.5 (30 Jul 2012)
+
+ 30 Jul 2012; Hans de Graaff <graaff@gentoo.org> +bundler-1.1.5.ebuild:
+ Version bump, fixes bug 422939.
18 Jun 2012; Hans de Graaff <graaff@gentoo.org> -bundler-1.0.21.ebuild:
Remove old version.
diff --git a/dev-ruby/bundler/bundler-1.1.5.ebuild b/dev-ruby/bundler/bundler-1.1.5.ebuild
new file mode 100644
index 000000000000..d8be8f79e501
--- /dev/null
+++ b/dev-ruby/bundler/bundler-1.1.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/bundler-1.1.5.ebuild,v 1.1 2012/07/30 19:38:31 graaff Exp $
+
+EAPI=2
+
+# jruby → needs to be tested because jruby-1.5.1 fails in multiple
+# ways unrelated to this package.
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ISSUES.md UPGRADING.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="http://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend virtual/rubygems
+
+ruby_add_bdepend "test? ( app-text/ronn )"
+
+RDEPEND="${RDEPEND}
+ dev-vcs/git"
+DEPEND="${DEPEND}
+ test? ( dev-vcs/git )"
+
+all_ruby_prepare() {
+ # Bundler only supports running the specs from git:
+ # http://github.com/carlhuda/bundler/issues/issue/738
+ sed -i -e '751s/should/should_not/' spec/runtime/setup_spec.rb || die
+
+ # Fails randomly and no clear cause can be found. Might be related
+ # to bug 346357. This was broken in previous releases without a
+ # failing spec, so patch out this spec for now since it is not a
+ # regression.
+ sed -i -e '/works when you bundle exec bundle/,/^ end/ s:^:#:' spec/install/deploy_spec.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19)
+ # Account for different wording in ruby 1.9.3.
+# sed -i -e 's/no such file to load/cannot load such file/' spec/runtime/require_spec.rb spec/install/gems/groups_spec.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}