summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-24 10:23:13 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-24 10:23:13 +0000
commitdea798a13dfd528c51eeed9d7b0995f1ae7e8b12 (patch)
treeb80aefe022f6757e6c9ebbdaee1915d31efd270f /dev-ruby
parentforgot an item in todo (diff)
downloadgentoo-2-dea798a13dfd528c51eeed9d7b0995f1ae7e8b12.tar.gz
gentoo-2-dea798a13dfd528c51eeed9d7b0995f1ae7e8b12.tar.bz2
gentoo-2-dea798a13dfd528c51eeed9d7b0995f1ae7e8b12.zip
touchups
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/soap4r/soap4r-1.4.8.1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-ruby/soap4r/soap4r-1.4.8.1.ebuild b/dev-ruby/soap4r/soap4r-1.4.8.1.ebuild
index 1f20cff276de..d5626ffef206 100644
--- a/dev-ruby/soap4r/soap4r-1.4.8.1.ebuild
+++ b/dev-ruby/soap4r/soap4r-1.4.8.1.ebuild
@@ -1,24 +1,27 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/soap4r/soap4r-1.4.8.1.ebuild,v 1.1 2003/04/23 15:55:02 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/soap4r/soap4r-1.4.8.1.ebuild,v 1.2 2003/04/24 10:23:13 vapier Exp $
-MY_PV=`echo ${PV} | tr . _`
-MY_P="${PN}-${MY_PV}"
-DESCRIPTION="This is a sample skeleton ebuild file"
+MY_PV=${PV//./_}
+MY_P=${PN}-${MY_PV}
+DESCRIPTION="an implementation of SOAP 1.1"
HOMEPAGE="http://rrr.jin.gr.jp/rwiki?cmd=view;name=soap4r"
SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/contrib/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
+
DEPEND=">=dev-lang/ruby-1.8
>=dev-ruby/devel-logger-1.0.1
>=dev-ruby/http-access2-0j
>=dev-ruby/rexml-2.5.3
>=dev-ruby/uconv-0.4.10"
+
S=${WORKDIR}/${MY_P}
src_install() {
cp install.rb install.rb.orig
sed -e "s:^DSTPATH = :DSTPATH = \"${D}\" + \"/\" + :" install.rb.orig > install.rb
- ruby install.rb
+ ruby install.rb || die
}