summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-15 21:41:12 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-15 21:41:12 +0000
commitde6808265d8c06d39c6f3fa71d0ef45c94e3899b (patch)
treeb113d6eaa75c815b88805f98bc02af99d0af2d1b /dev-ruby
parentadded warning, removed unnecessary quotes (diff)
downloadgentoo-2-de6808265d8c06d39c6f3fa71d0ef45c94e3899b.tar.gz
gentoo-2-de6808265d8c06d39c6f3fa71d0ef45c94e3899b.tar.bz2
gentoo-2-de6808265d8c06d39c6f3fa71d0ef45c94e3899b.zip
Add patch from upstream git to fix tests with Ruby 1.9.2 (closes bug #332879).
(Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/bacon/ChangeLog9
-rw-r--r--dev-ruby/bacon/bacon-1.1.0-r1.ebuild6
-rw-r--r--dev-ruby/bacon/files/bacon-1.1.0+ruby-1.9.2.patch21
3 files changed, 32 insertions, 4 deletions
diff --git a/dev-ruby/bacon/ChangeLog b/dev-ruby/bacon/ChangeLog
index 1e2ea9140427..03d724b6dcc2 100644
--- a/dev-ruby/bacon/ChangeLog
+++ b/dev-ruby/bacon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/bacon
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bacon/ChangeLog,v 1.4 2010/10/02 17:40:48 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bacon/ChangeLog,v 1.5 2011/02/15 21:41:12 flameeyes Exp $
+
+ 15 Feb 2011; Diego E. Pettenò <flameeyes@gentoo.org> bacon-1.1.0-r1.ebuild,
+ +files/bacon-1.1.0+ruby-1.9.2.patch:
+ Add patch from upstream git to fix tests with Ruby 1.9.2 (closes bug
+ #332879).
02 Oct 2010; Raúl Porcel <armin76@gentoo.org> bacon-1.1.0-r1.ebuild:
Add ~ia64/~sparc wrt #338013
diff --git a/dev-ruby/bacon/bacon-1.1.0-r1.ebuild b/dev-ruby/bacon/bacon-1.1.0-r1.ebuild
index 8765a1ba8a86..886bed6f00f8 100644
--- a/dev-ruby/bacon/bacon-1.1.0-r1.ebuild
+++ b/dev-ruby/bacon/bacon-1.1.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bacon/bacon-1.1.0-r1.ebuild,v 1.2 2010/10/02 17:40:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bacon/bacon-1.1.0-r1.ebuild,v 1.3 2011/02/15 21:41:12 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18 ruby19 ree18 jruby"
@@ -17,3 +17,5 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
IUSE=""
+
+RUBY_PATCHES="${FILESDIR}/${P}+ruby-1.9.2.patch"
diff --git a/dev-ruby/bacon/files/bacon-1.1.0+ruby-1.9.2.patch b/dev-ruby/bacon/files/bacon-1.1.0+ruby-1.9.2.patch
new file mode 100644
index 000000000000..36f7c7919738
--- /dev/null
+++ b/dev-ruby/bacon/files/bacon-1.1.0+ruby-1.9.2.patch
@@ -0,0 +1,21 @@
+Filtered from upstream commit bc0df844c7b20f30e456c493e086a9a871471550
+Author: Eloy Duran <eloy.de.enige@gmail.com>
+Date: Mon Aug 31 23:36:56 2009 +0200
+
+--- a/test/spec_bacon.rb
++++ b/test/spec_bacon.rb
+@@ -1,5 +1,5 @@
+ $-w,w = nil, $-w
+-require File.join(File.dirname(__FILE__), '../lib/bacon')
++require File.expand_path('../../lib/bacon', __FILE__)
+ $-w = w
+
+ # Hooray for meta-testing.
+--- a/test/spec_should.rb
++++ b/test/spec_should.rb
+@@ -1,4 +1,4 @@
+-require File.join(File.dirname(__FILE__), '../lib/bacon')
++require File.expand_path('../../lib/bacon', __FILE__)
+
+ describe "#should shortcut for #it('should')" do
+