summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-05-11 05:55:12 +0000
committerHans de Graaff <graaff@gentoo.org>2012-05-11 05:55:12 +0000
commitdd6ce5bf87636b6f14cf2f6949a3f951fcd0c01e (patch)
treeacf696edae229a57084be918dd82682ed390e811 /dev-ruby
parentmarked x86 per bug 415379 (diff)
downloadgentoo-2-dd6ce5bf87636b6f14cf2f6949a3f951fcd0c01e.tar.gz
gentoo-2-dd6ce5bf87636b6f14cf2f6949a3f951fcd0c01e.tar.bz2
gentoo-2-dd6ce5bf87636b6f14cf2f6949a3f951fcd0c01e.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/capistrano/ChangeLog7
-rw-r--r--dev-ruby/capistrano/capistrano-2.12.0.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ruby/capistrano/ChangeLog b/dev-ruby/capistrano/ChangeLog
index acb6208ce21c..13749bd4cf5b 100644
--- a/dev-ruby/capistrano/ChangeLog
+++ b/dev-ruby/capistrano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/capistrano
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.76 2012/05/01 18:24:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.77 2012/05/11 05:55:12 graaff Exp $
+
+*capistrano-2.12.0 (11 May 2012)
+
+ 11 May 2012; Hans de Graaff <graaff@gentoo.org> +capistrano-2.12.0.ebuild:
+ Version bump.
01 May 2012; Raúl Porcel <armin76@gentoo.org> capistrano-2.5.20.ebuild,
capistrano-2.9.0.ebuild:
diff --git a/dev-ruby/capistrano/capistrano-2.12.0.ebuild b/dev-ruby/capistrano/capistrano-2.12.0.ebuild
new file mode 100644
index 000000000000..941bfd91edd1
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-2.12.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-2.12.0.ebuild,v 1.1 2012/05/11 05:55:12 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.mdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capify.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.0.14
+ >=dev-ruby/net-sftp-2.0.2
+ >=dev-ruby/net-scp-1.0.2
+ >=dev-ruby/net-ssh-gateway-1.1.0
+ >=dev-ruby/highline-1.2.7"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile test/utils.rb || die
+# sed -i -e '/ruby-debug/ s:^:#:' test/utils.rb || die
+
+ # Avoid copy strategy tests since these fail in some cases due to
+ # complicated (aka unknown) interactions with other parts of the
+ # test suite.
+ rm test/deploy/strategy/copy_test.rb || die
+}