summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-07-31 14:16:30 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-07-31 14:16:30 +0000
commitdce042e201345901ec7611ab48688b74da53a575 (patch)
tree505226d8eb999f90ed779fc0963121806bf4fc26 /dev-ruby
parentVersion bump (diff)
downloadgentoo-2-dce042e201345901ec7611ab48688b74da53a575.tar.gz
gentoo-2-dce042e201345901ec7611ab48688b74da53a575.tar.bz2
gentoo-2-dce042e201345901ec7611ab48688b74da53a575.zip
Version bump
(Portage version: 2.1.13.2/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/temple/ChangeLog7
-rw-r--r--dev-ruby/temple/temple-0.6.6.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-ruby/temple/ChangeLog b/dev-ruby/temple/ChangeLog
index 8420f195d077..b3278fcddaca 100644
--- a/dev-ruby/temple/ChangeLog
+++ b/dev-ruby/temple/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/temple
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/temple/ChangeLog,v 1.9 2013/05/30 06:00:36 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/temple/ChangeLog,v 1.10 2013/07/31 14:16:30 mrueg Exp $
+
+*temple-0.6.6 (31 Jul 2013)
+
+ 31 Jul 2013; Manuel Rüger <mrueg@gentoo.org> +temple-0.6.6.ebuild:
+ Version bump
*temple-0.6.5 (30 May 2013)
diff --git a/dev-ruby/temple/temple-0.6.6.ebuild b/dev-ruby/temple/temple-0.6.6.ebuild
new file mode 100644
index 000000000000..54c305214386
--- /dev/null
+++ b/dev-ruby/temple/temple-0.6.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/temple/temple-0.6.6.ebuild,v 1.1 2013/07/31 14:16:30 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="An abstraction and a framework for compiling templates to pure Ruby."
+HOMEPAGE="http://github.com/judofyr/temple"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/tilt )"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Ilib -Itest --automatic --quiet || die
+}