summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-06-29 05:38:23 +0000
committerHans de Graaff <graaff@gentoo.org>2015-06-29 05:38:23 +0000
commitd3990cb46fa045c52b519140e0afc0be3892d415 (patch)
tree31a882d93734af96def72cae41afea1cf4d1ade1 /dev-ruby
parentFix comment in conf file and revbump to push it out, bug #553296. (diff)
downloadgentoo-2-d3990cb46fa045c52b519140e0afc0be3892d415.tar.gz
gentoo-2-d3990cb46fa045c52b519140e0afc0be3892d415.tar.bz2
gentoo-2-d3990cb46fa045c52b519140e0afc0be3892d415.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/bundler/ChangeLog7
-rw-r--r--dev-ruby/bundler/bundler-1.9.10.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/dev-ruby/bundler/ChangeLog b/dev-ruby/bundler/ChangeLog
index 6006e0014831..e0d12daba1dc 100644
--- a/dev-ruby/bundler/ChangeLog
+++ b/dev-ruby/bundler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/bundler
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.98 2015/06/21 18:07:36 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.99 2015/06/29 05:38:23 graaff Exp $
+
+*bundler-1.9.10 (29 Jun 2015)
+
+ 29 Jun 2015; Hans de Graaff <graaff@gentoo.org> +bundler-1.9.10.ebuild:
+ Version bump.
21 Jun 2015; Mikle Kolyada <zlogene@gentoo.org> bundler-1.7.13.ebuild:
alpha stable wrt bug #550314
diff --git a/dev-ruby/bundler/bundler-1.9.10.ebuild b/dev-ruby/bundler/bundler-1.9.10.ebuild
new file mode 100644
index 000000000000..0f886b065a72
--- /dev/null
+++ b/dev-ruby/bundler/bundler-1.9.10.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/bundler-1.9.10.ebuild,v 1.1 2015/06/29 05:38:23 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+#RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ISSUES.md UPGRADING.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="https://github.com/carlhuda/bundler"
+SRC_URI="https://github.com/carlhuda/bundler/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend virtual/rubygems
+
+ruby_add_bdepend "doc? ( app-text/ronn )"
+
+# ruby_add_bdepend "test? ( app-text/ronn )"
+
+# The specs require a number of gems to be installed in a temporary
+# directory, but this requires network access. All tests should still
+# pass with network access.
+RESTRICT="test"
+
+RDEPEND+=" dev-vcs/git"
+
+all_ruby_prepare() {
+ # Bundler only supports running the specs from git:
+ # https://github.com/carlhuda/bundler/issues/issue/738
+ sed -i -e '/when Bundler is bundled/,/^ end/ s:^:#:' spec/runtime/setup_spec.rb || die
+
+ # Fails randomly and no clear cause can be found. Might be related
+ # to bug 346357. This was broken in previous releases without a
+ # failing spec, so patch out this spec for now since it is not a
+ # regression.
+ sed -i -e '/works when you bundle exec bundle/,/^ end/ s:^:#:' spec/install/deploy_spec.rb || die
+
+ # Remove unneeded git dependency from gemspec, which we need to use
+ # for bug 491826
+ sed -i -e '/files/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid specs that are not compatible with all rspec versions.
+ sed -e '/has no malformed whitespace/,/^ end/ s:^:#:' \
+ -e '/uses double-quotes consistently/,/^ end/ s:^:#:' \
+ -i spec/quality_spec.rb || die
+
+ # Avoid spec failing with git 2.0.
+ sed -i -e '/on releasing/,/^ end/ s:^:#:' spec/bundler/gem_helper_spec.rb || die
+}
+
+each_ruby_compile() {
+ if use doc ; then
+ ${RUBY} -S rake man:build || die
+ fi
+}