summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-04 18:51:26 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-04 18:51:26 +0000
commitd0da2058ee65355ec7830a817c0962426fc052fe (patch)
tree4ca9e736737703c284a3dfa1a03f08d279bbe172 /dev-ruby
parentVersion bump, drop old (diff)
downloadgentoo-2-d0da2058ee65355ec7830a817c0962426fc052fe.tar.gz
gentoo-2-d0da2058ee65355ec7830a817c0962426fc052fe.tar.bz2
gentoo-2-d0da2058ee65355ec7830a817c0962426fc052fe.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/thread_safe/ChangeLog7
-rw-r--r--dev-ruby/thread_safe/thread_safe-0.1.3-r1.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-ruby/thread_safe/ChangeLog b/dev-ruby/thread_safe/ChangeLog
index 5430a9625fc3..799d46d051cf 100644
--- a/dev-ruby/thread_safe/ChangeLog
+++ b/dev-ruby/thread_safe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/thread_safe
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thread_safe/ChangeLog,v 1.4 2013/09/11 13:02:11 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thread_safe/ChangeLog,v 1.5 2013/10/04 18:51:26 mrueg Exp $
+
+*thread_safe-0.1.3-r1 (04 Oct 2013)
+
+ 04 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +thread_safe-0.1.3-r1.ebuild:
+ Add ruby20 target.
*thread_safe-0.1.3 (11 Sep 2013)
diff --git a/dev-ruby/thread_safe/thread_safe-0.1.3-r1.ebuild b/dev-ruby/thread_safe/thread_safe-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..5afb29d9551c
--- /dev/null
+++ b/dev-ruby/thread_safe/thread_safe-0.1.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thread_safe/thread_safe-0.1.3-r1.ebuild,v 1.1 2013/10/04 18:51:26 mrueg Exp $
+
+EAPI=5
+# jruby → there is code for this in ext but that requires compiling java.
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of thread-safe versions of common core Ruby classes"
+HOMEPAGE="https://github.com/headius/thread_safe"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/atomic"
+
+each_ruby_prepare(){
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+}