summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-18 09:11:54 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-18 09:11:54 +0000
commitc9c302b77bdb36bd012728fca130351feafef336 (patch)
tree88d3612ba9cb5398a6359b1ebe78c9afe77ac9b1 /dev-ruby
parentDrop bundled libstdc++.so.6 #393125 (diff)
downloadgentoo-2-c9c302b77bdb36bd012728fca130351feafef336.tar.gz
gentoo-2-c9c302b77bdb36bd012728fca130351feafef336.tar.bz2
gentoo-2-c9c302b77bdb36bd012728fca130351feafef336.zip
Version bump. Add missing test dependency and fix test task.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ffi/ChangeLog7
-rw-r--r--dev-ruby/ffi/ffi-1.0.11.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-ruby/ffi/ChangeLog b/dev-ruby/ffi/ChangeLog
index 29e4b6c7dea5..6eeaa607bea6 100644
--- a/dev-ruby/ffi/ChangeLog
+++ b/dev-ruby/ffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ffi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ChangeLog,v 1.27 2011/12/17 18:31:36 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ChangeLog,v 1.28 2011/12/18 09:11:54 graaff Exp $
+
+*ffi-1.0.11 (18 Dec 2011)
+
+ 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ffi-1.0.11.ebuild:
+ Version bump. Add missing test dependency and fix test task.
17 Dec 2011; Raúl Porcel <armin76@gentoo.org> ffi-1.0.9.ebuild,
ffi-1.0.9-r1.ebuild, ffi-1.0.10.ebuild:
diff --git a/dev-ruby/ffi/ffi-1.0.11.ebuild b/dev-ruby/ffi/ffi-1.0.11.ebuild
new file mode 100644
index 000000000000..f3325e433272
--- /dev/null
+++ b/dev-ruby/ffi/ffi-1.0.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ffi-1.0.11.ebuild,v 1.1 2011/12/18 09:11:54 graaff Exp $
+
+EAPI=4
+
+# jruby → unneeded, this is part of the standard JRuby distribution, and
+# would just install a dummy.
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="specs"
+
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension for programmatically loading dynamic libraries"
+HOMEPAGE="http://wiki.github.com/ffi/ffi"
+
+SRC_URI="http://github.com/${PN}/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
+RUBY_S="${PN}-${PN}-*"
+
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+
+RDEPEND="${RDEPEND} virtual/libffi"
+DEPEND="${DEPEND} virtual/libffi"
+
+ruby_add_bdepend "dev-ruby/rake-compiler
+ test? ( dev-ruby/rspec:2 )"
+
+ruby_add_rdepend "virtual/ruby-threads"
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "compile failed"
+ ${RUBY} -S rake -f gen/Rakefile || die "types.conf generation failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc samples/*
+}