summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-09 01:57:12 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-09 01:57:12 +0000
commitc558b11acf2c935da488594322dd61c6d887cac0 (patch)
treebc5c4edd28002c4d5d9e605274fff323af55b23d /dev-ruby
parentAdd ruby20 target. (diff)
downloadgentoo-2-c558b11acf2c935da488594322dd61c6d887cac0.tar.gz
gentoo-2-c558b11acf2c935da488594322dd61c6d887cac0.tar.bz2
gentoo-2-c558b11acf2c935da488594322dd61c6d887cac0.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/RubyInline/ChangeLog7
-rw-r--r--dev-ruby/RubyInline/RubyInline-3.12.2-r1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/RubyInline/ChangeLog b/dev-ruby/RubyInline/ChangeLog
index d890e85e5f29..606d34499e60 100644
--- a/dev-ruby/RubyInline/ChangeLog
+++ b/dev-ruby/RubyInline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/RubyInline
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/RubyInline/ChangeLog,v 1.17 2013/09/09 02:46:58 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/RubyInline/ChangeLog,v 1.18 2013/10/09 01:57:12 mrueg Exp $
+
+*RubyInline-3.12.2-r1 (09 Oct 2013)
+
+ 09 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +RubyInline-3.12.2-r1.ebuild:
+ Add ruby20 target.
09 Sep 2013; Manuel Rüger <mrueg@gentoo.org> -RubyInline-3.8.6.ebuild,
-files/ruby-inline-3.11.0-gentoo.patch, -files/ruby-inline-3.8.4-gentoo.patch,
diff --git a/dev-ruby/RubyInline/RubyInline-3.12.2-r1.ebuild b/dev-ruby/RubyInline/RubyInline-3.12.2-r1.ebuild
new file mode 100644
index 000000000000..6730eda51a52
--- /dev/null
+++ b/dev-ruby/RubyInline/RubyInline-3.12.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/RubyInline/RubyInline-3.12.2-r1.ebuild,v 1.1 2013/10/09 01:57:12 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows to embed C/C++ in Ruby code"
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/RubyInline/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/zentest"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ virtual/ruby-minitest
+ )"
+
+RUBY_PATCHES=(
+ ruby-inline-3.12.2-gentoo.patch
+ ruby-inline-3.11.1-ldflags.patch
+)
+
+all_ruby_prepare() {
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc example.rb example2.rb demo/*.rb
+}